Tagged Questions

Preparation of components or SharePoint itself for use.

learn more… | top users | synonyms

0
votes
1answer
20 views

Deploying Web-Solutions “deprececated”?

I am currently in contact with an administrator who has to deploy a feature-solution from another dev. The solution is deployed globally, which the admin does not like, cause it only is needed for ...
0
votes
0answers
10 views

Issue when *directly* deploying a Solution on SharePoint 2013

I have been having trouble deploying a WSP file (a solution containing visual web parts and [primarily] core backend logic) to our SharePoint 2013 server. Deploying through Visual Studio works ...
1
vote
1answer
30 views

Deploying workflows from Visual Studio problems

I recently ran into a problem while trying to deploy WSP containing workflow 2013 SPIs. Visual Studio 2012 couldn't delete workflows and workflow associations during deployment process.
1
vote
1answer
27 views

SharePoint is not installed error in Visual Studio 2013

I have a solution I'm keeping all my specific projects inside. I can easily deploy existing one and even add new Visual Web Parts and redeploy. But when trying to add a new project I get the error ...
0
votes
1answer
17 views

Automating Sharepoint Foundation 2013 Installation and Deployment of Project

I'm a long time software developer with absolutely no experience in Sharepoint. I have just joined a new company and I was asked by the team leader to create an installer for Sharepoint Foundation ...
1
vote
2answers
67 views

“The activity named 'WorkflowXaml_GUID' from scope was not found” when deploying SP 2013 Workflow

Ok. I have been getting this issue once in a while and I need to know how to fix it. Scenario: I wanted some custom actions performed on my workflow. So created an activity library and a class that ...
2
votes
1answer
46 views

Anonymous Authentication doesn't work in SharePoint 2010 Extended application

Am new to SharePoint, Am not a SP developer, i do only administration. My question is very simple and straight regarding configuring a SP application in SP2010. I created a default application with ...
0
votes
0answers
38 views

Deployed .WSP via powershell, but now jquery wont work

I followed the steps in This article to deploy my solution, which uses some jQuery. however now that I've deployed it, it doesn't work. what can I do to get this working again? It worked perfect in my ...
1
vote
0answers
22 views

Update long running workflow in SP 2013

I have a question concerning how to manage installation of new versions of workflow features, in case when there are already running instances. It seems on my development machine that after installing ...
0
votes
0answers
33 views

Auto Create Folders When deploying module

I'm trying building some modules on my solution for Sharepoint deployment from visual studio. So the main goal is deploy css, scripts files into the style library. So I added the feature module on vs ...
0
votes
1answer
25 views

Move Web Sites and Site Collection from Test to Production without access to the servers

We have two environments for our SharePoint 2010 installation: Test environment and Prod environment. We are not coding or doing heavy customizations and we are covering our needs somehow with ...
0
votes
2answers
76 views

how to deploy a page with XML in Visual Studio that having Friendly Url?

how to deploy a page with XML in Visual Studio that having Friendly Url? Does anyone knows how can I do that? example what not have Friendly Url <File Path="Home.aspx" Url="Home.aspx" ...
0
votes
1answer
27 views

Production SharePoint 2013 environment with only one server?

I'm currently running a small SharePoint 2010 farm with two servers. The first is a dedicated Microsoft SQL server, and the second is my SharePoint server running my web application and Central ...
0
votes
0answers
25 views

Error occurred in deployment step 'Activate Features': The file Image Library/KeynoteBackdrop1.png has been modified by i:0#.w|xyz\harsh.dave

I have created a following module - <Module Name="Images" Url="Image Library" RootWebOnly="TRUE" > <File Path="SliderFiles\KeynoteBackdrop1.png" Url="KeynoteBackdrop1.png" ...
0
votes
1answer
32 views

Best way to include Template File, Images, Layouts in Sandboxed solution

If you are trying to include Template File, Images, Layouts in Package. In Visual Studio 2010 will raise an error like “The deployment type "TemplateFile" of file "XXXUserControl.ascx" in Project Item ...
0
votes
1answer
35 views

The deployment type “TemplateFile” of file “xxx.js” in Project Item “Layouts” is not compatible

I have deployed my SP solution to farm successfully with some js files, those are added to layout mapped folder. Then I want the same solution to be deployed to SharePoint online. I just chaged the ...
0
votes
0answers
22 views

VS SP project cannot connect to SP Site

I am building the same SP project in VS 2010 on two different accounts on the same server. On the admin account (with the final version), I needed to change the Site URL and found that it cannot ...
0
votes
0answers
35 views

The job 'GUID' is already running and cannot be canceled- PowerShell

A deployment or retraction is already under way for the solution "xxx.wsp", and only one deployment or retraction at a time is supported it occurs if anomalies deployment is running for the same ...
0
votes
0answers
33 views

Add all DLLs to GAC?

My SharePoint 2010 solution has two projects, one responsible for the back end (WCF web service) and one for the front end (webparts). I added the DLL from the back end to GAC via Visual Studio ...
0
votes
1answer
49 views

Error in deployment step 'Activate Features'

Every time I try to deploy my project (containing only one Event Receiver), I get the following error: Error occurred in deployment step 'Activate Features': Operation is not valid due to the ...
0
votes
1answer
25 views

Making the SharePoint project “Safe”

I deployed a SharePoint solution consisting of 4 webparts. When I try to add one to a page on my SharePoint site, it gives me this error: "a web part or web form control on this page cannot be ...
0
votes
1answer
31 views

Deploying Webpart to SharePoint Site

I am unsure how to deploy a SharePoint project solution to a SharePoint site. I thought it was by deploying to the SharePoint server, but is that not enough? Do I deploy to SP and Web server? Note: I ...
1
vote
0answers
22 views

Deploying “Renditions: Word to Wiki” inside Sharepoint 2013 [closed]

I have SharePoint server 2013 SP1 , and I want to use the Kaboodle Word to Wiki inside it. So I did the following steps to be able to test a trial version:- I download the related 7 .wsp files from ...
1
vote
2answers
40 views

SharePoint Webpart Feature installation

Do I ever install the Feature in my SharePoint project manually, or is that handled when I install the solution? Am I only supposed to have one overall, or one per webpart?
0
votes
2answers
34 views

Deployiment Issues - multiple webparts

If my SharePoint Project has multiple web parts, then I should see multiple .webpart files when I deploy the solution and check the webpart gallery, right? If not then what do I do/why is it ...
0
votes
0answers
36 views

Deployed sharepoint-hosted app not accessible

I have created a sharepoint-hosted app (sharepoint 2013) and I cannot publish it. I already deployed another provider-hosted apps, the CNAME is configured an seems to work... but when I try to ...
0
votes
1answer
93 views

update the page layout links for all the publishing site collection pages

i have export/import a publishing site collection as a subsite. but i read that the page layout links inside publishing pages are hard coded. and to update all the page layout links i found the ...
0
votes
0answers
40 views

IE default security settings block any App scripts from running

I wrote a Sharepoint-hosted app for use by a single company. But in order for my javascript to execute on their local intranet, which uses Microsoft Windows Server 2008, I have to instruct them to ...
0
votes
1answer
219 views

spadminV4 which could not be contacted in deployment

I have Sharepoint 2013 and Powershell deployment. I execute muy ps1 script in SPS01 machine. Farm servers are SPS01, SPS02, SPS03, SPS04. User for deploy is UserInstallerMoss , it's Farm ...
2
votes
1answer
49 views

Subsite creation issue

I created a site in french. Then I've created a subsite to this site (also in french), I saved this subsite as a template. Later I deployed my site on another web application and I applied an english ...
0
votes
1answer
20 views

Based on what do we make a decision to choose GAC or Web App(bin) deployment of project?

In VS there are is project property which allows you to choose: GAC or Web APP(bin). Based on what do we make a decision to choose one of option? Is this property valid only while deploying via VS? ...
0
votes
3answers
69 views

Building a Sharepoint project - the big picture

I'm a Sharepoint beginner so my question could be naive but I wasn't able to find any answer. Could someone give me a brief guide about developing a complete, enterprise class solutions in a shorat ...
0
votes
1answer
32 views

List provision order on deployment

I have a generic list with just title fields. I'm trying to have another list use a lookup column to list each item. If I add the lookup to second list after deployment it works. But if I simply ...
0
votes
1answer
154 views

Access denied in powerschell script for Add SPSolution

I have a Windows Server 2012 Standard, named DC. This server is a Domain Controller. I have Sharepoint 2013. The domain is DEVRSG.COM. I log on in DC machine using DEVRSG\Administrator, is Domain ...
0
votes
1answer
56 views

What does “Synchronize” paramter of Install-SPSolution do?

Install-SPSolution command can accept an optional Synchronize parameter. MSDN says that it "synchronizes all solutions or the specified solution in the local farm". But what does this mean? What ...
0
votes
1answer
56 views

Browse button issue - Asset Picker

I just did a Backup - Restore of a site collection from one farm to another. On the destination after the restore, the "Browse..." is no longer working - the one that is used to navigate within ...
0
votes
2answers
50 views

BDC Deployment to Foundation

I was able to successfully develop and test a BDC model developed in visual studio 2010. It was developed on a server using SharePoint Server 2010. I tried deploying the solution to our SharePoint ...
0
votes
1answer
155 views

Why aren't service application pools recycled on solution retract/update?

When you update or retract a SharePoint solution, it's supposed to automatically restart or recycle any affected application pools on all servers on the farm. For web application pools, this appears ...
1
vote
0answers
229 views

XsltListViewWebPart: select default view

I'm trying to configure an XsltLisViewWebPart for deployment to a SharePoint site. I'm provisioning the views beforehand using: List oList = clientContext.Web.Lists.GetByTitle(list.Title); ...
0
votes
0answers
71 views

Deploying app part to office 365, takes long time to load

When I am debugging the solution, the app part is working properly. After testing I deployed this app part to Office 365 site, and added app part to the page. It's taking very long time to load the ...
0
votes
1answer
44 views

Error deploying custom web parts

I deployed my WSP to the SP server and activated my solution. When I attempted to add my web parts to a page I get the message: A Web Part of Web Form Control on this Page cannot be displayed or ...
0
votes
2answers
43 views

Sharepoint 2010 Application Deployment

I have a VS2012 solution with a few visual web parts in it. When I run the project it deploys it to my local server and my web parts are available for my local sharepoint. How can I deploy these new ...
1
vote
1answer
505 views

SharePoint 2013: Programatically Installing AND Activating sandbox solutions using CSOM

I have tested this successfully, but wanted to check if anyone else has run into issues with this approach? The following object SP.Publishing.DesignPackage allows you to .install() and .apply() ...
1
vote
1answer
54 views

Dependency of feature deployment with List and webpart

We have a project containing a webpart and a list instance (rootwebonly). The webpart and the list instance are activated via a single feature. Now problem is that, everytime a change is requested, ...
0
votes
1answer
47 views

What happens if feature is already activated and you install new wsp?

Suppose we have deployed a wsp (say webpart) with a feature at site collection level and it is activated. Then, we change code of the webpart, create a new wsp. Then, go to central admin->manage ...
0
votes
1answer
17 views

Webpart not appearing in site

We have deployed webpart using powershell but cannot find it under the Edit page-> add webpart -> custom, there is no folder called 'custom'. This folder otherwise comes up when deployed via VS. ...
0
votes
0answers
51 views

Deploying web part to https site

I'm trying to deploy custom Visual Web Part created in Visual Studio 2013 as a farm solution in Sharepoint 2013. The thing is, the site I want to specify for debugging is a https site. After ...
1
vote
0answers
17 views

How do you clean up the test features and solutions from the farm?

we have been playing around with sharepoint wsps and visual studio and there are lot of test files in the layout folder, coltrol templates and images folders, etc. Also there exist wsps and features ...
0
votes
0answers
11 views

Setup separated account for Search Service and get SQL deny error

I have a new account "wss_search". Then I re-create the existing "Search Service Application" and assign wss_search as the new application pool owner. Also I have granted wss_search have full control ...
0
votes
2answers
139 views

How to remove features from farm?

I have figured out a way to uninstall and remove the wsp from manage farm solutions. (Solution Management) - http://centraladmin:8888/_admin/Solutions.aspx But I donotknow how to uninstall and ...