Preparation of components or SharePoint itself for use.

learn more… | top users | synonyms

0
votes
1answer
148 views

Sharepoint Feature Batch Deployment Script

Does anyone have a batch file we can use to deploy solutions and and activate features into sharepoint. The batch file should contain pause to allow features to activate and only then move on to the ...
1
vote
1answer
1k views

Installing SP2010 on Windows 8.1

Did anyone have a successful story of installing SP2010 on Windows 8.1? So far I'm stuck at installing .net 3.5. It gives me an error: 0x800F0906 could not install .NET Framework 3.5 (includes ...
8
votes
4answers
10k views

Sharepoint 2013 Distributed Cache cacheHostInfo null

I have setup a development environment for SharePoint 2013 so we can begin testing our 2010 content, however I am running into trouble starting the Distributed Cache service. Note that this is ...
0
votes
1answer
277 views

SharePoint 2013 Workflow - Error occurred in deployment step 'Activate Features'

When I deploy my workflow.. I get the following error... Any idea what Can be causing this? Error 10 Error occurred in deployment step 'Activate Features': ...
0
votes
0answers
21 views

IE default security settings block any App scripts from running

I wrote a Sharepoint-hosted app for use by a single company. But in order for my javascript to execute on their local intranet, which uses Microsoft Windows Server 2008, I have to instruct them to ...
1
vote
1answer
313 views

SharePoint 2013: Programatically Installing AND Activating sandbox solutions using CSOM

I have tested this successfully, but wanted to check if anyone else has run into issues with this approach? The following object SP.Publishing.DesignPackage allows you to .install() and .apply() ...
2
votes
1answer
448 views

Why CustomRibbonButton for List not displaying in RibbonBar?

I have added 1 Element File for CustomRibbon Button. And added 1 Feature to deploy this RibbonButton. When I deploy this, it deploys and Feature is Activated but not displaying the Button in ...
1
vote
1answer
750 views

deploy custom site list solution to web application scope?

I created a custom list definition in Visual Studio. Then, I generated a .wsp and sent it to our server admin to install. He got a warning: The solution contains no Web application scoped ...
0
votes
0answers
46 views

spadminV4 which could not be contacted in deployment

I have Sharepoint 2013 and Powershell deployment. I execute muy ps1 script in SPS01 machine. Farm servers are SPS01, SPS02, SPS03, SPS04. User for deploy is UserInstallerMoss , it's Farm ...
1
vote
1answer
290 views

Issue with deploying webpart in sharepoint 2010

We've created 2 webparts under a single visual studio solution as a farm environment. But after creating the WSP and trying to deploy it to our UAT, we are getting the following error This ...
-2
votes
0answers
21 views

How to take IIS backup in SharePoint Server

How to take IIS backup in SharePoint Server ? How to create Users and how to allocates permissions to the Users ?
2
votes
1answer
686 views

Retraction and deployment tasks are not executed Sharepoint 2010 after SP1

I am unable to redeploy solution to my sharepoint 2010 site. When I try to retract solution, the task is registered in scheduled que but not executed (sharepoint timer and admin services are running, ...
2
votes
1answer
42 views

Subsite creation issue

I created a site in french. Then I've created a subsite to this site (also in french), I saved this subsite as a template. Later I deployed my site on another web application and I applied an english ...
1
vote
1answer
380 views

Enable-SPFeature doesn't work, but activation via Site Settings does. Why?

I have a weird problem... I'm trying to deploy a sharepoint solution in production. This project works fine in the test environment, but in production trying to enable the feature returns this error: ...
2
votes
1answer
430 views

How to add and use external assemblies in solutions?

I need to use DocumentFormat.OpenXml.dll in my code. In the solution package, I included this external dll in the Additional Assemblies. It looks like this: I also need to reference it, so that I ...
0
votes
1answer
295 views

Sharepoint 2013, how do i programmatic deployment

I have following queries : How do i programmatically deploy Managed Metadata Fields, and associate then to particular Term Set in Store while deployment When I am trying to create List/List ...
0
votes
1answer
23 views

List provision order on deployment

I have a generic list with just title fields. I'm trying to have another list use a lookup column to list each item. If I add the lookup to second list after deployment it works. But if I simply ...
0
votes
1answer
17 views

Based on what do we make a decision to choose GAC or Web App(bin) deployment of project?

In VS there are is project property which allows you to choose: GAC or Web APP(bin). Based on what do we make a decision to choose one of option? Is this property valid only while deploying via VS? ...
0
votes
3answers
58 views

Building a Sharepoint project - the big picture

I'm a Sharepoint beginner so my question could be naive but I wasn't able to find any answer. Could someone give me a brief guide about developing a complete, enterprise class solutions in a shorat ...
3
votes
2answers
496 views

Problem with SP2013 solution scope: WebApplication vs GAC

I have a SP2013 solution that contains a custom WCF service, custom Timer Job and a Feature Event Reciever. Because of these the solution Assembly Deploying Target is set to GlobalAssemblyCache. The ...
4
votes
3answers
12k views

Error : Object reference not set to an instance of an object on feature deployment

I am writing code for feature activated code. But when I try to deploy my solution through VS 2010 it says deploy failed Error on feature activation : object reference not set to an instance of an ...
0
votes
1answer
53 views

Access denied in powerschell script for Add SPSolution

I have a Windows Server 2012 Standard, named DC. This server is a Domain Controller. I have Sharepoint 2013. The domain is DEVRSG.COM. I log on in DC machine using DEVRSG\Administrator, is Domain ...
0
votes
1answer
21 views

What does “Synchronize” paramter of Install-SPSolution do?

Install-SPSolution command can accept an optional Synchronize parameter. MSDN says that it "synchronizes all solutions or the specified solution in the local farm". But what does this mean? What ...
0
votes
1answer
25 views

Browse button issue - Asset Picker

I just did a Backup - Restore of a site collection from one farm to another. On the destination after the restore, the "Browse..." is no longer working - the one that is used to navigate within ...
0
votes
2answers
29 views

BDC Deployment to Foundation

I was able to successfully develop and test a BDC model developed in visual studio 2010. It was developed on a server using SharePoint Server 2010. I tried deploying the solution to our SharePoint ...
0
votes
1answer
54 views

Why aren't service application pools recycled on solution retract/update?

When you update or retract a SharePoint solution, it's supposed to automatically restart or recycle any affected application pools on all servers on the farm. For web application pools, this appears ...
1
vote
0answers
103 views

XsltListViewWebPart: select default view

I'm trying to configure an XsltLisViewWebPart for deployment to a SharePoint site. I'm provisioning the views beforehand using: List oList = clientContext.Web.Lists.GetByTitle(list.Title); ...
4
votes
3answers
5k views

Error occurred in deployment step 'Recycle IIS Application Pool': Object reference not set to an instance of an object

I get this error in the deployment step of a share-point farm based project. Most of the suggested solutions on the net are a simple Visual Studio re-start, however, a simple VS restart won't fix ...
1
vote
2answers
2k views

How do I deploy custom web part to Sharepoint Online Site Collection?

After uploading the wsp to the site collection using the browser and activating it, everything seems to work fine and i see all the page layouts, masterpage, content types, lists and webparts. BUT, ...
3
votes
2answers
4k views

Cannot add the specified assembly “Microsoft.Practices.ServiceLocation.dll”

For a while now, me and my team having been having an issue where when we try and deploy a project we very frequently end up with the error Error occurred in deployment step 'Add Solution': ...
12
votes
2answers
1k views

SharePoint Designer 2010 workflow lifecycle

I've build a workflow with SharePoint Designer 2010 on a dev computer. Let's say it's in V1. Now I want to move the workflow to the production environment. What is the correct way to do that ? I've ...
0
votes
2answers
1k views

Deploy List Workflow in Production Environment

I created list workflow using SharePoint Designer. How to deploy my list workflow in Production environment?
1
vote
7answers
8k views

Deploying columns with content types in Visual Studio 2010

I've written a feature that deploys new columns along with a content type containing the columns. The feature is Site scoped and written in Visual Studio 2010 to deploy to SharePoint 2010. When the ...
0
votes
0answers
52 views

Deploying app part to office 365, takes long time to load

When I am debugging the solution, the app part is working properly. After testing I deployed this app part to Office 365 site, and added app part to the page. It's taking very long time to load the ...
7
votes
3answers
14k views

Explain it to me: SharePoint deployment scope, solution and features

There are different levels of scope for deployment, but I have not been able to find a definitive explaination of when each applies and what the restrictions are that require loosening (or tightening) ...
0
votes
1answer
35 views

Error deploying custom web parts

I deployed my WSP to the SP server and activated my solution. When I attempted to add my web parts to a page I get the message: A Web Part of Web Form Control on this Page cannot be displayed or ...
0
votes
2answers
436 views

Master page giving error: System.NullReferenceException: Object reference not set to an instance of an object

So this is the scene: We have a sharepoint site with different portals. Each portal is deployed by its seperate wsp on same server.Now there is this staging server where all of us deploy our wsps for ...
0
votes
2answers
41 views

Sharepoint 2010 Application Deployment

I have a VS2012 solution with a few visual web parts in it. When I run the project it deploys it to my local server and my web parts are available for my local sharepoint. How can I deploy these new ...
9
votes
6answers
3k views

How do I deploy the new version of a webpart?

As stated here (and as i checked), to upload a new version of an installed webpart, uninstalling the assembly from the GAC and installing the new version would suffice. I've tried it and it worked. ...
5
votes
10answers
4k views

What technical skills do you use most when developing/deploying SharePoint?

(I think my question is sufficiently different from this question to justify asking it. My question is not about useful SharePoint resources, but what technical skills you actually need...) I'm a ...
1
vote
1answer
49 views

Dependency of feature deployment with List and webpart

We have a project containing a webpart and a list instance (rootwebonly). The webpart and the list instance are activated via a single feature. Now problem is that, everytime a change is requested, ...
0
votes
1answer
511 views

How to deploy app_browsers file?

Is there a simple way to deploy a file into the App_Browsers folder of all web applications? By now, the only way I found is to use a feature receiver that create and fire a custom SPTimerJob that ...
2
votes
1answer
4k views

Activating a WebApplication Scoped Feature for a particular WebApplication

I developed a SharePoint 2010 WSP that contains a custom HTTP Module for performing short-url redirects. The WSP also contains a WebApplication scoped feature that consists of a feature receiver that ...
0
votes
1answer
38 views

What happens if feature is already activated and you install new wsp?

Suppose we have deployed a wsp (say webpart) with a feature at site collection level and it is activated. Then, we change code of the webpart, create a new wsp. Then, go to central admin->manage ...
0
votes
1answer
17 views

Webpart not appearing in site

We have deployed webpart using powershell but cannot find it under the Edit page-> add webpart -> custom, there is no folder called 'custom'. This folder otherwise comes up when deployed via VS. ...
0
votes
0answers
40 views

Deploying web part to https site

I'm trying to deploy custom Visual Web Part created in Visual Studio 2013 as a farm solution in Sharepoint 2013. The thing is, the site I want to specify for debugging is a https site. After ...
1
vote
0answers
78 views

Move listitems in SharePoint Hosted app

I am trying to creating a SharePoint 2013 Hosted app that get a selected listitem and move it to another folder of library in the same web. When I debug my code everything runs without any problem. ...
1
vote
0answers
16 views

How do you clean up the test features and solutions from the farm?

we have been playing around with sharepoint wsps and visual studio and there are lot of test files in the layout folder, coltrol templates and images folders, etc. Also there exist wsps and features ...
0
votes
0answers
9 views

Setup separated account for Search Service and get SQL deny error

I have a new account "wss_search". Then I re-create the existing "Search Service Application" and assign wss_search as the new application pool owner. Also I have granted wss_search have full control ...
0
votes
2answers
72 views

How to remove features from farm?

I have figured out a way to uninstall and remove the wsp from manage farm solutions. (Solution Management) - http://centraladmin:8888/_admin/Solutions.aspx But I donotknow how to uninstall and ...