Preparation of components or SharePoint itself for use.

learn more… | top users | synonyms

0
votes
1answer
20 views

Error deploying custom web parts

I deployed my WSP to the SP server and activated my solution. When I attempted to add my web parts to a page I get the message: A Web Part of Web Form Control on this Page cannot be displayed or ...
0
votes
2answers
323 views

Master page giving error: System.NullReferenceException: Object reference not set to an instance of an object

So this is the scene: We have a sharepoint site with different portals. Each portal is deployed by its seperate wsp on same server.Now there is this staging server where all of us deploy our wsps for ...
1
vote
2answers
2k views

How do I deploy custom web part to Sharepoint Online Site Collection?

After uploading the wsp to the site collection using the browser and activating it, everything seems to work fine and i see all the page layouts, masterpage, content types, lists and webparts. BUT, ...
0
votes
2answers
33 views

Sharepoint 2010 Application Deployment

I have a VS2012 solution with a few visual web parts in it. When I run the project it deploys it to my local server and my web parts are available for my local sharepoint. How can I deploy these new ...
2
votes
1answer
334 views

How to add and use external assemblies in solutions?

I need to use DocumentFormat.OpenXml.dll in my code. In the solution package, I included this external dll in the Additional Assemblies. It looks like this: I also need to reference it, so that I ...
9
votes
6answers
2k views

How do I deploy the new version of a webpart?

As stated here (and as i checked), to upload a new version of an installed webpart, uninstalling the assembly from the GAC and installing the new version would suffice. I've tried it and it worked. ...
1
vote
1answer
474 views

deploy custom site list solution to web application scope?

I created a custom list definition in Visual Studio. Then, I generated a .wsp and sent it to our server admin to install. He got a warning: The solution contains no Web application scoped ...
1
vote
1answer
25 views

SharePoint 2013: Programatically Installing AND Activating sandbox solutions using CSOM

I have tested this successfully, but wanted to check if anyone else has run into issues with this approach? The following object SP.Publishing.DesignPackage allows you to .install() and .apply() ...
5
votes
10answers
3k views

What technical skills do you use most when developing/deploying SharePoint?

(I think my question is sufficiently different from this question to justify asking it. My question is not about useful SharePoint resources, but what technical skills you actually need...) I'm a ...
1
vote
1answer
404 views

Installing SP2010 on Windows 8.1

Did anyone have a successful story of installing SP2010 on Windows 8.1? So far I'm stuck at installing .net 3.5. It gives me an error: 0x800F0906 could not install .NET Framework 3.5 (includes ...
1
vote
1answer
41 views

Dependency of feature deployment with List and webpart

We have a project containing a webpart and a list instance (rootwebonly). The webpart and the list instance are activated via a single feature. Now problem is that, everytime a change is requested, ...
0
votes
1answer
467 views

How to deploy app_browsers file?

Is there a simple way to deploy a file into the App_Browsers folder of all web applications? By now, the only way I found is to use a feature receiver that create and fire a custom SPTimerJob that ...
2
votes
1answer
4k views

Activating a WebApplication Scoped Feature for a particular WebApplication

I developed a SharePoint 2010 WSP that contains a custom HTTP Module for performing short-url redirects. The WSP also contains a WebApplication scoped feature that consists of a feature receiver that ...
0
votes
1answer
19 views

What happens if feature is already activated and you install new wsp?

Suppose we have deployed a wsp (say webpart) with a feature at site collection level and it is activated. Then, we change code of the webpart, create a new wsp. Then, go to central admin->manage ...
0
votes
1answer
13 views

Webpart not appearing in site

We have deployed webpart using powershell but cannot find it under the Edit page-> add webpart -> custom, there is no folder called 'custom'. This folder otherwise comes up when deployed via VS. ...
0
votes
1answer
812 views

Deploy List Workflow in Production Environment

I created list workflow using SharePoint Designer. How to deploy my list workflow in Production environment?
0
votes
0answers
20 views

Deploying web part to https site

I'm trying to deploy custom Visual Web Part created in Visual Studio 2013 as a farm solution in Sharepoint 2013. The thing is, the site I want to specify for debugging is a https site. After ...
1
vote
0answers
62 views

Move listitems in SharePoint Hosted app

I am trying to creating a SharePoint 2013 Hosted app that get a selected listitem and move it to another folder of library in the same web. When I debug my code everything runs without any problem. ...
1
vote
0answers
13 views

How do you clean up the test features and solutions from the farm?

we have been playing around with sharepoint wsps and visual studio and there are lot of test files in the layout folder, coltrol templates and images folders, etc. Also there exist wsps and features ...
0
votes
0answers
5 views

Setup separated account for Search Service and get SQL deny error

I have a new account "wss_search". Then I re-create the existing "Search Service Application" and assign wss_search as the new application pool owner. Also I have granted wss_search have full control ...
0
votes
2answers
31 views

How to remove features from farm?

I have figured out a way to uninstall and remove the wsp from manage farm solutions. (Solution Management) - http://centraladmin:8888/_admin/Solutions.aspx But I donotknow how to uninstall and ...
0
votes
1answer
23 views

Module -> Elements.xml URL value implication

In module we have 2 files sameple.txt and custommaster.master. Here is an sample image:- I would like to know from the URL you can see in the above elements.xml file, where would the sample.txt and ...
1
vote
1answer
666 views

Retraction and deployment tasks are not executed Sharepoint 2010 after SP1

I am unable to redeploy solution to my sharepoint 2010 site. When I try to retract solution, the task is registered in scheduled que but not executed (sharepoint timer and admin services are running, ...
2
votes
1answer
386 views

Why CustomRibbonButton for List not displaying in RibbonBar?

I have added 1 Element File for CustomRibbon Button. And added 1 Feature to deploy this RibbonButton. When I deploy this, it deploys and Feature is Activated but not displaying the Button in ...
0
votes
1answer
34 views

How to deploy ItemAdded event receiver to the entire farm? [duplicate]

I have created an ItemAdded event receiver that is supposed to process new documents/files after they've been added to any document library in the farm - i.e., I'd like the event receiver to ...
2
votes
3answers
622 views

Binding lookup fields to document library template

I have features that define site content types and a document library template that uses these content types. Now, when I create a document library from the template, all the content types appear ...
2
votes
3answers
195 views

How to check if there is any active solution deployment running on the server?

Is there a way to know if there is any active solution deployment running on SharePoint server? I'm wondering how to do this using a PowerShell script?
1
vote
0answers
41 views

Able to Export a site but unable to import in another webapplication

Here I am using SharePoint 2013. I exported site collection with no errors, but when trying to Import site onto different web application as a site, I got below error Verbose: List URL: ...
1
vote
1answer
19 views

Muilti deploy DLLs from external Projects into single WSP

I'm trying to build a single .WSP that should contains multiple DLLs from External projects. I've been following that this tutorial: Link I've followed all steps but on deploy , DLLS doesn't appear ...
4
votes
2answers
63 views

SharePoint 2013 - App Deployment

i need some best practices or advices on a common scenario in SP2013 where i can't get my head around as i'm fairly new to App development. Let's say i have some kind of existing site structure and ...
2
votes
1answer
31 views

Migrate Web Part from one environment to another?

SharePoint Foundation 2010. I have added a very basic web part to my development environment. It is honestly just the Visual Web Part template. I would like to export this web part and import to ...
2
votes
1answer
36 views

Activate only selected features on SharePoint 2013 deployment

Using Visual Studio 2010 and CKSDEV 2010, I was able to select to set of features (right click on project, select features to activate). Then using a custom deployment configuration, I used to ...
12
votes
3answers
3k views

Deployed Timer Job not taking new code when deployed

I've realized recently that, when re-deploying (either manually or through vs2010) my timer job feature package, the updated execute code is not being deployed. Strange yea. Essentially, I'll ...
2
votes
1answer
33 views

List out the ways in which we can deploy the files to the SharePoint [closed]

What are the possible ways in which we can deploys files to:- The SharePoint hive (folders in hive) The SharePoint content db (libraries, etc) By files I mean css, js, masterpage, site page, html ...
4
votes
4answers
894 views

Error while adding Sandbox WebPart

I created a simple "Hello World" sandbox webpart in VS.NET 2010. After uploading the .wsp file to SharePoint site, I activated the webpart. But while trying to add it to a page, I was getting this ...
0
votes
1answer
35 views

Display text under image - SharePoint 2013 Foundation

I need help in how to display the text under an image in SharePoint 2013 Foundation. I attached an image to show what the OOTB Picture Library does and what I would like for it to be: Currently ...
6
votes
4answers
5k views

Sandboxed web part failing with “No available sandboxed code execution server could be found”

I'm deploying a web part as a component of a sandboxed solution from Visual Studio 2010 to Windows 7 SharePoint Foundation Server 2010 on my development box, and I receive the following error when ...
0
votes
2answers
6k views

Error when trying to deploy SharePoint 2010 solution package - SharePoint 2010 - Visual Studio 2010

when i try to deploy the project from VS 2010 i get this below error.... Error occurred in deployment step 'Recycle IIS Application Pool': The local SharePoint server is not available. Check that the ...
1
vote
2answers
27 views

Automated deployment and environment-specific configuration

We are using TeamCity and Octopus Deploy to perform CI/CD with the custom WSP's that we use for SharePoint, and I'm currently trying to solve the problem of how to handle environment-specific ...
0
votes
2answers
275 views

How do I move the contents (and mappings) of the Managed Metadata Service Application from dev to test environment?

I have a solution on a development server with a custom list with Managed Metadata fields that reference Managed Metadata term sets (from the standard Managed Metadata Service (MMS)). The term sets ...
0
votes
3answers
1k views

Custom List Form Will Not Deploy

A demo List Form using Visual Studio 2010 to test and experiment with a few things. Nothing at all was added inside the project. Functionality, etc, will be added later, but at this point it was ...
0
votes
2answers
45 views

How to determine custom application page URL independently of the environment/farm?

I have deployed a custom ribbon button and when a user clicks it, I open a custom application page - I have deployed the page to _layouts mapped folder. To open the page (with JavaScript), so far I'm ...
1
vote
3answers
2k views

Powershell Deployment - Enable-SPFeature Error

I get the following problem activating a feature in powershell: Enable-SPFeature : The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: ...
0
votes
0answers
121 views

SharePoint 2013 Workflow - Error occurred in deployment step 'Activate Features'

When I deploy my workflow.. I get the following error... Any idea what Can be causing this? Error 10 Error occurred in deployment step 'Activate Features': ...
3
votes
1answer
539 views

Install-SPUserSolution: Sandboxed code execution request failed

When executing Install-SPUserSolution powershell command the following error is shown: Install-SPUserSolution : Sandboxed code execution request failed. At line:1 char:23 + ...
0
votes
1answer
37 views

Creating a List , document library, content type as Features using VS , VERSUS using CA to create these

In the past I have used the Central administrator to add lists, document libraries, apps, site collection, etc. and I did not use the visual Studio to create any of these items. But now as I gained ...
1
vote
1answer
23 views

Converting an ASP.NET application into a SharePoint application, need assistance on doubts and good practice [closed]

we have a ASP.NET simple application with custom functionality that performs certain calculations based on data entered in text box and shows output in a label. We would now like to use it in ...
0
votes
1answer
66 views

Trying to view custom application page in browser results in “404 FILE NOT FOUND” error

In VS2010 I created a new .NET 3.5 solution and inside a new project for SharePoint 2010 (empty project called "SPAppPageTest"); I deployed it as a farm solution. I added a new application page, ...
6
votes
3answers
12k views

Explain it to me: SharePoint deployment scope, solution and features

There are different levels of scope for deployment, but I have not been able to find a definitive explaination of when each applies and what the restrictions are that require loosening (or tightening) ...
1
vote
0answers
41 views

SharePoint2013, provider-hosted, remoteAppUrl resolution in Elemets.xml

In my experience when a provider-hosted app is built in VS ~remoteAppUrl gets resolved according to the build profile. The end results is that all webparts' Elements.xml get their page location set at ...