Preparation of components or SharePoint itself for use.

learn more… | top users | synonyms

2
votes
1answer
4k views

Activating a WebApplication Scoped Feature for a particular WebApplication

I developed a SharePoint 2010 WSP that contains a custom HTTP Module for performing short-url redirects. The WSP also contains a WebApplication scoped feature that consists of a feature receiver that ...
2
votes
1answer
43 views

Where can I find more info on Deployment model?

•Select a deployment model This objective may include but is not limited to: identifying artifacts and execution appropriate for sandbox and farm (i.e. GAC vs. BIN) implementation, designing solutions ...
0
votes
2answers
234 views

deploying custom feature in sharepoint 2010

I have created a custom feature for adding a button in the SharePoint 2010 ribbon. If I click that button, I can open a show model dialog box which I have loaded a aspx file that contains file upload ...
1
vote
1answer
3k views

Why am I getting this error? “The given assembly name or codebase was invalid.”

I have created and implemented the IHttpModule interface in order to use the Session_Start event in SharePoint 2010 (like global.asax in asp.net). I have added the add tag into my web.config file in ...
0
votes
2answers
87 views

Can I deploy a Sharepoint 2010 blog on a plain ASP.NET hosting company?

If I decide to host a blog using Sharepoint 2010 can any plain vanilla .NET 4.0 ASP.NET hosting company be OK or does the host need to support Sharepoint? Are Sharepoint stuff deployed when I deploy ...
4
votes
4answers
966 views

Error while adding Sandbox WebPart

I created a simple "Hello World" sandbox webpart in VS.NET 2010. After uploading the .wsp file to SharePoint site, I activated the webpart. But while trying to add it to a page, I was getting this ...
0
votes
1answer
131 views

Using SharePoint token to link to the Silvelight XAP file

I deploy my silverlight .xap file to a document library.I'd like to add the silverlight using the object control,like below param name="source" ...
0
votes
1answer
102 views

Solutions not Deploying

My farm has stopped deploying solutions. No matter what I try they are always stuck on "deploying" I have checked that all timer services are running but still it is stuck. I am looking for other ...
1
vote
2answers
652 views

Migrating Theme from MOSS 2007 to 2010

Can any of the post readers help me out how to make my moss 2007 custom theme work in sharepoint 2010. Thanks in Advance Manoj
1
vote
1answer
720 views

Deploying a WSP to application server with stopped Web Application Service

Maybe this will be obvious to someone with more medium to large farm experience than I have. I've got a custom Central Admin (.aspx) page that gets deployed to the \TEMPLATE\ADMIN directory. I also ...
6
votes
4answers
6k views

Sandboxed web part failing with “No available sandboxed code execution server could be found”

I'm deploying a web part as a component of a sandboxed solution from Visual Studio 2010 to Windows 7 SharePoint Foundation Server 2010 on my development box, and I receive the following error when ...
0
votes
1answer
208 views

unable to deployWSPBuilder visual webpart in sharepoint 2010

i have created simple webpart in visual studio 2010 with the WSPBuilder Template (restricted to use this template. can not use the sharepoint tooling). I have added the Visual Webpart type. i found a ...
2
votes
1answer
1k views

How to deploy WSPBuilder developed package on specific Sharepoint site?

I am developing the wsp package, which includes 2 list definitions,a webpart, and a picture library definition in WSPBuilder. I tried with sample webpart. I wondered, there is option given in solution ...
12
votes
2answers
1k views

SharePoint Designer 2010 workflow lifecycle

I've build a workflow with SharePoint Designer 2010 on a dev computer. Let's say it's in V1. Now I want to move the workflow to the production environment. What is the correct way to do that ? I've ...
1
vote
1answer
1k views

Sharepoint 2010 - wpresources for Bin / web Application Deployment

In SharePoint 2010 , using visual studio 2010 : i have bin / web application deployment. i want to add java script file under Virtual Directories\/wpresources// I cannot use the Resources mapped ...
3
votes
1answer
2k views

Set SPWeb title on a SharePoint site using PowerShell

I'm having problems setting the title of a root web in a site collection when creating it in an other language then English. When i run the script under using 1033, it works fine the site title is set ...
6
votes
6answers
1k views

Please suggest a practice to deploy a sharepoint site collection from test to production server

This is the current scenario: Sharepoint 2010 on MachineA with SQL Server. Site collection SCa on web app WAa. Now I need to "deploy" my site collection on MachineB. What are the suggested ways ...
3
votes
1answer
711 views

Error deploying WSP package

Error: Cannot find this file specified in the manifest file: ChangeContentTypeEventHandler.dll I'm getting this error when attempting to deploy this solution to the Sharepoint environment. Here is ...
1
vote
1answer
473 views

Installing a file to the GAC through a Sharepoint 2007 WSP package

I'm creating a WSP package in Visual Studio 2010 to deploy my feature to the Sharepoint 2007 environment on a Windows 2003 Server box. Currently, the xml file that references the assembly containing ...
1
vote
1answer
310 views

Cross-Farm Social Features in SharePoint 2010?

We have two separate SP2010 Farms, Farm-A has a "TeamSite" web-application and "Mysite" is hosted on Farm-B. User Profile service is hosted on Farm-B and consumed in Farm-A. My Requirement is: ...
0
votes
1answer
230 views

Sharepoint 2010 deployment one way whats the best way to get external data back in

As sharepoint 2010 can not deploy back to the source what could be the best method of getting data back into the source site collection? eg lets say a webpart asks a user some questions, which needs ...
9
votes
6answers
3k views

How do I deploy the new version of a webpart?

As stated here (and as i checked), to upload a new version of an installed webpart, uninstalling the assembly from the GAC and installing the new version would suffice. I've tried it and it worked. ...
1
vote
1answer
56 views

Looking for a good resource for building a SP 2007 WSP package in Visual Studio 2010

Can anyone point me in the right direction for this?
0
votes
1answer
1k views

How to maintain workflow associations when deploying a SharePoint Designer wsp file on my customer's machine?

I know this might be a silly question but here goes... I created an event calendar site and it has some customized webparts (done using visual studio), custom views (XLV webpart views) and workflows ...
4
votes
3answers
2k views

Deploying a site template and instantiate it in the same PowerShell script?

I want to create a PowerShell script that : add a farm solution that only contains a site template deploy the solution globally wait for the deploy job to finish create a site collection based on ...
1
vote
2answers
178 views

Adding Infopath forms into different libraries

I am following this link to add some infopath forms into different doc lib when a site is provisioned. <File Path="Module1\File-01.xml" Url="./SalesLib1/File-01.xml" Type="GhostableInLibrary" ...
4
votes
2answers
150 views

Solution package for a specific webapplication

I have created a solution package using the makecab tool that contains a feature and a DLL which will be installed on the GAC. Its getting deployed globally however I want to deploy it for specific ...
7
votes
1answer
10k views

Can't Activate Solution from Site Settings in SharePoint foundation 2010

I'm currently tasked with developing a branding solution for SharePoint Foundation sites. I've created a WSP file which can be deployed through my local machine through Visual Studios, but when I ...
3
votes
3answers
1k views

Maintenance Page/Downtime

I have an IF site that will be undergoing a fairly large deployment. There will be a few hours of downtime, and I want to put a maintenance page at the front of the site, and prevent any traffic from ...
2
votes
3answers
2k views

Deploy WSP from Visual Studio 2010 to web application with set host header

I have a demo SharePoint server with multiple web applications created. Each of them has a host header that is entered into company's DNS. All the web applications are on port 80. I changed SiteURL ...
0
votes
3answers
688 views

Error when using stsadm.exe to deploy webpart

I am trying to deploy a webpart to our live SharePoint instance. STSADM.EXE -o AddSolution -filename webpart.wsp I then get the following error: Object reference not set to an instance of an ...
6
votes
1answer
2k views

Problem installing web part using Powershell

We've developed a custom Visual Web Part using Visual Studio 2010 for Sharepoint 2010 Server. The webpart gets deployed when executed from VS (F5), so we can add it wherever we want using Sharepoint ...
1
vote
2answers
1k views

Is adding aspx pages to onet.xml allowed for team site?

I have about 20 custom aspx pages that I need to deploy whenever a site is provisioned. I tried the following code but the aspx page didnt get added. (I even activated the publishing but the aspx ...
18
votes
2answers
6k views

Multiple Sharepoint projects in one solution - how to package correctly?

I have multiple Sharepoint projects in a solution: MySolution.WF MySolution.Webparts MySolution.UI I also have some common code in a MySolution.Common project. All of the aboe projects ...
1
vote
2answers
2k views

Error occured in deployment step

I get this error message when I try to deploy my project: Error occurred in deployment step 'Add solution': The located assembly's manifest definition does not match the assembly reference. ...
2
votes
1answer
398 views

Only Upgrade solution works!

We are having a weird issue. None of our WSPs (MOSS 2007 and 2010) work first time they are deployed. We noticed that upgrading solution (after deploying) works. Our WSPs normally replace user ...
0
votes
1answer
506 views

SharePoint Server 2010 to the Cloud (Azure)

As part of our implementation of SharePoint 2010 (Server), I am tasked with investigating the option to deploy SharePoint 2010 via the cloud. Does anyone have the benefits and/or limitations for ...
1
vote
1answer
812 views

Using a globally reusable workflow

I have created a globally reusable workflow in Sharepiont Designer. I was able to save it as a .wsp. I would like to deploy and use this workflow to a different site collection. After succesfully ...
6
votes
2answers
1k views

How to reproduce Visual Studio “Deploy” action?

It seems like whenever I am developing a web part and I "Deploy" it from Visual Studio, everything gets deployed and works exactly as I would expect. When I take my WSP and try to install it to a ...
2
votes
1answer
185 views

Remove SQL Dependencies from SP Standalone Cloned VM

I have made a copy of a standalone SP 2010 VM -> VM_2. I've renamed it, defined another IP. Now VM_1 and VM_2 run simultaneously. I've added following line to hosts file: MY_NEW_IP VM_1 VM_2 to ...
5
votes
4answers
11k views

Custom web part deployment produces 'Cannot import this webpart' error

I have built an empty SharePoint project in Visual Studio 2010 with some custom web parts in it. When I've tested these on my local development machine they can be added to a page without any trouble. ...
4
votes
2answers
161 views

Any good open source tools for doing WSP installations for SharePoint 2010?

I've heard that SharePoint Solution Installer is a good one, but it only works for 2007 and the 2010 version only appears to be in the planning phase. Does anyone know of any existing tools out ...
1
vote
2answers
137 views

Need guidance on SharePoint Environment Building

I just created a Virtual Machine on my laptop with Windows 2008 R2 Standard + SQLServer 2008 Standard + SharePoint 2010 Enterprise (everything on Single Box). I want to start my development of my ...
2
votes
4answers
3k views

error CS0234: The type or namespace name 'DirectoryServices' does not exist in the namespace 'System'

I have deployed a feature (wsp) on our new production server but get the following error: error CS0234: The type or namespace name 'DirectoryServices' does not exist in the namespace 'System' The ...
2
votes
2answers
779 views

Farm deployments often fail with GAC DLL noted as being in use

Sometimes when doing deployments to our farm there are errors that appear where the GAC DLL is noted as being in use, this happens even though we stop/start the SP services before uninstalling and ...
0
votes
3answers
262 views

Removing GUID from linked datasource

I'm deploying a DVWP and I'm looking to remove GUIDs references from the datasource. This is fine for standard single satasources, but I'm having troubles with joined datasources. Here's (a portion ...
2
votes
1answer
137 views

Redeploying a list provisioning feature

I created a site definition to use as the base for project workspaces. I then staple features to the definition as needed. In one of the features I instantiate lists and document repositories. I ...
4
votes
3answers
680 views

Best practices for updating production site

I've a VM (#1) with installed SP 2010 and SQL Server 2008. It suites our needs in terms of load and capacity. In case of breaking down we can revert it to the snapshot. The development process still ...
19
votes
5answers
1k views

Organizing WebParts in Visual Studio - Best Practices

My team is responsible for maintaining a SharePoint 2010 site that was developed by another group. This maintenance includes updates to existing web parts (approximately 20). Currently, all of these ...
7
votes
6answers
7k views

What is causing a “Cannot find a Feature” error when uninstalling a solution?

I have a weird error when trying to deploy a solution via Visual Studio 2010: Error 1 Error occurred in deployment step 'Add Solution': The solution cannot be deployed. The feature ...