Preparation of components or SharePoint itself for use.

learn more… | top users | synonyms

0
votes
1answer
584 views

How to deploy app_browsers file?

Is there a simple way to deploy a file into the App_Browsers folder of all web applications? By now, the only way I found is to use a feature receiver that create and fire a custom SPTimerJob that ...
0
votes
2answers
429 views

How to make SharePoint Online to update files inside modules

We have deployed solution to SharePoint Online with following elements.xml file: <?xml version="1.0" encoding="utf-8"?> <Elements xmlns="http://schemas.microsoft.com/sharepoint/"> ...
2
votes
1answer
318 views

SharePoint WSP Deployment Best Practices

I'm building a few WSPs (a custom web part and a branding wsp both scoped to site collection level) using WSP builder on VS2010. Our SharePoint 2007 Farm contains two Web applications. I'd like to ...
1
vote
0answers
43 views

Listdefinitions use Listname as Contenttype

I have a Sharepoint 2010 Foundation, VS2010 and i use the Sharepointfactory(spsf.codeplex.com), if this is important. My typical approach are: I create first some fields, then i use these in a ...
0
votes
0answers
129 views

Problem with adding webparts with limitedWebManager.ImportWebPart PowerShell

When creating a web in Visual Studio it generates a web part where the namespace and the class name is the same. I'm thinking that this is giving me a problem with the limitedWebManager.ImportWebPart ...
0
votes
2answers
520 views

Thoughts about deployment via Site Collection backup-restore

I wonder sharepoint experts ideas about deployment of sharepoint projects/portals via site collection backup & restore, instead of visual studio solutions? Especially for the projects that will ...
0
votes
1answer
415 views

Deploy with PowerShell issue

When I deploy my project from visual studio everything is fine, I have a module with some pictures in it and a stylesheet that get replaced on deployment, from the output window: Retracting ...
3
votes
2answers
5k views

Cannot add the specified assembly “Microsoft.Practices.ServiceLocation.dll”

For a while now, me and my team having been having an issue where when we try and deploy a project we very frequently end up with the error Error occurred in deployment step 'Add Solution': ...
1
vote
2answers
359 views

How to add a specialised content editor web part to the web part gallery?

I would like to add in the web part catalog for the whole farm a specialized version of the content editor web part. Actually, I want to allow all site managers to drop a content editor that contains ...
0
votes
2answers
794 views

Web-scoped Feature falsely activated during Visual Studio deployment

In Visual Studio I have a solution containing two features with their Scope set to "Web". These two features work as expected but the only thing that is going "wrong" is that they are activated when I ...
0
votes
2answers
627 views

OpenXML and WebPart Solution Deploying to Live Server

I have the OpenXML SDK installed on my development machine, and I have written a webpart solution that basically creates an excel file using the OpenXML dll. This solution is a full farm solution not ...
0
votes
3answers
94 views

Why is my MySite looking at hive 60 for its files?

404: "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\60\Template\SiteTemplates\CUSTOMMYSITE\default.aspx" It was working perfectly fine until I got the above after one ...
1
vote
0answers
244 views

how to maintain workflow task list data when retracting or removing workflow association

whenever i try to remove workflow association or retract workflow solution (.wsp) all associated task list data also gets deleted. i want to prevent this behavior as task list data is important for ...
0
votes
1answer
140 views

workflow inactive - after deployment?

my workflow is deployed through the following script in SharePoint 2010: # Set CurrentDirectory $callingDir = Split-Path -Parent $MyInvocation.MyCommand.Path [Environment]::CurrentDirectory = ...
0
votes
1answer
224 views

Foundation 2010 Services fail to restart on reboot

All of the services on our SP Install that use Domain Accounts fail to start automatically after an IIS Restart or System Restart. Services Affected: SharePoint 2010 Timer - Logging on as ...
0
votes
1answer
222 views

Error while executing Powershell Script SharePoint 2010

I am writing a PS script to add,deploy solution and deploy the features. The sequence is as follows Check if solution already exists, if yes then Disable -SPFeature (Runs for around 10 features) ...
1
vote
2answers
557 views

Deploying styles only for root site collection or for each site collection

I know how to deploy the masterpages and styles like css, javascripts, images etc, my question is rather what is the best practice? As I deploy the all the requisites on a site collection in the ...
0
votes
2answers
710 views

How to Make Sure the Newly Deployed DLL is Updated With New Code? And How to Clear the Cache of SharePoint DLL?

I am working on a big SharePoint project. We have 4 solutions with around 40 projects. So in my development environment, when ever I am deploying a modified project, I am not sure whether the newly ...
0
votes
3answers
199 views

Changing Application Link URLS from UAT Server to Production Server in Lists Automatically

I have two SharePoint 2007 sites, a UAT/Development site (ip.ip.ip.ip) and a Production site (intranet.mycompany.com). Each site contains collections of lists pointing to applications our company ...
0
votes
1answer
266 views

deploy customized infopath form

I have a SharePoint custom list with some fields. I modified the form using InfoPath. This modified form has many views, rules and logic inside. Now I would like to deploy this form to Production ...
0
votes
2answers
2k views

programmatically deploy to site collection level using c#

I would like to use c# to remotely deploy my sharepoint site collections and sites, I can easily write the code to perform most operations. However I can't seem to find a way of deploying the code to ...
0
votes
1answer
2k views

can't deploy from VS2010 to Sharepoint 2010

I have run VS 2010 as an administrator The user, which is running VS2010, have db_owner rights to the config, content, and central admin DBs of SP2010. In my hostfile i have 127.0.0.1 ...
1
vote
2answers
2k views

Deploying web part from Visual Studio?

I exported a Core Search Results Web Part and created a new Visual Web Part in a Visual Studio project. I have added some code to the .cs page and the code for my exported webpart to the .webpart file ...
0
votes
2answers
253 views

When Re-activating Feature, All Content Shows Up Twice

Let me preface this by saying that I am brand new to Sharepoint, so the answer to this question may be obvious. I have a blog feature on one of my Sharepoint sites that I need to make changes to. ...
0
votes
1answer
160 views

Adding new Web Front End. What will stop working?

I have one web server with Central Administration and all SharePoint web applications on it. I want to add new front end. Will, at any point of adding new new web front end server to existing ...
0
votes
2answers
257 views

Will be next SharePoint 13/15 have new deploy features?

Over the past couple of years I've been making solutions for SharePoint Server and always most important problem was the availability of the web-site. Deployment not-sandboxed solution is pain at ...
0
votes
2answers
193 views

SharePoint 2010 Dev Machine Deploy to Stage Machine

Machine 1: Virtual Development box with Visual Studio 2010, SharePoint 2010 Foundations, Designer 2010. Machine 2: SharePoint 2010 Enterprise (Staging Environment) Question: Does Machine 2 need to ...
0
votes
1answer
214 views

Deploying WSP, Sharepoint Version

In my current environment we have SH 2010 RTM, and deployment works fine. But in the near future there is going to be another farm, and in this one we would like to have it up to date with SP 1, all ...
0
votes
1answer
159 views

Sharepoint Feature Batch Deployment Script

Does anyone have a batch file we can use to deploy solutions and and activate features into sharepoint. The batch file should contain pause to allow features to activate and only then move on to the ...
1
vote
2answers
724 views

Automating changes in web.config file on load balanced server

Issue We currently have a deployment process which is partially automated and part manual. The manual part involves making manual changing to the web.config for some things. We have two load balanced ...
1
vote
2answers
2k views

Can't debug/deploy solution from VS 2010

I have encountered strange problem on my dev VM. Background: Having my VM open (VM Player), I put host computer into sleep mode, then I woke it and put into sleep mode for second time. After waking ...
6
votes
2answers
987 views

How to make SharePoint simpler for end users?

We are going to use SharePoint for our intranet. The perception at my office is that SharePoint is too complicated for average users to learn. There are many different ways to do any given task, and ...
0
votes
2answers
4k views

SharePoint Architecture Design Examples

I am bit confused with entire SharePoint Process. I mean if there is a Company who never used SharePoint and they want to get one for there Organisation. They have there own team of C# developers but ...
2
votes
4answers
2k views

How can I make sure the features in my solution activate in the correct order?

I'm working on a fairly large SharePoint 2010 project. We have broken up the code into a number of solutions, each containing a number of features which we deploy via powershell and activate in the ...
4
votes
3answers
13k views

Error : Object reference not set to an instance of an object on feature deployment

I am writing code for feature activated code. But when I try to deploy my solution through VS 2010 it says deploy failed Error on feature activation : object reference not set to an instance of an ...
6
votes
1answer
6k views

Error when deploying module with GhostableInLibrary files

Here is the module which I want to deploy on the server and the files which should be shown in the Style Library, when deploying them without type ghostale in library, all go good and well, no errors, ...
2
votes
1answer
325 views

Custom Field Type error when deploying solution

I'm having problems when deploying a solution that creates several custom columns, for the content types I need to use. As it turned out I needed a couple custom field types for my application. The ...
1
vote
1answer
128 views

Silverlight Application Development : Custom UI Form Development Beginner Question

So I am new to SP Dev, and completely new to the idea of developing Silverlight applications, and the use of Expression. But I am trying to understand how Expression gets used with Visual Studio in ...
1
vote
1answer
85 views

Prevent List from being deployed automatically by feature

I have a list that is deploying with a Site Template. I have properly set the Definition to deploy with a Site scoped feature, and the Instance to deploy with a Web scoped feature. All is well, in ...
1
vote
1answer
2k views

SandBox Solutions Deployment of WSP to Solution Gallery : Beginner Questions

I am a beginner to SP Dev, and I have been reading a few things about Sandbox Solutions and the limitations there. Also it seems that to deploy a solution, I can simply upload a wsp to the solution ...
1
vote
2answers
87 views

Deployment Issue Event Reciver

i built a event receiver it works 100%. when i deploy it manually using power shell it deploys with no error i then used Get-SPSolution to see if it has been deployed and it returns true when i go ...
1
vote
1answer
182 views

Creating the illusion of dynamically provisionable Web Part Zones

I'm currently creating an application for SharePoint 2010 that leverages what I consider to be repeatable solutions I've used over and over as a consultant. Something that I made that I liked was a ...
6
votes
1answer
559 views

Site Definition vs Web Template for product site

I'm getting ready to create a product for SharePoint, and I'd like it to be as easy as possible for people to deploy and use. I was planning on using a Site Definition, since this seems like a great ...
1
vote
1answer
432 views

Visual Studio Retract - Install features script

when Visual Studio launch a Sharepoint Project does some steps, when debug ends does a retract to restore the system status. Now I'm developing an application based on content type.. When I deploy ...
1
vote
1answer
2k views

What are the relationship between administrators groups of domain, dev computer and of Sharepoint services?

I know-know I can search and read but anyway I would need to ask in order to escape possible typos, personal misunderstandings and to better remember. I develop on a machine with installed ...
4
votes
3answers
4k views

How to deploy web part solution to multi-server farm?

I am having a heck of a time deploying a simple web part to a multi-server farm. The error I receive when deploying is: Error occurred in deployment step 'Activate Features': Feature with Id ...
2
votes
5answers
3k views

Adding new webparts to an already deployed solution

I have a webpart project built in visual studio 2010 and it has been deployed successfully to my production environment. I recently had to make some changes to the webpart and also needed to add a ...
3
votes
1answer
822 views

Timeout while deploying VS2010 solution to SP2010

When deploy a solution (no sandbox solution) with many projects, I always get the following error: Error occurred in deployment step 'Recycle IIS Application Pool': The open operation did not ...
0
votes
1answer
138 views

Hooking feature reciever issue

I have invalidly hooked feature reciever. Feature has two configuration files The first, SharePoint looks like this: < feature ...
3
votes
2answers
7k views

Failed to load reciever assembly

I have issue during deployment. It throws: Failed to load reciever assembly I tried to GAC that assembly, also microsoft.office.sharepoint.clientextensions.dll and Microsoft.Office.Server.dll ...