Preparation of components or SharePoint itself for use.

learn more… | top users | synonyms

2
votes
4answers
1k views

How can I make sure the features in my solution activate in the correct order?

I'm working on a fairly large SharePoint 2010 project. We have broken up the code into a number of solutions, each containing a number of features which we deploy via powershell and activate in the ...
4
votes
3answers
11k views

Error : Object reference not set to an instance of an object on feature deployment

I am writing code for feature activated code. But when I try to deploy my solution through VS 2010 it says deploy failed Error on feature activation : object reference not set to an instance of an ...
4
votes
1answer
4k views

Error when deploying module with GhostableInLibrary files

Here is the module which I want to deploy on the server and the files which should be shown in the Style Library, when deploying them without type ghostale in library, all go good and well, no errors, ...
2
votes
1answer
297 views

Custom Field Type error when deploying solution

I'm having problems when deploying a solution that creates several custom columns, for the content types I need to use. As it turned out I needed a couple custom field types for my application. The ...
1
vote
1answer
120 views

Silverlight Application Development : Custom UI Form Development Beginner Question

So I am new to SP Dev, and completely new to the idea of developing Silverlight applications, and the use of Expression. But I am trying to understand how Expression gets used with Visual Studio in ...
1
vote
1answer
84 views

Prevent List from being deployed automatically by feature

I have a list that is deploying with a Site Template. I have properly set the Definition to deploy with a Site scoped feature, and the Instance to deploy with a Web scoped feature. All is well, in ...
1
vote
1answer
2k views

SandBox Solutions Deployment of WSP to Solution Gallery : Beginner Questions

I am a beginner to SP Dev, and I have been reading a few things about Sandbox Solutions and the limitations there. Also it seems that to deploy a solution, I can simply upload a wsp to the solution ...
1
vote
2answers
85 views

Deployment Issue Event Reciver

i built a event receiver it works 100%. when i deploy it manually using power shell it deploys with no error i then used Get-SPSolution to see if it has been deployed and it returns true when i go ...
1
vote
1answer
173 views

Creating the illusion of dynamically provisionable Web Part Zones

I'm currently creating an application for SharePoint 2010 that leverages what I consider to be repeatable solutions I've used over and over as a consultant. Something that I made that I liked was a ...
5
votes
1answer
503 views

Site Definition vs Web Template for product site

I'm getting ready to create a product for SharePoint, and I'd like it to be as easy as possible for people to deploy and use. I was planning on using a Site Definition, since this seems like a great ...
1
vote
1answer
400 views

Visual Studio Retract - Install features script

when Visual Studio launch a Sharepoint Project does some steps, when debug ends does a retract to restore the system status. Now I'm developing an application based on content type.. When I deploy ...
1
vote
1answer
2k views

What are the relationship between administrators groups of domain, dev computer and of Sharepoint services?

I know-know I can search and read but anyway I would need to ask in order to escape possible typos, personal misunderstandings and to better remember. I develop on a machine with installed ...
4
votes
3answers
3k views

How to deploy web part solution to multi-server farm?

I am having a heck of a time deploying a simple web part to a multi-server farm. The error I receive when deploying is: Error occurred in deployment step 'Activate Features': Feature with Id ...
2
votes
5answers
2k views

Adding new webparts to an already deployed solution

I have a webpart project built in visual studio 2010 and it has been deployed successfully to my production environment. I recently had to make some changes to the webpart and also needed to add a ...
3
votes
1answer
655 views

Timeout while deploying VS2010 solution to SP2010

When deploy a solution (no sandbox solution) with many projects, I always get the following error: Error occurred in deployment step 'Recycle IIS Application Pool': The open operation did not ...
0
votes
1answer
131 views

Hooking feature reciever issue

I have invalidly hooked feature reciever. Feature has two configuration files The first, SharePoint looks like this: < feature ...
3
votes
2answers
6k views

Failed to load reciever assembly

I have issue during deployment. It throws: Failed to load reciever assembly I tried to GAC that assembly, also microsoft.office.sharepoint.clientextensions.dll and Microsoft.Office.Server.dll ...
1
vote
3answers
1k views

Sharepoint web.config deployment

I have SharePoint app which we are deploying to another SharePoint server and I need to update target server web.config with changes made on source server web.config. Can somebody advise me how to ...
0
votes
1answer
2k views

Overwrite custom masterpage on deployment? [duplicate]

Possible Duplicate: How to update custom master page and page layout, which is already deployed I have my custom masterpage in my visual studio solution and first time I deployed it worked ...
0
votes
1answer
120 views

Create Sharepoint Web Application in Dev, deploy to Live?

[I've searched on here and googled, but can't find anything that actually makes any sense to me! - I'm a n00b to SP...our SP Dev left at very short notice...i.e. he was here yesterday, gone ...
1
vote
2answers
655 views

Deploying custom webservices

I am working on an old project, not currently used, that I pulled from our source backups. I have experience as a Sharepoint user but this is the first time I have been developing for or ...
0
votes
1answer
371 views

What are the advantages/disadvantages of building a list template with Visual Studio as opposed to SharePoint Designer

First, let me say, I am new to SharePoint Development. I have been able to create a couple of related custom lists using SharePoint Designer. I was able to deploy them and they work quite well. ...
0
votes
1answer
116 views

What happens to content if you remove content's dependency?

Dependency may not be the right word here - but basically my question is regarding what happens to the data inside a sharepoint content database if that data was created, for example, by using a ...
1
vote
4answers
190 views

The nature of deploying a sharepoint solution (or TO a sharepoint solution)

I'm in the really early stages of learning sharepoint and I'm struggling with a few concepts. One of which is the way in which one builds/deploys/debugs a sharepoint solution. Prior to sharepoint I'm ...
0
votes
1answer
69 views

GUIDs need replacing every time I press F5 - any way around this?

(Caveat: this is the first time I've ever worked with SharePoint, so am probably failing to understand something fairly fundamental. But Google's been singularly unhelpful, so here I am.) I'm ...
1
vote
3answers
969 views

How to work in Sharepoint 2010 Team based development

We have following environment to create a publishing fully branded portal. Three developers each one have sharepoint 2010 installed on their workstation. One Server so that when each dev finish its ...
0
votes
2answers
298 views

How do I move the contents (and mappings) of the Managed Metadata Service Application from dev to test environment?

I have a solution on a development server with a custom list with Managed Metadata fields that reference Managed Metadata term sets (from the standard Managed Metadata Service (MMS)). The term sets ...
0
votes
1answer
376 views

Changing Deployment Url for Webpart in VS 2008

I am trying to debug a webpart in SharePoint 2007 using Visual Studio 2008. When I click debug, it deploys the solution to http://localhost:8080. The url I want to deploy to is on a different port. ...
0
votes
0answers
300 views

Quickest way to backup and restore a web application content database across farms?

When I perform a complete backup of my development content database using Backup-SPSite and restore the site on a separate farm using Restore-SPSite its currently taking around 25 mins to backup and ...
12
votes
3answers
4k views

Deployed Timer Job not taking new code when deployed

I've realized recently that, when re-deploying (either manually or through vs2010) my timer job feature package, the updated execute code is not being deployed. Strange yea. Essentially, I'll ...
0
votes
1answer
543 views

Why the files which are added as link in project are not deployed on SharePoint 2010

I have two projects in my VS solution, a project named "B" is a SharePoint 2010 project which has a mapped SharePoint "Layouts\js" folder and some other project "A". In project "B" I put various ...
1
vote
1answer
82 views

What are the technical reasons to go for BIN deployment in SharePoint 2010?

In my current project, the team uses BIN deployment instead of the standard GAC deployment. The application is just a custom application using NHibernate as the ORM framework. I know thats not a good ...
0
votes
2answers
418 views

DVWP Display of Multiple Lists Results in “Unable to display this Web Part” Error in Production Environment

I used SharePoint Designer 2007 to create a joined view of two lists and changed the 'ListID' parameters to 'ListName'. The list is grouped and sorted. Update: When the joined subview is in the ...
2
votes
3answers
634 views

What is the “best practice” for Dev/Test/Release for SP2010?

I am a .Net coder new to SP. I've set up a new SP2010 in our test environment but wonder what the best practice is for the cycle I am familiar with "dev->test->live" with SP? e.g. How can I make test ...
1
vote
2answers
222 views

Web Part Module Itens error 404

We have a WebPart that has a module with resources (images, css and js files). Locally it works perfectly when deploying from VisualStudio. In a testing server we're deploying the webpart via ...
2
votes
1answer
380 views

Is it possible to update .Webpart file and reflect the change on all uses of a webpart

I have a webpart that is a modified XSLT list view webpart in SharePoint 2010. I exported the webpart as a file and uploaded it to the webpart gallery manually. If the user adds this webpart to ...
0
votes
1answer
438 views

Can't find workflow deployed as WSP solution

I am new to SharePoint, sorry if answer to my question is obvious. I am trying to deploy my very simple workflow as WSP package, it deploys without errors, I activate it, but I can't find my workflow ...
1
vote
1answer
826 views

How do I deploy from a site template that has a feature dependency?

I am trying to deploy an alpha version of the project I'm working on and I'm running into some issues that are likely because I have a flawed understanding of how to do deployments. My site is fairly ...
1
vote
1answer
295 views

Solution deploys without errors, creates lists, but I can't see workflows

I am new to SharePoint and .Net development, sorry if answer for my question is obvious. I've created a solution, pack it to the WSP package and deploy. It deploys without errors, creates all lists, ...
1
vote
2answers
788 views

Error deploying SharePoint 2010 solution with InfoPath form (The path is not of a legal form.)

I am new to SharePoint and .Net development, sorry if answer for my question is obvious. I've created SharePoint solution, which uses InfoPath form. When I deploy it from Visual Studio, all work ...
1
vote
2answers
772 views

Deploy multiple wsp versions to different webapps in the same farm

Im working on a newer version (2.0) of my sharepoint2010 wsp (which contains several features and webparts). I have dev+test servers which have a webapp each with v1.0 of wsp. In the newer version ...
3
votes
2answers
650 views

Deploying web parts to sharepoint with out taking sharepoint down?

Is there a way to install sharepoint web parts with out taking sharepoint down at all? Here is what I use for my deployment batch file: @ECHO OFF SET PATH=%PATH%;"C:\Program Files\Common ...
1
vote
2answers
2k views

Event receiver not working properly?

I created an Event Receiver for a feature, my problem is when I deploy the solution, the feature is deployed as active but never goes through my FeatureActivated() inside my Event Receiver. It also ...
2
votes
3answers
277 views

Deploying Custom DLL

I'm new to the SharePoint platform, although I've been coding in the .NET platform since v1.1. I created a customization that takes a SharePoint Library, iterates through the items and changes ...
0
votes
1answer
142 views

How to deploy changes in one webpart fromd dev to test and production

Regarding this question here: How to edit/replace an existing page when the ribbon is not visible? lets say that in test I already have my configuration done. New mapped property Changed the ...
2
votes
3answers
199 views

How to check if there is any active solution deployment running on the server?

Is there a way to know if there is any active solution deployment running on SharePoint server? I'm wondering how to do this using a PowerShell script?
2
votes
1answer
91 views

How to develop in the following environment

Production has 10 servers, 8 app servers, 2 front end. Its own active directory Testing has almost the same. Its own active directory The problem is that at the moment, in the current company ...
2
votes
3answers
563 views

How can I update a custom form (Edit/New Item) without deploying the list?

I have a list in Visual Studio 2010 with a custom forms (EditForm/NewForm). I deploy the project to SharePoint Server 2010, to update the New Item form. The problem is that if I deploy the project ...
0
votes
1answer
1k views

How to deploy an aspx to subsite from VS 2010

Is there any chance to achieve this? The sharepoint project and the silverlight web part, which is called by the aspx, are linked by this template. I played with module and feature xml files but i ...
3
votes
1answer
352 views

Why Is My Content Type Replaced With a List Instance Detail When I Deploy My Project in Visual Studio, but Not When I Deploy it Manually?

I'm doing something that I think is pretty typical. I've created a content type, descended from Document, to go into a document library, like so: <?xml version="1.0" encoding="utf-8"?> ...