Preparation of components or SharePoint itself for use.

learn more… | top users | synonyms

2
votes
2answers
760 views

Using SharePoint with Hardware versus Software Load Balancing

Is there any difference when using Hardware or Software load balancing with SharePoint? What we want to do is to test a clustered solution using Windows NLB in test, and then run it using Hardware ...
2
votes
1answer
40 views

Migrate Web Part from one environment to another?

SharePoint Foundation 2010. I have added a very basic web part to my development environment. It is honestly just the Visual Web Part template. I would like to export this web part and import to ...
2
votes
2answers
272 views

Deploying Site Solution

EDIT to add more detail about what I'm trying to do: This is the first SP project I've worked on, so I might be making a very basic mistake with how the project is set up. The project consists of a ...
2
votes
1answer
1k views

deploy custom site list solution to web application scope?

I created a custom list definition in Visual Studio. Then, I generated a .wsp and sent it to our server admin to install. He got a warning: The solution contains no Web application scoped ...
2
votes
2answers
2k views

SharePoint 2010 User Code Host service stops

When I try to deploy any SandBox Solution I receive following error: Error occurred in deployment step 'Retract Solution': Timeout occurred while running the SharePoint Sandboxed Code service. ...
2
votes
1answer
516 views

How to add and use external assemblies in solutions?

I need to use DocumentFormat.OpenXml.dll in my code. In the solution package, I included this external dll in the Additional Assemblies. It looks like this: I also need to reference it, so that I ...
2
votes
1answer
503 views

Why CustomRibbonButton for List not displaying in RibbonBar?

I have added 1 Element File for CustomRibbon Button. And added 1 Feature to deploy this RibbonButton. When I deploy this, it deploys and Feature is Activated but not displaying the Button in ...
2
votes
1answer
317 views

SharePoint WSP Deployment Best Practices

I'm building a few WSPs (a custom web part and a branding wsp both scoped to site collection level) using WSP builder on VS2010. Our SharePoint 2007 Farm contains two Web applications. I'd like to ...
2
votes
1answer
148 views

SP 2007 custom workflow activity not deploying properly

I have a relatively simple workflow activity that just removes all permissions on a list item. This activity runs great in our test environments which is 2k8 r2 64bit. However, when we GAC the ...
2
votes
1answer
202 views

How can I avoid “service unavailable”/“recompiling” when deploying solutions

The topic says a lot. I'm looking for a way to avoid that ugly "service unavailable" page when you deploy a solution. Also, I would like some theory on it, as I'm not sure I understand it completely. ...
2
votes
2answers
706 views

Retraction and deployment tasks are not executed Sharepoint 2010 after SP1

I am unable to redeploy solution to my sharepoint 2010 site. When I try to retract solution, the task is registered in scheduled que but not executed (sharepoint timer and admin services are running, ...
2
votes
0answers
324 views

Why does WSP Deployment Type 'ApplicationServer' require features to be manually installed?

When I create a WSP with Deployment Type set to WebFrontEnd and deploy, all of the features contained within are automatically installed. Features that are set up as ActivateOnDefault="TRUE" (Farm or ...
2
votes
1answer
224 views

Sharepoint 2010 development process

I'm about start working on a new sharepoint 2010 project and I have some doubts about the development process. The thing is: as far as I know, all the code development chould be in a continuous ...
1
vote
3answers
9k views

How to deploy webpart on production (not debugging) server?

I've created a web part, debugging it on a test Sharepoint 2010 install on my local workstation. I'd like to test it on our production server. It seems that I won't be able to use Build --> Deploy to ...
1
vote
7answers
9k views

Deploying columns with content types in Visual Studio 2010

I've written a feature that deploys new columns along with a content type containing the columns. The feature is Site scoped and written in Visual Studio 2010 to deploy to SharePoint 2010. When the ...
1
vote
2answers
137 views

Need guidance on SharePoint Environment Building

I just created a Virtual Machine on my laptop with Windows 2008 R2 Standard + SQLServer 2008 Standard + SharePoint 2010 Enterprise (everything on Single Box). I want to start my development of my ...
1
vote
3answers
3k views

How to deploy DLL as SafeControls? (No manual solutions, please)

I've user controls project (UI) and am using AJAX Extension Toolkit with them. The dll of AJAX Extension Toolkit is referenced in the project. The project is successfully compiling. Another project ...
1
vote
1answer
137 views

Deploying web applications to a file share

what do you think about deploying the SharePoint IIS web sites to a Shared file location (\\Fileserver\WWWRoot\Application1 for example) in contrast with deploying a copy locally to each Web Front End ...
1
vote
3answers
1k views

How to work in Sharepoint 2010 Team based development

We have following environment to create a publishing fully branded portal. Three developers each one have sharepoint 2010 installed on their workstation. One Server so that when each dev finish its ...
1
vote
2answers
237 views

Web Part Module Itens error 404

We have a WebPart that has a module with resources (images, css and js files). Locally it works perfectly when deploying from VisualStudio. In a testing server we're deploying the webpart via ...
1
vote
2answers
2k views

Error occured in deployment step

I get this error message when I try to deploy my project: Error occurred in deployment step 'Add solution': The located assembly's manifest definition does not match the assembly reference. ...
1
vote
4answers
196 views

The nature of deploying a sharepoint solution (or TO a sharepoint solution)

I'm in the really early stages of learning sharepoint and I'm struggling with a few concepts. One of which is the way in which one builds/deploys/debugs a sharepoint solution. Prior to sharepoint I'm ...
1
vote
1answer
266 views

SharePoint 2010 new server farm with shared SQL Server

Here is the situation I'm planning an upgrade from MOSS 2007 to MOSS 2010. My goal is to provision the minimum amount of new hardware. My Thought was to just setup new WFE's and re-use the existing ...
1
vote
1answer
473 views

Installing a file to the GAC through a Sharepoint 2007 WSP package

I'm creating a WSP package in Visual Studio 2010 to deploy my feature to the Sharepoint 2007 environment on a Windows 2003 Server box. Currently, the xml file that references the assembly containing ...
1
vote
2answers
170 views

Is it possible to deploy SharePoint solution (WSPs) via feature activation?

This seems to me an uphill task in SharePoint but is it possible to deploy the WSPs via SharePoint features? For instance, if we activate a certain feature then some specific SharePoint solutions ...
1
vote
4answers
6k views

Error occurred in deployment step 'Recycle IIS Application Pool': Invalid namespace

I am trying to test developing for SharePoint 2010 on a Windows 7 machine. I created a new empty SharePoint project, added a web part and deployed, which worked fine. When I try to run or deploy a ...
1
vote
3answers
2k views

Installing MOSS in DMZ with no AD

We want to install 2 WFEs in a DMZ with no AD in a workgroup environment. These WFEs will only host deployed content for anonymous users. The Index/Central Admin server will be on the internal LAN ...
1
vote
1answer
120 views

Custom library referenced in sharepoint project is not being put into GAC

I have a SharePoint 2010 project in a solution, and I have a library project in the solution. In the SharePoint project I've referenced to that project. Now when I deploy the SharePoint project, my ...
1
vote
2answers
99 views

Can I safely rename applications residing under 'SharePoint Web Services' in IIS?

I understand that sharepoint creates the SharePoint Web Services for a number of purposes, as described here. Here is my particular instance: Is it possible to organize/rename these GUID named ...
1
vote
2answers
721 views

Automating changes in web.config file on load balanced server

Issue We currently have a deployment process which is partially automated and part manual. The manual part involves making manual changing to the web.config for some things. We have two load balanced ...
1
vote
1answer
2k views

SandBox Solutions Deployment of WSP to Solution Gallery : Beginner Questions

I am a beginner to SP Dev, and I have been reading a few things about Sandbox Solutions and the limitations there. Also it seems that to deploy a solution, I can simply upload a wsp to the solution ...
1
vote
3answers
1k views

Sharepoint web.config deployment

I have SharePoint app which we are deploying to another SharePoint server and I need to update target server web.config with changes made on source server web.config. Can somebody advise me how to ...
1
vote
1answer
142 views

Workflow deployment in a multiple WFE farm environment

The issue is:, I change the visual studio workflow's initiation form via infopath create the wsp package again Retract and Remove it via the ca. Deploy the new package via powershell When I try to ...
1
vote
1answer
1k views

What is an efficient way to copy Web Part pages from a dev server to a production server?

I have 29 web part pages, all very similar in structure. I built them using the browser. I'd like to migrate them from a development server to a production server. I tried copying them using both ...
1
vote
1answer
812 views

Using a globally reusable workflow

I have created a globally reusable workflow in Sharepiont Designer. I was able to save it as a .wsp. I would like to deploy and use this workflow to a different site collection. After succesfully ...
1
vote
5answers
4k views

SharePoint 2010 GAC deployment doesn't update

The following issue just crept up on me. The steps mentioned below had worked just fine until about 2 days ago. When I deploy a update to a solution (of web parts) to a SharePoint 2010 server I don't ...
1
vote
2answers
1k views

Does replacing an assembly in the GAC cause a reset?

So, I have a web part I wrote that is not working correctly, I get "object reference not set to an instance of an object." it works fine in dev, but when I installed in prod, it doesn't. Anyway, if I ...
1
vote
3answers
232 views

What is best practice for deploying third party SharePoint 2007 solutions?

I want to know what to look for and what to do (both from a developer and IT admin point of view) before installing a third party solution into a SharePoint 2007 farm? Is there a checklist that I ...
1
vote
1answer
38 views

Deploying workflows from Visual Studio problems

I recently ran into a problem while trying to deploy WSP containing workflow 2013 SPIs. Visual Studio 2012 couldn't delete workflows and workflow associations during deployment process.
1
vote
2answers
46 views

SharePoint Webpart Feature installation

Do I ever install the Feature in my SharePoint project manually, or is that handled when I install the solution? Am I only supposed to have one overall, or one per webpart?
1
vote
1answer
240 views

Solution deployment fails with error “Violation of PRIMARY KEY constraint 'PK_Classes'”

In our install script, which installs several solutions together, we found that solutions were occasionally failing to deploy with the following error in the ULS log: ...
1
vote
1answer
22 views

Authentication in Sharepoint - Could you explain me?

Im learning SP and i have everything installed and running. The only thing im not sure about is authentication: 1)If you run your SP installation on LAN and the only users who can access it, is ...
1
vote
1answer
482 views

Enable-SPFeature doesn't work, but activation via Site Settings does. Why?

I have a weird problem... I'm trying to deploy a sharepoint solution in production. This project works fine in the test environment, but in production trying to enable the feature returns this error: ...
1
vote
1answer
429 views

How do I export web application and site collections structure to production environment without deploying?

Microsoft tells us (yet again) that no custom code is needed in the new version of Sharepoint. However I'm curious how to export Web Application(s) | Site Collection(s) and Site(s) structure including ...
1
vote
1answer
1k views

Can't find WebApplication scoped feature

I've deployed a wsp that has 2 features. The one scoped at a web level is listed where I'd expect to see it and activates without a problem. The feature scoped at a web application can't be found ...
1
vote
1answer
178 views

Deploying a feature for custom sharepoint timer job

To give some background, I am an ASP.net developer tasked with creating a calender event notification system with a lot of features beyond the out of the box calender. My application would read a list ...
1
vote
1answer
621 views

How to create a PowerShell script that accepts one or more SPWebApplication and use it in an expression?

I'm trying to create a custom function that can uninstall and reinstall any SharePoint solution. Some solutions requires the -GACDeployment switch, some requires the -AllWebApplications and some ...
1
vote
2answers
358 views

How to add a specialised content editor web part to the web part gallery?

I would like to add in the web part catalog for the whole farm a specialized version of the content editor web part. Actually, I want to allow all site managers to drop a content editor that contains ...
1
vote
2answers
556 views

Deploying styles only for root site collection or for each site collection

I know how to deploy the masterpages and styles like css, javascripts, images etc, my question is rather what is the best practice? As I deploy the all the requisites on a site collection in the ...
1
vote
2answers
2k views

Can't debug/deploy solution from VS 2010

I have encountered strange problem on my dev VM. Background: Having my VM open (VM Player), I put host computer into sleep mode, then I woke it and put into sleep mode for second time. After waking ...