Preparation of components or SharePoint itself for use.

learn more… | top users | synonyms

4
votes
2answers
9k views

When do we need an IISreset after deployment?

Is there any good articles out there to explain when we need to do an IISreset after deployment? We are using SharePoint as an internet facing site, and try to not do an IISreset if it is not ...
1
vote
0answers
147 views

Move listitems in SharePoint Hosted app

I am trying to creating a SharePoint 2013 Hosted app that get a selected listitem and move it to another folder of library in the same web. When I debug my code everything runs without any problem. ...
1
vote
1answer
352 views

Custom library referenced in sharepoint project is not being put into GAC

I have a SharePoint 2010 project in a solution, and I have a library project in the solution. In the SharePoint project I've referenced to that project. Now when I deploy the SharePoint project, my ...
-1
votes
1answer
39 views

Deploying a sharepoint solution [closed]

I'm new to sharepoint site development. I've developed a sharepoint 2013 site and would like to view in user's mode. Currently it is in designer mode with edit options. But, I would like to view in ...
1
vote
1answer
1k views

How to replace the server name in the web application URL

I have a server named sv002, and I have created an intranet web application at the root of this server. So currently I am able to access the web application using the following URL: - http://sv002. ...
1
vote
1answer
5k views

Can not restore my site collection .No content databases in the web application were available to store your site collection.

I want to change the URL of my team site collection, to do so i have back-up the site collection from inside the old URL, and i want to restore it to the new URL. so i did the following:- -i create ...
0
votes
1answer
3k views

Is there a way to modify my SharePoint web URL to display a custom name instead of the servername/sites/intranet

I have created a new SharePoint 2013 web application, under the default port so the current web application URL is :- http://servername/sites/Intranet/ But our client is asking if there is a way to ...
2
votes
0answers
26 views

Requirments for running my web application under https

I have created a new web application that uses https. After that I added a new site collection to it, but my question is "will SharePoint web application and the site collection works under HTTPS out ...
0
votes
1answer
5k views

Deploy a single feature using SharePoint Management Shell with SharePoint 2013

I have been working in a development environment and deploying my custom web part features from Visual Studio directly by just hitting F5. I now need a way to deploy features separately to a test ...
1
vote
1answer
50 views

How to manage future updates for my APPs and site collections

My SharePoint 2013 environments are as follow:- I have three environments; Development, staging, production. Currently I have developed an intranet for our company, on the development env, then I ...
0
votes
2answers
35 views

Full deploy with customization

I have installed 2 VM's (DC/SQL box and a SP2010app/VS2012 box). I have created a web app with its initial root site collection (based on Blank Site). My goal is to prepare the dev environment so ...
0
votes
1answer
65 views

How do you deploy an edit/add custom form to Sharepoint 2010 without modifying views or data on target server?

I have a custom content type and list on a SharePoint 2010 server. The edit/add forms are custom, built in SharePoint Designer. I want to modify the layout of the forms including a new field, but ...
0
votes
1answer
257 views

Restoring a Team site collection inside another environment will display an empty white page

I have developed a team site inside my development machine, which contains the following :- 5 overlayed calendar Apps. One announcement APP One document management APP Script editor web part Content ...
0
votes
0answers
78 views

Restoring my Site collection from my development machine to my staging machine will show blank page

I have a team site collection inside my development machine; containing Apps, text, pictures, etc. So i back up the site collection from my development machine, i create a new web application inside ...
1
vote
1answer
423 views

How to customize SharePoint 2007 in Visual Studio 2010?

How to customize SharePoint 2007 in Visual Studio 2010
0
votes
1answer
83 views

Back-up a site collection that contain overlay calendars will keeping referencing the old calendars URL

I have a community site collection, which contain 5 calendars Apps, and I have overlayed 4 calendars together inside a general calendar. Then I have backup the site collection from my development ...
0
votes
1answer
1k views

Transfer my sharepoint application from one environment to another

I have SharePoint 2013 server & SQL server 2008 r2 inside my development and UAT environments. Currently inside my development environment I did the following main tasks:- I have created a new ...
0
votes
2answers
792 views

Master page giving error: System.NullReferenceException: Object reference not set to an instance of an object

So this is the scene: We have a sharepoint site with different portals. Each portal is deployed by its seperate wsp on same server.Now there is this staging server where all of us deploy our wsps for ...
2
votes
1answer
5k views

App installation failure due to App Management Shared Service Proxy

I have a SharePoint 2013 Foundation installation for development activity and when trying to deploy a SharePoint hosted App, I get the error: App Management Shared Service Proxy is not installed. ...
1
vote
0answers
135 views

VS 2013 not deploying silverlight solution in sandboxed on stand alone dev: SPUCWorkerProcess not running error

I have a stand alone machine with SP2010 set up on Windows Server 2008 R2. Office, SPD, VS2013, Expression, etc. There is no AD or anything as it is stand alone installation using local accounts and ...
2
votes
1answer
237 views

How does SharePoint 2010 manage versioned dlls in the GAC when referenced by multiple features?

We have multiple SharePoint projects and features that reference common library code. The library is versioned using the 4 part identifier (x.x.x.x). Each feature may reference a particular version ...
1
vote
1answer
946 views

Issue with deploying webpart in sharepoint 2010

We've created 2 webparts under a single visual studio solution as a farm environment. But after creating the WSP and trying to deploy it to our UAT, we are getting the following error This ...
0
votes
1answer
623 views

Custom Master Page Feature on Parent Site automatically getting activated on activating child's master page feature

I've created and deployed a custom master page and kept its scope to be Web because I want to apply to specific sites not the complete site collection. But when I activate feature at a specific site, ...
0
votes
1answer
172 views

SharePoint Deployment with third party assembly that requires a .dat file

I develop an SharePoint 2010 application with VS 2012. This application contains a third party dll that is embedded in the package manifest and deployed to gac. However, every time I deploy the ...
3
votes
2answers
619 views

Deploying Site Solution

EDIT to add more detail about what I'm trying to do: This is the first SP project I've worked on, so I might be making a very basic mistake with how the project is set up. The project consists of a ...
0
votes
1answer
136 views

SharePoint Online takes hour to install the sharepoint hosted app

I am trying to write SharePoint hosted app and connecting to microsoft online Sharepoint portal (dev site). It takes more than an hour to install the app on the sharepoint after I press F5 in Visual ...
0
votes
2answers
156 views

Assembly load errors after adding web application resources to solution with farm features

We have a solution that was recently changed from being globally deployed to deployed by web application in order to move binding redirects into the solution manifest (instead of using ...
0
votes
2answers
72 views

SharePoint 2010 no code deployment

Is it possible to deploy changes from a Staging environment to production environment without custom code or solution packages? Basically, I don't want to disturb an existing content. Suppose in dev ...
3
votes
4answers
2k views

Web Application scoped features not visible in Central Admin after installing solution with WebApplication scoped resources

In an effort to use WebConfigModifications less, I am trying to move some binding redirects and safe control entries into the solution manifest. The DeploymentTarget of the assembies is ...
2
votes
3answers
3k views

Files deployed in module cannot be found

I'm trying to deploy a selection of pages and master pages in modules but I'm encountering the same problem with all of them. When I try to navigate to a page, I get a File Not Found error (with ...
1
vote
1answer
473 views

Solution deployment fails with error “Violation of PRIMARY KEY constraint 'PK_Classes'”

In our install script, which installs several solutions together, we found that solutions were occasionally failing to deploy with the following error in the ULS log: ...
9
votes
4answers
14k views

Error occurred in deployment step 'Recycle IIS Application Pool': Object reference not set to an instance of an object

I get this error in the deployment step of a share-point farm based project. Most of the suggested solutions on the net are a simple Visual Studio re-start, however, a simple VS restart won't fix ...
0
votes
1answer
466 views

BDC Model Deployment to Default Web App

I have a BDC model in one of my SharePoint projects. This model ultimately needs to be deployed to 3 environments: Dev, Test and Production. Now my Dev environment only has one web application on port ...
0
votes
1answer
70 views

Deployment dedicated project does not work with VS 2012

I have a complex application that is split into two projects, and a deployment project. MySolution.sln Core.csproj Client.csproj Deployment.csproj The deployment project is setup to include all ...
0
votes
1answer
1k views

Security Exception in SharePoint 2010 when executing

My SharePoint 2010 solution comprises of 2 Features. One feature uses the Flee library to do some mathematical calculations in some code behind. The solution has a number of class libraries that I ...
0
votes
1answer
50 views

Solution Package Deployment

I have a solution Package which comprises of multiple features, Events receivers, layouts, timerjobs, webparts and custom Master Page. In my Central Administration, I have two web applications. I ...
3
votes
1answer
2k views

deploy custom site list solution to web application scope?

I created a custom list definition in Visual Studio. Then, I generated a .wsp and sent it to our server admin to install. He got a warning: The solution contains no Web application scoped ...
0
votes
1answer
32 views

Deploy Workflow as template?

I have a workflow that resides in a visual studio 2010 solution. Its a state machine workflow for a list. Currently the workflow is deploy at the root site, using a root lists (customlist, task, ...
1
vote
0answers
19 views

Deployment Question

We have a live sharepoint site and one development and one UAT server. Whenever we want to refresh the live site content to UAT, we are having problems. Most of the web parts are failing and ending up ...
1
vote
1answer
26 views

Authentication in Sharepoint - Could you explain me?

Im learning SP and i have everything installed and running. The only thing im not sure about is authentication: 1)If you run your SP installation on LAN and the only users who can access it, is ...
3
votes
1answer
853 views

When do I need to use -CASPolicies updating a 2010 solution?

When I update a solution in 2010, I use the following PowerShell Script with the -CASPolicies attribute: Update-SPSolution -Identity MySolution.wsp -LiteralPath ...
0
votes
0answers
107 views

SharePoint 2010 custom service with no GAC deployment

I am working with a Custom Share Point 2010 service development. The issue is if the Solution is scoped at GAC then I can access my Service with /mex extension, to the url. But, if the solution is ...
0
votes
1answer
68 views

Managing SharePoint versions on different environments

After I have finished my first SharePoint development on my development environment, new issues automatically raised. Mainly on how to transfer my SharePoint application from my development to my ...
0
votes
2answers
274 views

What is the recommended approach to move my Publishing site collection from my development environment to my production environment

I have created the following on my SharePoint 2013 development environment:- Created new managed path Create a new site collection of type publishing site. Create sub sites under the main site ...
0
votes
1answer
54 views

Possible to implement continuous integration against SharePoint online?

I have implemented CI on SharePoint server projects without a problem (so to speak). Can this also be done for SharePoint online?
0
votes
1answer
470 views

How can I deploy a solution to a farm with 2 WFE?

How should I deploy my solution to a farm with 2 WFE? Should I deploy to the WFE one by one or what's the procedures? How should I configure my solution in visual studio? I tried to deploy it ...
0
votes
2answers
72 views

deploy application page to multiple folders

I have an app that applies to two different groups and each has a different database. Example: _Layouts/dept1/SomePage.aspx (uses dept1db) _Layouts/dept2/SomePage.aspx (uses dept2db) I would like ...
0
votes
2answers
79 views

Set 2013 High Trust App StartUrl at deployment time

Is it possible to set the start url of a High Trust App at deployment time? From what I can tell it looks like this the url from app manifest gets hard coded into a binary .app file at compile time. ...
0
votes
2answers
424 views

wsp deploy error sharepoint2013

i tried to deploy my vs solution to another sharepoint portal. i did Add-SPSolution -LiteralPath "pathofthe wsp file" and when i write the command which is; Install-SPSolution -Identity ...
0
votes
1answer
345 views

Slow and errors openening a new site after deploying solutions in SP2013

We are running SP2013 and having often problems after deploying and creating a new site. When the solutions are deployed, we create a site with powershell or from central admin with de new deployed ...