Preparation of components or SharePoint itself for use.

learn more… | top users | synonyms

0
votes
1answer
240 views

Trying to view custom application page in browser results in “404 FILE NOT FOUND” error

In VS2010 I created a new .NET 3.5 solution and inside a new project for SharePoint 2010 (empty project called "SPAppPageTest"); I deployed it as a farm solution. I added a new application page, ...
1
vote
0answers
122 views

SharePoint2013, provider-hosted, remoteAppUrl resolution in Elemets.xml

In my experience when a provider-hosted app is built in VS ~remoteAppUrl gets resolved according to the build profile. The end results is that all webparts' Elements.xml get their page location set at ...
1
vote
0answers
20 views

How to deploy a cross-site publishing environment to prod

I'm building out a cross-site publishing environment on a dev server. So, it will have the following sites/assets: publishing site (myserver/sites/devpubsite) product Catalog Site ...
0
votes
1answer
29 views

Deploying a solution, IIS and Web Service

Basic question: When you deploy a solution with Visual Studio 2010, where the views is placed? I've opened my IIS and I try to found the files deployed and I doesn't find it. Another issue is ...
1
vote
1answer
1k views

Installing SP2010 on Windows 8.1

Did anyone have a successful story of installing SP2010 on Windows 8.1? So far I'm stuck at installing .net 3.5. It gives me an error: 0x800F0906 could not install .NET Framework 3.5 (includes ...
0
votes
0answers
31 views

Deploy works from Visual Studio, get security exception from Site Collection Features. SP 2010

I have a solution that creates a new send to connection for a web application. When deploying from visual studio the feature get activated with no errors and creates the connection. When I try to ...
0
votes
2answers
285 views

deployment of designer workflow from test to production

I have created a SPD designer workflow in my test environment and want to deploy onto production. Please let me know the each steps in details as I would be doing 1st time
0
votes
0answers
33 views

Deployment time at Visual Studio's output window

I am deploying webpart solution or another wsp project from Visual Studio and i need to see finishing time. Are there any way to see the time when deploy finished or any error occured for interrupt ...
1
vote
1answer
122 views

Add PHP Intranet Site to sharepoint

I have been given files for a whole PHP Intranet portal to add to sharepoint and i have no idea how its done. The site runs on port 82. The database i'm using is MS-SQL server 2008. Can anyone help me ...
4
votes
2answers
619 views

Problem with SP2013 solution scope: WebApplication vs GAC

I have a SP2013 solution that contains a custom WCF service, custom Timer Job and a Feature Event Reciever. Because of these the solution Assembly Deploying Target is set to GlobalAssemblyCache. The ...
3
votes
1answer
40 views

Deploying client-side cloud-ready modules

I am a big advocate of client side code and using the client-side API in SP2013 / SP Online. For me, it's really important that my solutions can be deployed to the cloud as well as on-prem. And thus i ...
0
votes
2answers
268 views

Sandboxed solution deployed activated, in Site Collection Features but not in Manage site features?

I have a sandboxed feature I deployed successfully. It is activated when I check in Site collection features, but when I go to Manage site features it is not there to activate. What am I missing? ...
0
votes
1answer
25 views

Binding documents along with a custom webpart

I have these 2 two word documents which should be added to the web part ( a document library ) as soon as it is deployed. Is there any way to bind documents in a web part (during custom development) ...
4
votes
1answer
81 views

How to deploy centrally managed Infopath forms with reusable workflows to a new environment

I am looking for a way of deploying solutions based on infopath and reusable workflows through development, test and production in a consistent manner. Can anyone outline a robust approach to the ...
0
votes
1answer
214 views

“The system cannot find the file specified” message while deploying new feature

I'm trying to deploy a new feature on sharepoint 2010 with scope web. The deploy seems to run successfully, but the feature is not prensent in feature manager. While visual Studio deploys the ...
0
votes
1answer
128 views

Deploy SharePoint app project and solution

When I created a solution of SharePoint MVC app, it is deployed and working fine. This is a test purpose. However when I created a SP MVC app project in an existing solution, am not able to deploy the ...
1
vote
0answers
130 views

SharePoint App Deployment error : 'Failed to install app for SharePoint'

I created a test MVC sharepoint app succesfully in a solution. Now I need to integrate this into a main solution project. But when I added a SharePoint MVC App into the solution and hit F5, I am ...
0
votes
0answers
20 views

Missing feature when deploing with -Local parameter

We have package with publishing page template and content type. All this stuff is in web scoped feature. Whe we deploys our package globally (wothout -local param) Install-SPSolution -Identity "Name" ...
3
votes
2answers
3k views

When do we need an IISreset after deployment?

Is there any good articles out there to explain when we need to do an IISreset after deployment? We are using SharePoint as an internet facing site, and try to not do an IISreset if it is not ...
1
vote
0answers
82 views

Move listitems in SharePoint Hosted app

I am trying to creating a SharePoint 2013 Hosted app that get a selected listitem and move it to another folder of library in the same web. When I debug my code everything runs without any problem. ...
1
vote
1answer
85 views

Custom library referenced in sharepoint project is not being put into GAC

I have a SharePoint 2010 project in a solution, and I have a library project in the solution. In the SharePoint project I've referenced to that project. Now when I deploy the SharePoint project, my ...
-1
votes
1answer
36 views

Deploying a sharepoint solution [closed]

I'm new to sharepoint site development. I've developed a sharepoint 2013 site and would like to view in user's mode. Currently it is in designer mode with edit options. But, I would like to view in ...
0
votes
1answer
241 views

How to replace the server name in the web application URL

I have a server named sv002, and I have created an intranet web application at the root of this server. So currently I am able to access the web application using the following URL: - http://sv002. ...
1
vote
1answer
1k views

Can not restore my site collection .No content databases in the web application were available to store your site collection.

I want to change the URL of my team site collection, to do so i have back-up the site collection from inside the old URL, and i want to restore it to the new URL. so i did the following:- -i create ...
0
votes
1answer
918 views

Is there a way to modify my SharePoint web URL to display a custom name instead of the servername/sites/intranet

I have created a new SharePoint 2013 web application, under the default port so the current web application URL is :- http://servername/sites/Intranet/ But our client is asking if there is a way to ...
1
vote
0answers
22 views

Requirments for running my web application under https

I have created a new web application that uses https. After that I added a new site collection to it, but my question is "will SharePoint web application and the site collection works under HTTPS out ...
0
votes
1answer
1k views

Deploy a single feature using SharePoint Management Shell with SharePoint 2013

I have been working in a development environment and deploying my custom web part features from Visual Studio directly by just hitting F5. I now need a way to deploy features separately to a test ...
1
vote
1answer
48 views

How to manage future updates for my APPs and site collections

My SharePoint 2013 environments are as follow:- I have three environments; Development, staging, production. Currently I have developed an intranet for our company, on the development env, then I ...
0
votes
2answers
34 views

Full deploy with customization

I have installed 2 VM's (DC/SQL box and a SP2010app/VS2012 box). I have created a web app with its initial root site collection (based on Blank Site). My goal is to prepare the dev environment so ...
0
votes
1answer
57 views

How do you deploy an edit/add custom form to Sharepoint 2010 without modifying views or data on target server?

I have a custom content type and list on a SharePoint 2010 server. The edit/add forms are custom, built in SharePoint Designer. I want to modify the layout of the forms including a new field, but ...
0
votes
1answer
107 views

Restoring a Team site collection inside another environment will display an empty white page

I have developed a team site inside my development machine, which contains the following :- 5 overlayed calendar Apps. One announcement APP One document management APP Script editor web part Content ...
0
votes
0answers
68 views

Restoring my Site collection from my development machine to my staging machine will show blank page

I have a team site collection inside my development machine; containing Apps, text, pictures, etc. So i back up the site collection from my development machine, i create a new web application inside ...
1
vote
1answer
225 views

How to customize SharePoint 2007 in Visual Studio 2010?

How to customize SharePoint 2007 in Visual Studio 2010
0
votes
1answer
50 views

Back-up a site collection that contain overlay calendars will keeping referencing the old calendars URL

I have a community site collection, which contain 5 calendars Apps, and I have overlayed 4 calendars together inside a general calendar. Then I have backup the site collection from my development ...
0
votes
1answer
267 views

Transfer my sharepoint application from one environment to another

I have SharePoint 2013 server & SQL server 2008 r2 inside my development and UAT environments. Currently inside my development environment I did the following main tasks:- I have created a new ...
0
votes
2answers
447 views

Master page giving error: System.NullReferenceException: Object reference not set to an instance of an object

So this is the scene: We have a sharepoint site with different portals. Each portal is deployed by its seperate wsp on same server.Now there is this staging server where all of us deploy our wsps for ...
0
votes
1answer
2k views

App installation failure due to App Management Shared Service Proxy

I have a SharePoint 2013 Foundation installation for development activity and when trying to deploy a SharePoint hosted App, I get the error: App Management Shared Service Proxy is not installed. ...
1
vote
0answers
109 views

VS 2013 not deploying silverlight solution in sandboxed on stand alone dev: SPUCWorkerProcess not running error

I have a stand alone machine with SP2010 set up on Windows Server 2008 R2. Office, SPD, VS2013, Expression, etc. There is no AD or anything as it is stand alone installation using local accounts and ...
2
votes
1answer
134 views

How does SharePoint 2010 manage versioned dlls in the GAC when referenced by multiple features?

We have multiple SharePoint projects and features that reference common library code. The library is versioned using the 4 part identifier (x.x.x.x). Each feature may reference a particular version ...
1
vote
1answer
315 views

Issue with deploying webpart in sharepoint 2010

We've created 2 webparts under a single visual studio solution as a farm environment. But after creating the WSP and trying to deploy it to our UAT, we are getting the following error This ...
0
votes
1answer
309 views

Custom Master Page Feature on Parent Site automatically getting activated on activating child's master page feature

I've created and deployed a custom master page and kept its scope to be Web because I want to apply to specific sites not the complete site collection. But when I activate feature at a specific site, ...
0
votes
1answer
97 views

SharePoint Deployment with third party assembly that requires a .dat file

I develop an SharePoint 2010 application with VS 2012. This application contains a third party dll that is embedded in the package manifest and deployed to gac. However, every time I deploy the ...
2
votes
2answers
211 views

Deploying Site Solution

EDIT to add more detail about what I'm trying to do: This is the first SP project I've worked on, so I might be making a very basic mistake with how the project is set up. The project consists of a ...
0
votes
1answer
82 views

SharePoint Online takes hour to install the sharepoint hosted app

I am trying to write SharePoint hosted app and connecting to microsoft online Sharepoint portal (dev site). It takes more than an hour to install the app on the sharepoint after I press F5 in Visual ...
0
votes
2answers
106 views

Assembly load errors after adding web application resources to solution with farm features

We have a solution that was recently changed from being globally deployed to deployed by web application in order to move binding redirects into the solution manifest (instead of using ...
0
votes
2answers
72 views

SharePoint 2010 no code deployment

Is it possible to deploy changes from a Staging environment to production environment without custom code or solution packages? Basically, I don't want to disturb an existing content. Suppose in dev ...
2
votes
1answer
958 views

Web Application scoped features not visible in Central Admin after installing solution with WebApplication scoped resources

In an effort to use WebConfigModifications less, I am trying to move some binding redirects and safe control entries into the solution manifest. The DeploymentTarget of the assembies is ...
2
votes
3answers
939 views

Files deployed in module cannot be found

I'm trying to deploy a selection of pages and master pages in modules but I'm encountering the same problem with all of them. When I try to navigate to a page, I get a File Not Found error (with ...
1
vote
1answer
204 views

Solution deployment fails with error “Violation of PRIMARY KEY constraint 'PK_Classes'”

In our install script, which installs several solutions together, we found that solutions were occasionally failing to deploy with the following error in the ULS log: ...
4
votes
3answers
5k views

Error occurred in deployment step 'Recycle IIS Application Pool': Object reference not set to an instance of an object

I get this error in the deployment step of a share-point farm based project. Most of the suggested solutions on the net are a simple Visual Studio re-start, however, a simple VS restart won't fix ...