1
vote
1answer
19 views

Muilti deploy DLLs from external Projects into single WSP

I'm trying to build a single .WSP that should contains multiple DLLs from External projects. I've been following that this tutorial: Link I've followed all steps but on deploy , DLLS doesn't appear ...
1
vote
1answer
101 views

How does SharePoint 2010 manage versioned dlls in the GAC when referenced by multiple features?

We have multiple SharePoint projects and features that reference common library code. The library is versioned using the 4 part identifier (x.x.x.x). Each feature may reference a particular version ...
0
votes
0answers
81 views

SharePoint 2010 custom service with no GAC deployment

I am working with a Custom Share Point 2010 service development. The issue is if the Solution is scoped at GAC then I can access my Service with /mex extension, to the url. But, if the solution is ...
0
votes
2answers
256 views

Will be next SharePoint 13/15 have new deploy features?

Over the past couple of years I've been making solutions for SharePoint Server and always most important problem was the availability of the web-site. Deployment not-sandboxed solution is pain at ...
1
vote
1answer
78 views

What are the technical reasons to go for BIN deployment in SharePoint 2010?

In my current project, the team uses BIN deployment instead of the standard GAC deployment. The application is just a custom application using NHibernate as the ORM framework. I know thats not a good ...
1
vote
0answers
1k views

File not found on WebPart Deployment

I followed the Instructions on msdn and also this one here but unfortunatley nothing seems to work. I've built a custom webpart and packaged it into a .wsp file since i'm trying to import this ...
1
vote
1answer
2k views

Why am I getting this error? “The given assembly name or codebase was invalid.”

I have created and implemented the IHttpModule interface in order to use the Session_Start event in SharePoint 2010 (like global.asax in asp.net). I have added the add tag into my web.config file in ...
1
vote
5answers
3k views

SharePoint 2010 GAC deployment doesn't update

The following issue just crept up on me. The steps mentioned below had worked just fine until about 2 days ago. When I deploy a update to a solution (of web parts) to a SharePoint 2010 server I don't ...
0
votes
1answer
117 views

Is it possible to deploy a BDC model to BIN instead of the GAC

I have a BDC model which uses a .NET assembly to connect to an Oracle database. In order to make the connection working I need some ORA files in the same directory in the connecting assembly, so I ...
1
vote
2answers
1k views

Does replacing an assembly in the GAC cause a reset?

So, I have a web part I wrote that is not working correctly, I get "object reference not set to an instance of an object." it works fine in dev, but when I installed in prod, it doesn't. Anyway, if I ...