Debugging is a methodical process of finding and reducing the number of bugs, or defects, in a computer program or a piece of electronic hardware, thus making it behave as expected.

learn more… | top users | synonyms (1)

17
votes
5answers
3k views

Are there any tweaks, tips to make debugging SharePoint 2010 faster?

I am using Visual Studio 2010 Ultimate and SharePoint 2010. The debugging process itself is okay but the startup takes really long. Are there any options or hidden-hints to make this faster? Edit: I'...
17
votes
2answers
2k views

Can't start debugging after install VS11

After I installed VS11 Dev Preview, VS2010 cannot start debugging the Sharepoint 2010 server (developer install on Windows 7). I get a nice error dialog stating: Unable to start debugging on the ...
5
votes
3answers
7k views

How to get a web.config file in a sharepoint 2010 publishing site?

I am working on a sharepoint 2010 project and I noticed in the soultion their is no web.config. I asked one of my fellow co-workers and he mentioned something about we don't have access to to it as ...
4
votes
4answers
2k views

What techniques do you use to debug/test your SharePoint Timer Jobs?

I have developed a number of SharePoint Timer Jobs and they are always a bit more painful to debug and test than other areas of SharePoint. I was wondering what tools/techniques other people use to ...
3
votes
2answers
338 views

Is it possible to debug the DLL of a built in _layouts application page?

I'm getting a vague error (as below) on the built-in _layouts/ChangeFieldOrder.aspx page which uses the DLL "Microsoft.SharePoint.ApplicationPages". "Object reference not set to an instance of an ...
3
votes
1answer
2k views

How to load a sharePoint page in “safe mode”?

I seem to remember that there was a way to add something to the query string for a SharePoint page that would basically load the page in a "safe mode". In this mode you could delete or edit webparts. ...
3
votes
1answer
3k views

Is it possible to get detailed error messages in SharePoint Online?

When doing any sort of development/testing work against SharePoint Online, there are bound to be some errors. Some errors manifest in the form of exceptions, which can be logged to a special-purpose ...
3
votes
2answers
5k views

The breakpoint will not currently be hit - debuging feature receiver

I need to debug my feature receiver, so I set up few breakpoints, but when I hit F5 in VS2010, they are all missed, and it says that "The breakpoint will not currently be hit. No symbols have been ...
3
votes
2answers
4k views

Debugging SPFeatureReceiver

I have built an SPFeatureReceiver and am trying to debug it by attaching to the w3wp.exe process. No matter what I do no breakpoints are ever hit. Here are my steps Build and Package the solution ...
3
votes
1answer
856 views

Debugging remote event receiver - no context token

I am trying to use the MS supplied BasicDataOperations provider hosted app to play around with and learn about remote event receivers. I was following the instructions from this blog post by Chris O'...
2
votes
3answers
275 views

View callstack of unknown error

I've set <system.web> <customErrors mode="Off" /> </system.web> in my web.config file, but i'm still getting 'unknown error' instead of the stacktrace on my pages. How can I ...
2
votes
4answers
2k views

Debugging Feature Activation Trouble Attaching to W3WP.exe

I am using vs.net 2010 and having trouble debugging a feature activation. I have tried rebooting, reattaching etc. I have attached to w3wp processes (and vshost if it is available) and yet the debug ...
2
votes
1answer
105 views

How to debug a class library on a SharePoint 2013 Server?

I am learning to create a forms-based authentication for claims-based web application using custom membership and role provider based on the [msdn][1] link I will be building a class library to ...
2
votes
1answer
338 views

Debug FeatureUpgrading

Trying to debug FeatureUpgrading event receiver on Sharepoint 2013. Attached localy to all w3wp.exe processes. After run $MyFeature.Upgrade($true) feature get upgraded, but breakpoint inside ...
2
votes
1answer
1k views

Visual Studio 2013 - Workflow debugging prerequisites failed to complete

I am experiencing an issue with debugging SharePoint 2013 Workflows in a SharePoint App solution: Has anyone encountered this error?
2
votes
3answers
34 views

SharePoint 2013 not displaying Correlation ID when there is some error. Always displays a Runtime error page

One of my client's SharePoint 2013 site always displays the Runtime Error screen if there is some error instead of the "Sorry Something went wrong." page with the correlation ID. This makes ...
2
votes
1answer
101 views

Remotely debug Provider Hosted App from Visual Studio 2015

I have created a SharePoint Provider hosted App on Azure. I need to debug it now. I have enabled remote debugging from the Azure Portal. But when I try to debug it from Visual Studio, I get the ...
2
votes
3answers
757 views

Provider Hosted application often stops debugging

I have a very weird problem. I am trying to run a very basic provider hosted application on VS2013 (Update 3). The application stops debugging every now and then. The only thing I get in Output ...
2
votes
1answer
1k views

Feature activation suceeds in sandboxed server environment, but fails in SharePoint Online. How do I find what's wrong?

I am currently developing a solution in C# with a feature that uses the SharePoint API to create a number of sites, lists, list views etc. The final result is going to be used on SharePoint Online. ...
2
votes
2answers
972 views

Does anyone have ELMAH working with SharePoint?

Does anyone have ELMAH working with SharePoint 2010? I have the assembly in the bin folder and have what I believe to be the correct entries in the web.config file. I can run the test at http://...
2
votes
2answers
4k views

Debuging Event Receiver- Sharepoint 2013

I am trying to create ER for a document library, eg http://server.com/sites/dev I wanted to monitor document library for add and remove item. I created Empty SharePoint 2013 project ( Not sandboxed) ...
2
votes
2answers
837 views

How to debug sharepoint webservice?

I've followed Walkthrough: Creating a Custom ASP.NET Web Service and everything works fine. I just want to know how to enable debugging for this web service over network. Could you help me?
2
votes
1answer
98 views

File transformations before packaging WSP

I need to modify the content of some files in my SP 2010 project before packaging, something like Web.Config transformations. I need a file to have different content based on the environment: Debug, ...
2
votes
2answers
924 views

How do I debug a code-behind page in the Central Administration site

I built a custom timer job and created a configuration page (.aspx) for it. Going through the Central Administration site, I can get the to configuration page. When I enter values and click "OK" to ...
2
votes
2answers
2k views

How to determine if SharePoint is in Debug mode?

My SharePoint was choking on bad code in a feature. The VS12 debugger popped up and asked me if I wanted to enable debugging, and that it would update the web.config. Well, I would like to turn off ...
2
votes
1answer
244 views

Visual Studio debugger for SharePoint AutoHosted App

I'm using VS2013 for developing SharePoint Hosted App against a 365 development site. The VS debugger tool doesn't hit anymore my breakpoints. It used to the day before. I have made many tests, On ...
2
votes
1answer
505 views

Debugging custom membership provider - An unexpected error has occurred.

I used this video tutorial to get started and created a custom membership provider: http://channel9.msdn.com/Blogs/BomBom/Building-your-own-MemberShipProvider-in-ASPNET-20-and-use-it-in-SharePoint I'...
2
votes
2answers
8k views

Event Receiver Not Firing

I have an event receiver using the VS2010 template for SharePoint 2010 and I have coded it the same way I have done many times. This time, though, it is not firing at all. It is attached to the list ...
2
votes
0answers
1k views

Debugging XSLT in Visual Studio 2010 [closed]

I'm trying to debug XSLT for CQWP. I followed this guide. So I'm able to retrieve the XML, and link the files temporarily together using xsl:import. But then Visual Studio can't find the schema for ...
1
vote
3answers
78 views

Unable to debug TimerJob in Visual Studio 2012

I have create a timer job and deployed in SharePoint 2013. Debugging worked fine couple of times. After retract and redeploy couple of times. Now while attaching to OWSTIMER getting below error. ...
1
vote
2answers
286 views

How can I stop a broken webpart from killing the whole page?

The title says it all, when there's a error in my webpart I can't load the whole page. I'd like just to don't display the webpart and still see the rest of the page and not just get the error page. ...
1
vote
2answers
738 views

Debugging Problem with Sharepoint Foundation 2010

I've installed Sharepoint 2010 Foundation on my WS2008R2 copy... Whenever i lanch from Visual Studio some debug, the process couldn't attach to IIS and so every break point is skipped.. To male ...
1
vote
3answers
279 views

Debug Web Parts

I am studing this topic and I would like somebody to point me in the right direction for studying this. Debug Web Parts This objective may include but is not limited to: ULS log, and event log, debug....
1
vote
1answer
48 views

Any recommendations for SharePoint Online PowerShell Debugging Tools

I just discovered code.visualstudio.com, which even has intellisense for PowerShell scripts. Debugging those scripts, especially when the target is SharePoint Online, is a different matter. Does ...
1
vote
2answers
567 views

Debugging sandboxed solution?

I know this is a novice question, but my sandboxed solution works on one site and not the other. How/where can I actually see the errors generated by some sort of report? Debugging simply takes me to ...
1
vote
2answers
1k views

Possible to debug old solutions running in 2010 mode in a 2013 environment?

I've got a SharePoint 2013 VM for development using Visual Studio 2013. I've deployed an "old" 2010 wsp containing a visual webpart for using it within site collections running in 2010 mode in my 2013 ...
1
vote
2answers
2k views

Can't debug/deploy solution from VS 2010

I have encountered strange problem on my dev VM. Background: Having my VM open (VM Player), I put host computer into sleep mode, then I woke it and put into sleep mode for second time. After waking ...
1
vote
2answers
764 views

SharePoint very slow at Logging Correlation Data step in page trace

wondering if I configured something wrong. I just installed SharePoint on my laptop and it's running very slowly. It seems to be stuck at the Logging Correlation Data step. What exactly does this ...
1
vote
2answers
88 views

Could not load the Web.config configuration file. The given key was not present in the dictionary.

I'm trying to launch debugging on Visual Studio 2012 and it shows me this error message : By googling a little bit, I read that I should remove the 10 directory located in : C:/users/username/...
1
vote
3answers
2k views

Breakpoints not hitting as 'no symbols loaded'. Visual Studio 2012 c#

I'm attempting to debug an event handler and on the breakpoint I get the message that no symbols have been loaded when attaching to process. Is there any way I can figure out why this is? The ...
1
vote
1answer
37 views

Is it possible to selectively retract during F5-debug re-deployment?

Is there anyway I can select certain project features to remain deployed instead of being overwritten each time I F5-debug-deploy? ...other than creating multiple Solutions. If not, are there ...
1
vote
2answers
137 views

How to debug object model code?

Just finished coding an InfoPath form (C#, InfoPath 2010) on my local PC. Also, I copied the Microsoft.SharePoint.dll from the server to my local Windows 7 Enterprise environment with its respective ...
1
vote
1answer
451 views

Sharepoint 2010 alternate access mappings and HttpModule problem

I have encountered an interesting problem recently. I have a HttpModule, which i have added in modules runAllManagedModulesForAllRequests="true" node , by hand. The main site collection is at http: ...
1
vote
1answer
582 views

Cannot debug sharepoint solution

I have really strange problems with debuging sharepoint solution. Sometimes i cannot debug sharepoint webparts. Now i have such situation and nothing helps. I tried to restart computer\recycle pools\...
1
vote
1answer
2k views

Deploy event receiver to sandboxed solution

I am working with Sharepoint Foundation 2010 on both my development and production machines. My production site is hosted. I am trying to deploy a sandboxed event receiver to the production site ...
1
vote
0answers
31 views

SharePoint hosted app development, Less/Typescript and side-loading

I am doing some technology test for developing SharePoint hosted apps using Visual Studio 2013 in my SharePoint 2013 development environment. For that reason, I am trying to see how far I can push ...
1
vote
1answer
46 views

How to tackle error raised in 1 WFE out of 3 WFE?

Someone had asked this question but proper answer is not known, can anyone say what will be the proper answer for this? We have a SharePoint application spread on 3 WFE server. Now one component is ...
1
vote
1answer
58 views

Sending debug messages in sequential workflow

I'm trying to send messages to the workflow history of a workflow at some point after the workflow starts, based on a condition. There are some values in the code I would like to verify as the ...
1
vote
1answer
640 views

IIS hangs when debugging with Visual Studio

I keep having this ridiculous issue that's driving me mad. I happen to debug some code with Visual Studio (attached to all w3wp) and let's say I get an exception and VS is set to catch all exceptions. ...
1
vote
1answer
127 views

How to debug why i cannot add a webpart to a page in SP Designer

I have several custom webparts which i am attempting to add to a custom page WebPartZone using SPD2010. I can successfully add one, however when i attempt to add the other i get an "Error Creating ...