Debugging is a methodical process of finding and reducing the number of bugs, or defects, in a computer program or a piece of electronic hardware, thus making it behave as expected.

learn more… | top users | synonyms (1)

0
votes
2answers
187 views

Remote receivers debugging using azure service bus does not work

After i published app (not sure if related) to app o365 catalog (not store) i cannot debug app installed (or uninstalling) receivers using azure service bus anymore. I even tried removing remote ...
2
votes
1answer
187 views

Debugging remote event receiver - no context token

I am trying to use the MS supplied BasicDataOperations provider hosted app to play around with and learn about remote event receivers. I was following the instructions from this blog post by Chris ...
2
votes
1answer
374 views

Debugging custom membership provider - An unexpected error has occurred.

I used this video tutorial to get started and created a custom membership provider: http://channel9.msdn.com/Blogs/BomBom/Building-your-own-MemberShipProvider-in-ASPNET-20-and-use-it-in-SharePoint ...
1
vote
1answer
32 views

How to tackle error raised in 1 WFE out of 3 WFE?

Someone had asked this question but proper answer is not known, can anyone say what will be the proper answer for this? We have a SharePoint application spread on 3 WFE server. Now one component is ...
1
vote
1answer
277 views

IIS hangs when debugging with Visual Studio

I keep having this ridiculous issue that's driving me mad. I happen to debug some code with Visual Studio (attached to all w3wp) and let's say I get an exception and VS is set to catch all exceptions. ...
1
vote
1answer
82 views

How to debug why i cannot add a webpart to a page in SP Designer

I have several custom webparts which i am attempting to add to a custom page WebPartZone using SPD2010. I can successfully add one, however when i attempt to add the other i get an "Error Creating ...
1
vote
1answer
92 views

Adding new item to a list works in dev but not in prod

I have some code which simply gets a list, creates a new item with the appropriate fields, and adds the item to the list. The code worked perfect in the dev and UAT environments but since we deployed ...
0
votes
1answer
18 views

Can't debug SharePoint 2010 on a SP 2010 farm environment

I'm told I can't debug on a farm environment - one admin server, one web server, one SQL database, all separate boxes. But it seems like something you'd need to be able to do, so I'm looking for ...
0
votes
1answer
45 views

How to debug a solution in visual studio without deploying it

I'm running: Visual Studio 2013, Sharepoint 2013 and Microsoft SQL server 2012. I'm a beginer and I would like to know how to use the debug tool properly. I'm trying to debug my solution in visual ...
0
votes
1answer
494 views

FileNotFoundException :<nativehr>0x80070002</nativehr><nativestack></nativestack>

Error related To System.IO.FileNotFoundException`,trying to get survey 1,survey 2 from Custom list Survey list HAVING 2 Columns- 1)Title 2)Url :-Contain URL OF survey 1 or survey 2 Custom ...
0
votes
1answer
842 views

How to determine if SharePoint is in Debug mode?

My SharePoint was choking on bad code in a feature. The VS12 debugger popped up and asked me if I wanted to enable debugging, and that it would update the web.config. Well, I would like to turn off ...
0
votes
1answer
36 views

Debug DLLs in bin folder (SP 2013)

I'm using Sharepoint 2013 Foundation. I have configured Form Based Authentication. I wrote my own project to do the authentication (compiled into a DLL). Placed both DLL and PDB files in ...
0
votes
1answer
40 views

Read init params of workflow after it started

There's a sharepoint 2010 site of which I'm administrator. This site has a library with many items and workflows. One of the workflows is behaving wrong. I would like to look at the initialization ...
0
votes
0answers
13 views

Chrome Ends Debugging Session

I'm writing a SharePoint 2013 application in Visual Studio 2013, and I have an issue debugging in Chrome. The standard setting appears to be that the VS2013 debugging session ends automatically if I ...
0
votes
0answers
20 views

Failed to attach to debugger

I am working on a project in visual studio, and unable to attach w3wp process in visual studio, it's showing me that the attach was right, so the red circle appears solid, but when I refresh the page, ...
0
votes
0answers
19 views

VS Ribbon Button now showing, but its code created in SPD!

I have copied SPD created ribbon code into new Element.xml (VS -> Sharepoint 2013 Project -> Add New item -> Empty Element). I have deleted in SPD that custom action button. Created new feature for ...
0
votes
0answers
28 views

Debugging 2010 Solution running in SharePoint 2013 Environment (Comp Level 14)

I have a SharePoint 2013 environment where I created a site collection with compatibility level 14 (SharePoint 2010). Afterwards I deployed and successfully activated a SharePoint 2010 solution ...
0
votes
0answers
225 views

SharePoint WebParts. Attaching to ProteusDebugEngine debugger failed

I'm using Visual Studio 2010 Ultimate and SharePoint Foundation 2010. When I debug my VisualWebParts I have some errors: "Attaching to ProteusDebugEngine debugger failed. Invalid pointer." "Cannot ...
0
votes
0answers
629 views

debug feature activation

I have a visual studio project with Sharepoint Site structure. I didn't write any Event Receivers that will add my items (SP List Definitions, List Instances, ...) to the site. That means I use ERs ...
0
votes
0answers
930 views

How Sharepoint pages life cycle works?

I built a HttpModule for sharepoint. But when I begin to debug the page request, I notice that the debugging has an strange cycle: 1 - context_PreRequestHandlerExecute() 2- page_PreInit() 3 - ...
0
votes
0answers
77 views

How can Solve problems while debugging sharepoint web application?

Everytime I try to run my sharepoint application in debug mode, I get the error bellow:
0
votes
0answers
200 views

Sharepoint Solution showing old server url while debugging in visual studio 2010

I have a SharePoint solution which I developed in a server named HostA, and was deployed in the same server at the url, http://HostA:2100/ASD Later I moved the entire solution to a new server HostB, ...
0
votes
0answers
953 views

Unable to debug in an event receiver sharepoint 2010

When i debug in the event reciever(item adding) as soon as it reached the if condition i get the following error unable to automatically step into the server.The remote procedure could not be ...