Debugging is a methodical process of finding and reducing the number of bugs, or defects, in a computer program or a piece of electronic hardware, thus making it behave as expected.

learn more… | top users | synonyms (1)

1
vote
2answers
443 views

Debuging Event Receiver- Sharepoint 2013

I am trying to create ER for a document library, eg http://server.com/sites/dev I wanted to monitor document library for add and remove item. I created Empty SharePoint 2013 project ( Not sandboxed) ...
0
votes
0answers
11 views

Developer Dashboard for extended application

I have extended web application used by internal and external users . Recently the external users are facing performance issues ,so i enabled the developer dashboard . My concern is the developer ...
0
votes
0answers
32 views

SharePoint WebParts. Attaching to ProteusDebugEngine debugger failed

I'm using Visual Studio 2010 Ultimate and SharePoint Foundation 2010. When I debug my VisualWebParts I have some errors: "Attaching to ProteusDebugEngine debugger failed. Invalid pointer." "Cannot ...
1
vote
2answers
113 views

Workflow debugging prerequisites failed to complete - VS2013 Autohosted App

I am creating an auto-hosted app on VS2013. I am working with SharePoint Online and not locally. The problem is that when I try to enable the workflow debugging on my project I receive the error: ...
1
vote
0answers
40 views

"Unable to attach the process. Another debugger might be attached to the process” issue while debugging javascript?

I have an issue .. Currently im working on javascript file.. when I want to debug js file by using ie developer tool(F12) , It showing error : "Unable to attach the process. Another debugger might be ...
2
votes
1answer
34 views

Visual Studio debugger for SharePoint AutoHosted App

I'm using VS2013 for developping Sharepoint Hosted App against a 365 developpment site. The VS debugger tool doesn't hit anymore my breakpoints. It used to the day before. I have made many tests, - ...
1
vote
1answer
59 views

Debugging custom membership provider - An unexpected error has occurred.

I used this video tutorial to get started and created a custom membership provider: http://channel9.msdn.com/Blogs/BomBom/Building-your-own-MemberShipProvider-in-ASPNET-20-and-use-it-in-SharePoint ...
1
vote
1answer
17 views

How to debug why i cannot add a webpart to a page in SP Designer

I have several custom webparts which i am attempting to add to a custom page WebPartZone using SPD2010. I can successfully add one, however when i attempt to add the other i get an "Error Creating ...
2
votes
1answer
126 views

Visual Studio 2013 - Workflow debugging prerequisites failed to complete

I am experiencing an issue with debugging SharePoint 2013 Workflows in a SharePoint App solution: Has anyone encountered this error?
0
votes
3answers
49 views

Debugging a deployed solution residing in a server farm

I have deployed a solution on the server farm, through the PowerShell. I wish to be able to debug the execution of a specific button residing in an application page found inside the specific solution, ...
0
votes
2answers
77 views

Debug code in Napa ( Office 365 Online)

I have written a code to add an item in list in Office 365 using Napa. I have used client object model in the code. But the item doesnt get added in the list. Is there any way to debug the code in ...
2
votes
1answer
77 views

File transformations before packaging WSP

I need to modify the content of some files in my SP 2010 project before packaging, something like Web.Config transformations. I need a file to have different content based on the environment: Debug, ...
3
votes
1answer
2k views

Is it possible to get detailed error messages in SharePoint Online?

When doing any sort of development/testing work against SharePoint Online, there are bound to be some errors. Some errors manifest in the form of exceptions, which can be logged to a special-purpose ...
0
votes
3answers
442 views

How can I view Developer Dashboard from a custom master page or PowerShell?

I need to view Developer Dashboard data to investigate a bottleneck on a SharePoint deployment, but the master page has been customized and the Developer Dashboard is not available (after enabling it ...
0
votes
1answer
22 views

Debug DLLs in bin folder (SP 2013)

I'm using Sharepoint 2013 Foundation. I have configured Form Based Authentication. I wrote my own project to do the authentication (compiled into a DLL). Placed both DLL and PDB files in ...
2
votes
2answers
224 views

How to debug sharepoint webservice?

I've followed Walkthrough: Creating a Custom ASP.NET Web Service and everything works fine. I just want to know how to enable debugging for this web service over network. Could you help me?
0
votes
1answer
37 views

Debugging and running in Microsoft Windows SharePoint Services 3.0

I have been given some source code for a solution written for Microsoft Windows SharePoint Services 3.0 - with no instructions for how to get it up and running in Visual Studio. I've installed Visual ...
1
vote
2answers
5k views

Event Receiver Not Firing

I have an event receiver using the VS2010 template for SharePoint 2010 and I have coded it the same way I have done many times. This time, though, it is not firing at all. It is attached to the list ...
0
votes
0answers
211 views

debug feature activation

I have a visual studio project with Sharepoint Site structure. I didn't write any Event Receivers that will add my items (SP List Definitions, List Instances, ...) to the site. That means I use ERs ...
0
votes
0answers
23 views

Can't consume ANY Service Application from my farm

I am trying to consume with my Sharepoint development server a Search Service Application from another Sharepoint farm. I have followed the steps from this blog post, redone it three times, always ...
0
votes
1answer
318 views

EventReceivers not firing at all

I wrote some code to do some things before and after an item is added to some lists. The solution is sandboxed. I have checked and confirmed, through power shell, that the event receivers are bound ...
0
votes
1answer
164 views

Deploy VS2012 SharePoint 2010 Two Projects in Solution - Cannot see 2nd Feature in SharePoint

This is probably going to sound vague, but I have two C# SharePoint projects within a solution. I have been working on Project 1 for a while and it gets deployed to my local instance of SharePoint on ...
1
vote
1answer
60 views

Adding new item to a list works in dev but not in prod

I have some code which simply gets a list, creates a new item with the appropriate fields, and adds the item to the list. The code worked perfect in the dev and UAT environments but since we deployed ...
0
votes
2answers
306 views

Sharepoint 2013 App won't retract when debugging stopped

I'm trying out simple SP 2013 SharePoint hosted apps against an Office 365 2013 dev site. When I start debugging the apps install fine; when I stop debugging no retraction occurs, I'm having to ...
0
votes
1answer
36 views

SharePoint 2010 Development Setup

Is it possible to develop in Visual Studio on the host machine while F5 deploying/debugging a SharePoint WSP to a VM with SharePoint 2010 installed? I have had significant issues with Visual Studio, ...
0
votes
0answers
496 views

How Sharepoint pages life cycle works?

I built a HttpModule for sharepoint. But when I begin to debug the page request, I notice that the debugging has an strange cycle: 1 - context_PreRequestHandlerExecute() 2- page_PreInit() 3 - ...
0
votes
0answers
72 views

How can Solve problems while debugging sharepoint web application?

Everytime I try to run my sharepoint application in debug mode, I get the error bellow:
0
votes
1answer
40 views

Read init params of workflow after it started

There's a sharepoint 2010 site of which I'm administrator. This site has a library with many items and workflows. One of the workflows is behaving wrong. I would like to look at the initialization ...
0
votes
0answers
117 views

Sharepoint Solution showing old server url while debugging in visual studio 2010

I have a SharePoint solution which I developed in a server named HostA, and was deployed in the same server at the url, http://HostA:2100/ASD Later I moved the entire solution to a new server HostB, ...
1
vote
2answers
181 views

How can I stop a broken webpart from killing the whole page?

The title says it all, when there's a error in my webpart I can't load the whole page. I'd like just to don't display the webpart and still see the rest of the page and not just get the error page. ...
0
votes
2answers
475 views

ASP.NET/C# equivalent to js alert() or php echo

I am trying to debug a method and need to trace how a variable is being changed to see where I went wrong. What in ASP.NET/C# could I use to do this? For example if it was php I could stick an echo ...
15
votes
2answers
1k views

Can't start debugging after install VS11

After I installed VS11 Dev Preview, VS2010 cannot start debugging the Sharepoint 2010 server (developer install on Windows 7). I get a nice error dialog stating: Unable to start debugging on the ...
1
vote
2answers
96 views

How to debug object model code?

Just finished coding an InfoPath form (C#, InfoPath 2010) on my local PC. Also, I copied the Microsoft.SharePoint.dll from the server to my local Windows 7 Enterprise environment with its respective ...
0
votes
3answers
2k views

Debugging sandboxed ItemUpdated event receiver - breakpoints not hit

I'm trying to debug an ItemUpdated event receiver in SharePoint 2010. I add breakpoints to the code, and hit F5 in Visual Studio 2010. I click Attach when I'm prompted to attach to the process. Then, ...
1
vote
1answer
386 views

Sharepoint 2010 alternate access mappings and HttpModule problem

I have encountered an interesting problem recently. I have a HttpModule, which i have added in modules runAllManagedModulesForAllRequests="true" node , by hand. The main site collection is at http: ...
0
votes
1answer
133 views

Visual Studio 2010 opens “Create New Site” page in browser when I run “Start Debugging” instead of the site I am trying to debug

I am an Office 365 user and fairly new to Sharepoint. I am trying to write a sandboxed solution for SharePoint online. To do this, I have setup a local developer environment and am currently trying ...
1
vote
2answers
1k views

Can't debug/deploy solution from VS 2010

I have encountered strange problem on my dev VM. Background: Having my VM open (VM Player), I put host computer into sleep mode, then I woke it and put into sleep mode for second time. After waking ...
1
vote
3answers
258 views

Debug Web Parts

I am studing this topic and I would like somebody to point me in the right direction for studying this. Debug Web Parts This objective may include but is not limited to: ULS log, and event log, ...
14
votes
5answers
2k views

Are there any tweaks, tips to make debugging SharePoint 2010 faster?

I am using Visual Studio 2010 Ultimate and SharePoint 2010. The debugging process itself is okay but the startup takes really long. Are there any options or hidden-hints to make this faster? Edit: ...
3
votes
2answers
2k views

Debugging SPFeatureReceiver

I have built an SPFeatureReceiver and am trying to debug it by attaching to the w3wp.exe process. No matter what I do no breakpoints are ever hit. Here are my steps Build and Package the solution ...
0
votes
1answer
374 views

Debugging a Timer Job

I was not able to do something a little more elaborate with my timer job so I decided to check if something basic works. So I tried the code below - but it keeps giving me this error - why? UPDATE ...
2
votes
1answer
777 views

Feature activation suceeds in sandboxed server environment, but fails in SharePoint Online. How do I find what's wrong?

I am currently developing a solution in C# with a feature that uses the SharePoint API to create a number of sites, lists, list views etc. The final result is going to be used on SharePoint Online. ...
1
vote
1answer
288 views

Cannot debug sharepoint solution

I have really strange problems with debuging sharepoint solution. Sometimes i cannot debug sharepoint webparts. Now i have such situation and nothing helps. I tried to restart computer\recycle ...
0
votes
1answer
343 views

Changing Deployment Url for Webpart in VS 2008

I am trying to debug a webpart in SharePoint 2007 using Visual Studio 2008. When I click debug, it deploys the solution to http://localhost:8080. The url I want to deploy to is on a different port. ...
0
votes
1answer
293 views

Expiration Policy Job - debugging

I am trying to find out what error is preventing our Expiration Policy timer job from completing. It is scheduled daily about 10PM. Sometimes when I come in in the morning it is Aborted, sometimes ...
0
votes
2answers
356 views

Debugging Problem with Sharepoint Foundation 2010

I've installed Sharepoint 2010 Foundation on my WS2008R2 copy... Whenever i lanch from Visual Studio some debug, the process couldn't attach to IIS and so every break point is skipped.. To male ...
0
votes
0answers
777 views

Unable to debug in an event receiver sharepoint 2010

When i debug in the event reciever(item adding) as soon as it reached the if condition i get the following error unable to automatically step into the server.The remote procedure could not be ...
0
votes
1answer
81 views

64 bit vs. 32 bit - Significantly longer time to attach the debugger

Since switching to a 64-bit dev environment on Sharepoint 2007, I've noticed it takes orders or magnitude longer to attach the Visual Studio debugger to the OOTB SharePoint assemblies and my custom ...
0
votes
2answers
2k views

How to figure out why I'm getting “HttpCompileException was unhandled by user code”?

I am brand new to SharePoint, SharePoint development, and MS development. My SharePoint dev environment consists of Windows 2008, SharePoint 2010, and Visual Studio 2010. I created a very simple ...
3
votes
2answers
197 views

Is it possible to debug the DLL of a built in _layouts application page?

I'm getting a vague error (as below) on the built-in _layouts/ChangeFieldOrder.aspx page which uses the DLL "Microsoft.SharePoint.ApplicationPages". "Object reference not set to an instance of an ...