Debugging is a methodical process of finding and reducing the number of bugs, or defects, in a computer program or a piece of electronic hardware, thus making it behave as expected.

learn more… | top users | synonyms (1)

0
votes
2answers
442 views

Can't load break points for a feature reciever - what's wrong?

I've set a break point in my feature receiver, but symbols never load and break points never met, what can I do to resolve this?
0
votes
2answers
669 views

Sharepoint 2013 App won't retract when debugging stopped

I'm trying out simple SP 2013 SharePoint hosted apps against an Office 365 2013 dev site. When I start debugging the apps install fine; when I stop debugging no retraction occurs, I'm having to ...
0
votes
2answers
766 views

ASP.NET/C# equivalent to js alert() or php echo

I am trying to debug a method and need to trace how a variable is being changed to see where I went wrong. What in ASP.NET/C# could I use to do this? For example if it was php I could stick an echo ...
0
votes
2answers
2k views

debug javascript [closed]

I have a javascript thats breaking. Now Is there a way i can call the function from content editor web part and debug to see where the hick up is?
0
votes
1answer
84 views

64 bit vs. 32 bit - Significantly longer time to attach the debugger

Since switching to a 64-bit dev environment on Sharepoint 2007, I've noticed it takes orders or magnitude longer to attach the Visual Studio debugger to the OOTB SharePoint assemblies and my custom ...
0
votes
2answers
23 views

Debugging an SP Feature in production

I have developed an SP Feature in C# and tested in development environment, confirming it is functioning correctly. When I publish to production and enable on a site, I just get a single line in the ...
0
votes
1answer
62 views

Default SPEmailEventReceiver: Object reference not set to an instance of an object

I'm trying to write a new Email Event Receiver for an email-enabled document library. When my feature is disabled, email is delivered successfully to the library. When my feature is enabled, this ...
0
votes
2answers
24 views

Objects deployed at debug remain after debug stopped

I'm at my first developement in Sharepoint. I'm using VS2013 Ultimate with Sharepoint Foundation 2013 on a Windows 2008 R2. I started creating a custom list and some site columns. The first debug runs ...
0
votes
2answers
23 views

Sharepoint debugger process

Let's say I have a SharePoint web application running in my local machine. I want to debug a visual web part so that I can check what's wrong with my code. To start debugging I usually do the ...
0
votes
3answers
246 views

How to debug Napa SharePoint app

I've made a simple app in "Napa" Office 365 Development Tools. It's a SharePoint app that returns the current site lists. This is the rest call: site + /_api/web/lists When i debug this app it ...
0
votes
1answer
61 views

Debugging and running in Microsoft Windows SharePoint Services 3.0

I have been given some source code for a solution written for Microsoft Windows SharePoint Services 3.0 - with no instructions for how to get it up and running in Visual Studio. I've installed Visual ...
0
votes
1answer
391 views

EventReceivers not firing at all

I wrote some code to do some things before and after an item is added to some lists. The solution is sandboxed. I have checked and confirmed, through PowerShell, that the event receivers are bound to ...
0
votes
1answer
41 views

SharePoint 2010 Development Setup

Is it possible to develop in Visual Studio on the host machine while F5 deploying/debugging a SharePoint WSP to a VM with SharePoint 2010 installed? I have had significant issues with Visual Studio, ...
0
votes
1answer
141 views

Visual Studio 2010 opens “Create New Site” page in browser when I run “Start Debugging” instead of the site I am trying to debug

I am an Office 365 user and fairly new to Sharepoint. I am trying to write a sandboxed solution for SharePoint online. To do this, I have setup a local developer environment and am currently trying ...
0
votes
1answer
477 views

Changing Deployment Url for Webpart in VS 2008

I am trying to debug a webpart in SharePoint 2007 using Visual Studio 2008. When I click debug, it deploys the solution to http://localhost:8080. The url I want to deploy to is on a different port. ...
0
votes
1answer
363 views

Expiration Policy Job - debugging

I am trying to find out what error is preventing our Expiration Policy timer job from completing. It is scheduled daily about 10PM. Sometimes when I come in in the morning it is Aborted, sometimes ...
0
votes
1answer
86 views

call method in webpart

I'm trying to debug the code below. For some reason the GetUserProperties Method isn't called during debug. Can someone tell me how i'm able to call it? I wan't to display the user-properties in an ...
0
votes
2answers
5k views

How to figure out why I'm getting “HttpCompileException was unhandled by user code”?

I am brand new to SharePoint, SharePoint development, and MS development. My SharePoint dev environment consists of Windows 2008, SharePoint 2010, and Visual Studio 2010. I created a very simple ...
0
votes
0answers
13 views

Chrome Ends Debugging Session

I'm writing a SharePoint 2013 application in Visual Studio 2013, and I have an issue debugging in Chrome. The standard setting appears to be that the VS2013 debugging session ends automatically if I ...
0
votes
1answer
26 views

Can't debug SharePoint 2010 on a SP 2010 farm environment

I'm told I can't debug on a farm environment - one admin server, one web server, one SQL database, all separate boxes. But it seems like something you'd need to be able to do, so I'm looking for ...
0
votes
0answers
24 views

Failed to attach to debugger

I am working on a project in visual studio, and unable to attach w3wp process in visual studio, it's showing me that the attach was right, so the red circle appears solid, but when I refresh the page, ...
0
votes
1answer
50 views

How to debug a solution in visual studio without deploying it

I'm running: Visual Studio 2013, Sharepoint 2013 and Microsoft SQL server 2012. I'm a beginer and I would like to know how to use the debug tool properly. I'm trying to debug my solution in visual ...
0
votes
1answer
610 views

FileNotFoundException :<nativehr>0x80070002</nativehr><nativestack></nativestack>

Error related To System.IO.FileNotFoundException`,trying to get survey 1,survey 2 from Custom list Survey list HAVING 2 Columns- 1)Title 2)Url :-Contain URL OF survey 1 or survey 2 Custom ...
0
votes
0answers
19 views

VS Ribbon Button now showing, but its code created in SPD!

I have copied SPD created ribbon code into new Element.xml (VS -> Sharepoint 2013 Project -> Add New item -> Empty Element). I have deleted in SPD that custom action button. Created new feature for ...
0
votes
3answers
846 views

Breakpoints not hitting as 'no symbols loaded'. Visual Studio 2012 c#

I'm attempting to debug an event handler and on the breakpoint I get the message that no symbols have been loaded when attaching to process. Is there any way I can figure out why this is? The ...
0
votes
0answers
28 views

Debugging 2010 Solution running in SharePoint 2013 Environment (Comp Level 14)

I have a SharePoint 2013 environment where I created a site collection with compatibility level 14 (SharePoint 2010). Afterwards I deployed and successfully activated a SharePoint 2010 solution ...
0
votes
2answers
206 views

Remote receivers debugging using azure service bus does not work

After i published app (not sure if related) to app o365 catalog (not store) i cannot debug app installed (or uninstalling) receivers using azure service bus anymore. I even tried removing remote ...
0
votes
2answers
285 views

workflow debugging prerequisites failed to complete - Visual Studio SharePoint hosted Apps

When trying to debug a workflow created in SharePoint 2013 App using Visual Studio 2012 version, i am getting the error "workflow debugging prerequisites failed to complete". I tried to publish the ...
0
votes
2answers
907 views

How to determine if SharePoint is in Debug mode?

My SharePoint was choking on bad code in a feature. The VS12 debugger popped up and asked me if I wanted to enable debugging, and that it would update the web.config. Well, I would like to turn off ...
0
votes
0answers
235 views

SharePoint WebParts. Attaching to ProteusDebugEngine debugger failed

I'm using Visual Studio 2010 Ultimate and SharePoint Foundation 2010. When I debug my VisualWebParts I have some errors: "Attaching to ProteusDebugEngine debugger failed. Invalid pointer." "Cannot ...
0
votes
1answer
39 views

Debug DLLs in bin folder (SP 2013)

I'm using Sharepoint 2013 Foundation. I have configured Form Based Authentication. I wrote my own project to do the authentication (compiled into a DLL). Placed both DLL and PDB files in ...
0
votes
0answers
658 views

debug feature activation

I have a visual studio project with Sharepoint Site structure. I didn't write any Event Receivers that will add my items (SP List Definitions, List Instances, ...) to the site. That means I use ERs ...
0
votes
1answer
313 views

Deploy VS2012 SharePoint 2010 Two Projects in Solution - Cannot see 2nd Feature in SharePoint

This is probably going to sound vague, but I have two C# SharePoint projects within a solution. I have been working on Project 1 for a while and it gets deployed to my local instance of SharePoint on ...
0
votes
3answers
966 views

How can I view Developer Dashboard from a custom master page or PowerShell?

I need to view Developer Dashboard data to investigate a bottleneck on a SharePoint deployment, but the master page has been customized and the Developer Dashboard is not available (after enabling it ...
0
votes
0answers
957 views

How Sharepoint pages life cycle works?

I built a HttpModule for sharepoint. But when I begin to debug the page request, I notice that the debugging has an strange cycle: 1 - context_PreRequestHandlerExecute() 2- page_PreInit() 3 - ...
0
votes
0answers
77 views

How can Solve problems while debugging sharepoint web application?

Everytime I try to run my sharepoint application in debug mode, I get the error bellow:
0
votes
1answer
40 views

Read init params of workflow after it started

There's a sharepoint 2010 site of which I'm administrator. This site has a library with many items and workflows. One of the workflows is behaving wrong. I would like to look at the initialization ...
0
votes
0answers
205 views

Sharepoint Solution showing old server url while debugging in visual studio 2010

I have a SharePoint solution which I developed in a server named HostA, and was deployed in the same server at the url, http://HostA:2100/ASD Later I moved the entire solution to a new server HostB, ...
0
votes
1answer
472 views

Debugging a Timer Job

I was not able to do something a little more elaborate with my timer job so I decided to check if something basic works. So I tried the code below - but it keeps giving me this error - why? UPDATE ...
0
votes
0answers
959 views

Unable to debug in an event receiver sharepoint 2010

When i debug in the event reciever(item adding) as soon as it reached the if condition i get the following error unable to automatically step into the server.The remote procedure could not be ...
0
votes
1answer
161 views

Can a sharepoint security patch automatically upgrade your sharepoint installation.

Can a sharepoint security patch automatically upgrade your sharepoint installation. Recently my company experienced an outage after installing a bunch of Microsoft Security patches and automatic ...