A configuration is an arrangement of functional units according to their nature, number, and chief characteristics. Often, configuration pertains to the choice of hardware, software, firmware, and documentation. The configuration affects system function and performance.

learn more… | top users | synonyms

1
vote
1answer
249 views

Sharepoint 2010 XML schemas

When developing in Sharepoint I noticed you eventually end-up editing lots of XML files: Feature.Template.xmls, Package.Template.xmls etc. Although VS is helpful with auto-completion, I don't really ...
1
vote
1answer
185 views

Read configuration section in WebApplication scoped code with CAS

I'm testing some code here, trying to get it to work with CAS. I have a configuration file at a file location with some WCF definitions. I load this code with: var config = ...
1
vote
2answers
75 views

Anonymous web view configuration problem

I got this problem when trying to set the anonymous access for my local environment. i got this sp2010 running on my windows 7-64. and when i try to set the authentication providers. the button is ...
1
vote
1answer
301 views

Quick Reference Guide for Site Settings?

Is there a "quick reference" guide or "cheat sheet" type document for each of the available options within the "Site Settings" page in Sharepoint 2007 ? The settings page that I'm talking about is ...
1
vote
3answers
317 views

How to set up a SharePoint 2010 developer machine?

As the release date for the public beta of SharePoint 2010 is coming closer and closer, I'm wondering how to set up a developer machine for it. I've heard that for developing on SharePoint a 64 bit ...
1
vote
1answer
600 views

sharepoint 2013 64bit Event 3759 Database not empty

I've recently just created a brand new sharepoint 2013 app server and I've been running into the following error in my event log pretty consistently at one hour intervals. My event log keeps telling ...
1
vote
1answer
35 views

Add local users to a site collection

What do I have to do, to add local users to a site collection? The web application is running with classic mode authentication. Active Diretory users do not have any problem to logon. But local users ...
1
vote
0answers
124 views

SP 2010 Service Pack 2 - The trial period for this product has expired

Brand new 2010 SP 2 install. Entered Enterprise key, successfully went through config wizard. I configured a couple of different web apps with team sites and both of them give me The trial period ...
1
vote
1answer
91 views

Activate SharePoint 2013 App catalog

I tried to install an app on SP 2013 when I got this message: It is my developer server for a school project so I have all the privileges needed. When I Googled the problem I found this page ...
1
vote
0answers
618 views

Failed to connect to the configuration database (Keyset does not exist)

I am trying to configure one of my WFE servers to connect to an existing database using SharePoint Foundation 2010. Every time I try to configure using the SharePoint Products Configuration Wizard I ...
1
vote
2answers
120 views

Automated deployment and environment-specific configuration

We are using TeamCity and Octopus Deploy to perform CI/CD with the custom WSP's that we use for SharePoint, and I'm currently trying to solve the problem of how to handle environment-specific ...
1
vote
0answers
20 views

SharePoint 2013 Installation Error [duplicate]

I have a problem in installing SharePoint foundation 2013 on my Window Server 2012 R2. When i run SharePoint Product Preparation tool , i am getting error like "the tool was unable to install ...
1
vote
2answers
3k views

Error running SharePoint 2010 Product Configuration Wizard after SP2 and July 2013 CU Update

I am having a problem upgrading my local SharePoint 2010 Development environment. I recently installed Service Pack 2 for SharePoint 2010 (KB2687453) and the SharePoint 2010 Cumulative Update Package ...
1
vote
2answers
4k views

Error occured in deployment step 'install app for SharePoint': The System Account cannot perform this action. Deploying App - On-Premises Farm

Yes this question is the same as : This question How ever none of the proposed solutions work for me. I've tried swapping the account in Central Admin (did not work) I've created a new AD account, ...
1
vote
0answers
74 views

Unable to connect configuration database after change domain

Because of unexpected reformat and upgrade to server, I now have a new AD and i have difficulty connection back to my sharepoint. Due to AD user that i used to connect server farm changed, i cant ...
1
vote
3answers
627 views

applicationSettings ignored in web.config

I've written a feature assembly that includes an SPFeatureReceiver. I can successfully deploy the feature's WSP, the assembly goes to the GAC, and the feature (mostly) does what it's supposed to. ...
1
vote
0answers
423 views

Macro message and Document Information panel error popup's on server

We use Moss 2007. We have documents in a page where we can create documents on the server. While creating new document, after Microsoft word gets opened, a pop up is showing up for all users The ...
1
vote
1answer
244 views

Search Server Express fails to provide results after changing content source to FQDN

I have SP Foundation site which is running Search Server Express. When the site collection, IIS, and SSE are configured for a FQDN rather than the default machine name, the crawling service ...
1
vote
0answers
87 views

Why can't I create a new issue tracking list alert with a daily or weekly digest?

A site owner in my site collection created a new Issue Tracking list from the default list template, then added a handful of custom columns from the default list of available column types. When they ...
1
vote
1answer
205 views

Configuring Mobile Account Using Google SMS

The procedure to configure a mobile account for SP uses SMSOffice.com. Is it possible to configure mobile account to use Google SMS service? If you have done this please provide some insight. If ...
1
vote
1answer
1k views

Aliasing the SQL Server name

I'm creating a new SP 2010 farm that will replace our existing 2007 farm (using the db attach method), and decided I should probably use SQL aliasing with this install. So 2 questions relating to ...
1
vote
1answer
51 views

Electronically Signing Emails From Built-in Workflows

Is there any way to electronically sign an email that originates from one of the built in SharePoint workflows? We have an internal policy that restricts users from following links in emails that are ...
1
vote
1answer
612 views

How to programmatically access values on “My Site Settings” page

I'm working on an automated SharePoint 2013 production environment deployment. I'm searching for a programmatic means of manipulating all values found on the "My Site Settings" page of CA. Reverse ...
1
vote
2answers
377 views

Are there any way to change the authentication type to claims based in code without using Powershell?

I'm creating an application that changes the authentication type to Claims based, but I'm trying not to use powershell. any advice?
0
votes
2answers
2k views

How should I set up my database instances for multiple SP2010 installs?

I'm setting up three SharePoint instances. We have a single database instance (DB\SP2010) that will hold all the databases for these three SP instances. Will this be overly confusing? Is there some ...
0
votes
1answer
30 views

Is it possible to have a configurable parameter in a SharePoint 2013 (on-premises) Farm solution?

I am developing a SharePoint 2013 custom WebPart using Visual Studio 2012 where on Page_Load event, I am calling a method RunProc() which executes a SQL Stored Procedure in some other server. When I ...
0
votes
2answers
97 views

Where to save farm-wide settings and configuration data?

I guess we've all been there. We want to store some settings for our WebPart / List / Custom App / Timer Job. Where do we save it? Multiple options exist: The various existing property bags ...
0
votes
1answer
168 views

What exactly is the content in “Back up content and configuration settings”?

In Central Administration for SharePoint 2010 when one runs a full farm back up there is an option that allows the user to back up content and configuration settings or just the configuration ...
0
votes
2answers
2k views

Is it possible to migrate and attach a wss 3.0 configuration database to a new Foundation 2010 front-end?

We are preparing to migrate from WSS 3.0 to 2010. WSS is currently on a x86 operating system, so migrating to a x64 operating system will be involved as well. My co-worker's thought is to turn up a ...
0
votes
1answer
12 views

my web application is corrupted how to create a new content database using same web application?

My web application is corrupted, how do I create a new content database using the same web application? What can I do ? I need to use same web application but with a new content database, I don't ...
0
votes
1answer
608 views

Unable to create new Web Application - Corrupted Site in IIS and SecureToken Service errors

I'm not able to create new Web Application, after do that the page in CA when I was creating Web App shows error that "Internet Explorer cannot displayed the websitebe" In IIS Site has a few less ...
0
votes
1answer
102 views

Config file throws error while deploying

I've created a new config-file "TimerJobs.config" which stores all my values for the timerjob (of course...) This file is located under the Layouts/random folder. The problem I'm having, is when I ...
0
votes
1answer
331 views

Workflow configuration by custom config file

I'm currently researching workflow configuration possibilities delivered by Sharepoint 2010 (I am meaning the Visual Studio development side). The kind of configuration I'm meaning is the one done by ...
0
votes
1answer
234 views

Error : “can't access this page”

I am the only user so far who can see share point page at this time. Have also checked user permissions, anonymous access, and also through group access and all looks right. Can you suggest the ...
0
votes
2answers
2k views

Cannot connect to the configuration database

I don't really know what to do. I was trying to get some bcs working, and because they were not, I've decided to restart the server. After it restarted I was unable to go on any site / page or on the ...
0
votes
2answers
3k views

Risks of using Permissive vs. Strict for Browser File Handling

We have some web sites in our SharePoint 2010 site collection that need to display SWF files (to play FLV videos). For SharePoint to render the videos, we go to the web application in Central Admin > ...
0
votes
1answer
210 views

Sharepoint 2010 - database reconfiguration after failure

We had major database crash and our master database got broken. Probably it will be rebuild so then we will have to configure logins and user mappings for sharepoint databases. Is there some kind of ...
0
votes
2answers
51 views

Recommendations on browsing a virtual SharePonit 2010 development environment

I currently have SharePoint 2010 installed on a virtual machine running Windows Server 2008 R2 Standard. This setup works fine except when browsing the site from the virtual machine which doesn't ...
0
votes
2answers
4k views

SP2010 - TMG publishing rule error: _vti_inf.html*

I'm getting an error related to URL http://server:80/_vti_inf.html* when i test the firewall rule for SharePoint 2010 connection on TMG server . All other path connections to SP site are fine. ...
0
votes
1answer
177 views

Is there any problem in Installing Sharepoint foundation patches and CU inside sharepoint server 2013 professional

I have live & staging SharePoint servers 2013. and i have installed the November 2014 CU on both of them, then i run the product configuration wizard. now when i run the following command on both ...
0
votes
1answer
41 views

will installing sharepoint enterprise 2013 on windows server 2012 R2 requires more specifications compared to windows 2008 R2

I have installed SP 2013 SP1 on windows server 2008 R2 many times. and now i will do my first SP 2013 installation inside windows server 2012 R2 instead of windows server 2008 R2. so i need to know if ...
0
votes
2answers
72 views

sharepoint 2013 unable to load user profile

we restored the 2010 user profile DB to 2013,we are getting the issue when we are clicking on like MySite "AboutMe" i am getting the error like "unable to load user profile" i checked the issue i am ...
0
votes
1answer
76 views

Unable to configure custom apps (from store) in Sharepoint Online

I added a few custom applications from Office store into our O365/SharePoint Online 2013 and they were smoothly installed and became visible in our Site Content. Only problem is that if I try to click ...
0
votes
1answer
47 views

Hiding Search Results Office 365

I am trying to hide search results for certain posts in a discussion board app from appearing in the search. Is this possible? I have added the field "Private" a yes/no field to the discussions. ...
0
votes
1answer
212 views

Do we need separate Unattended service account for each SharePoint Server 2013 BI service applications?

SharePoint 2013 - I'm planning to use 'unattended service account' method of Secure Store Service - for Excel, Performance Point and Visio services. I'm about to create Active directory accounts for ...
0
votes
1answer
45 views

Configuration details

I just inherited a SharePoint farm and am trying to sort through everything and figure out whats going on. Are there any tools built-in or 3rd party that can show me the current configuration details? ...
0
votes
1answer
1k views

Sharepoint configuration - create new server farm System.InvalidOperationException

Getting the below error: Failed to create the configuration database. An execption of type System.InvalidOperationException was thrown. Additional exception >information: An error occurred ...
0
votes
1answer
76 views

Web.config was wiped out by Visual Studio

Upon trying to edit our web.config file on our SharePoint 2010 Enterprise server via "wss\VirtualDirectories\80", Visual Studio started up to load the file for editing and then threw an error, ...
0
votes
3answers
2k views

How to change the from address name in the outgoing email settings in SharePoint 2010?

For some reason the from address on the list or library notifications I get are always prefixed with an "Administration". although I have the from address set up as CustomerPortal@MyCompany.com in ...
0
votes
1answer
272 views

Configuration failed: FileNotFoundException but not found in log

On a Windows Server 2012, I configured as a domain controller and installed SQL Server, then tried to install SharePoint, but I get a FileNotFoundException at the end of configuration: Strange ...