For questions completely specific to SharePoint 2013 and **not past or future versions**

learn more… | top users | synonyms (1)

2
votes
1answer
129 views

Upload user profile images from desktop to sharepoint using a windows service

All, I was so glad to find this community. I am sharepoint newbie and just started working on Sharepoint 2013. My task is to upload and set user profile images which are saved in a local disk (share ...
0
votes
1answer
164 views

System.IO.DirectoryNotFoundException: <nativehr>0x80070003</nativehr><nativestack></nativestack>

I'm working on a sharepoint server. It was SP2010+SQL2008 R2. I migrated it to SP2013 + SQL2012. Everything worked fine for days. I keep working on it. Then, I find that there is ONE webapp having ...
2
votes
1answer
211 views

Set SPNavigationNode to open in a new window using PowerShell in SharePoint 2013

Based off of several blog posts I attempted the code below: $n1 = New-Object -TypeName "Microsoft.SharePoint.Navigation.SPNavigationNode" -ArgumentList "People", "http://myURL", $true ...
0
votes
4answers
2k views

Add new Calendar in Office 365 SharePoint site

I just created a new SharePoint site in Office 365. My experience is with WSS and MOSS 2007, so I don't know SharePoint 2013 very well. In 2007, you have a large number of list types to choose from, ...
0
votes
2answers
173 views

Are attachments a built-in feature in SharePoint 2013?

I've seen some very mixed results while searching on the internet of whether attaching documents to a blog post is a built-in feature for SharePoint 2013 and I'm not sure what to believe. Most people ...
1
vote
1answer
34 views

SP2013 AD and import

I noticed without configuring the sync user profile service the name and telephone number come from the AD ( domain\newUser, Some Number, New User Name ). Why not the email ( or other camps)? is this ...
1
vote
0answers
92 views

SharePoint 2013 User Profile Service - Attributes Not Being Imported

My SP 2013 User Profile Service is configured to import all active users within 2 domains; external.company.com (external domain) and company.org (internal domain). The UPS is setup on the external ...
0
votes
1answer
65 views

Double click on ribbon save button

When a user add a new list item in a list, if he performs a double click on the ribbon's save button he founds that 2 list items have been inserted. How can I prevent this behaviour?
2
votes
1answer
751 views

Using Lookup Value in a JS Link Context - SP2013 Foundation

I am tasked with styling some lists for our Intranet Home Page. While I was fairly capable of this in SharePoint 2010 using Data Views and XSLT, I am trying to learn the new (and I think better) way ...
0
votes
0answers
33 views

Create a Workflow in Farm Solution. DefinitionID is zero

I want to create a new Workflow in my Farm Solution. So I right click in VS 2012 and add a new Workflow. It is a List Associated Workflow and has a History and a Task List associated. I'm running ...
0
votes
1answer
107 views

How to add List item using javascript with anonymus access in SharePoint Online?

I have a public site and I want to add a 'Subscribe Us' box to it, where anonymous users will enter there email addresses. This address will be added to a list and workflows should trigger emails. ...
5
votes
1answer
183 views

Is there a way to set the landing page of variations [without customizations]?

I know by default, when users navigate to the Variation Root Site, they are redirected to the appropriate top site of a variation label, based on the language setting of their Web browser. For ...
4
votes
2answers
168 views

Recommended method to retrieve user personal site URL

I use following method to retrieve URL of personal site: private string GetPersonalSite(SPSite site) { var curUser = SPContext.Current.Web.CurrentUser; ServerContext context = ...
1
vote
1answer
156 views

2013 App View List of Host Web with ListViewWebPart

Is it somehow possible to use the XsltListViewWebPart in the SharePoint-Hosted App to view and manipulate a List of the Hostweb? <WebPartPages:WebPartZone runat="server" FrameType="TitleBarOnly" ...
2
votes
1answer
194 views

Uninstall Workflow manager client

I have been fighting to get workflow manager installed and running on my dev server for about two weeks, installing/uninstalling/reinstalling over an over again. I was FINALLY able to get it working ...
0
votes
0answers
164 views

Sharepoint 2013: Workflow for Survey item created

How can I create a workflow for a survey item created in SharePoint 2013 version. I need to insert survey ID and survey name to another list. It would be more helpful, if this thing can be achieved ...
2
votes
1answer
435 views

Anything other than username in Person or Group column will not resolve only in quick edit mode

This is a SharePoint 2013 environment migrated from SharePoint 2010 (this works properly in the old 2010 environment). There's a “Person or Group” column present in a document library. When using ...
0
votes
0answers
59 views

create a workflow that takes users inputs (yes/no) adds to the attendance list for the event

How do I create a workflow or something that allows a user to create an event on the calendar with a set amount of seats. Then have people say yes or no to attending the event, have them added to a ...
1
vote
0answers
132 views

SP2013: Creating a Loop in a Workflow

I am attempting to create a workflow that has a loop. The idea is to have the loop check for date and time and returns the date/time to the list library that the workflow is connected to. As well ...
6
votes
1answer
268 views

How can I get suffix matching in a search in SharePoint 2013?

I'm new to SharePoint 2013 and I'm quite puzzled, that it seems to be impossible to search for the middle part of a string. Simple example: I've added a lot of documents (PDFs, ...) from our Windows ...
0
votes
2answers
71 views

Access current item from the page layout's aspx file

I am creating a page layout (without the associated html file) for my custom content type. One of the fields in my content type is a URL (Hyperlink or Picture) which should point to an image. How do ...
1
vote
1answer
167 views

How to use “SPTreeView” in sharepoint hosted app

I am developing SharePoint hosted app. In that I have to use SPTreeView to display root site content in the Tree view form. For the data source I have to use SPHierarchyDataSourceControl. But I don't ...
0
votes
0answers
15 views

Setting request length in custom sharepoint service

I have a custom webservice that works with sharepoint. I created mapped catalog named ISAPI and put my Service.svc with .cs in subcatalog according to this blog. Service is working fine, but I don't ...
0
votes
1answer
355 views

Employee Directory (from AD) as webpart in SP 2013

Perhaps I am missing it Is there a way to create a employee Dir list that pulls from AD in sharepoint. all my users data is in AD and syncing to SP I just need an easy way to concentrate it all ...
0
votes
2answers
379 views

Import File from SharePoint and Link this file with SharePoint (File- Excel File)

I am using SharePoint 2013 and Microsoft Office 2007 or above. Scenario: I upload a Excel file to a SharePoint 2013 list. Now, I want to import this Excel file from this SharePoint list back to ...
0
votes
1answer
91 views

How do you access the urls in a Managed Metadata Menu to have them open in a New Window?

I have a PowerShell Script that can build a 3-level Menu SharePoint 2013 MetaNavigation Menu of Links and Labels. The menu is driven by a CSV file with 4 entries: First-level Label, Second-Level ...
0
votes
0answers
83 views

Sharepoint 2013 - How to remove background from Promoted Links app?

I would like to add some shadow to my background image which I add to the promoted links tiles, but the promote links tiles itself has a background, which stops the shadow from doing what it needs to ...
1
vote
2answers
201 views

SharePoint 2013 setting custom masterpage featureactivated not working

I have used this code on many projects for 2010 on a site-scoped feature, and it has always worked: public override void FeatureActivated(SPFeatureReceiverProperties properties) { if (properties ...
0
votes
1answer
104 views

Users with Contribute permission level can share site/documents

I am using SP 2013,and we have bunch of users in the members group. We noticed they can share the site or documents. Why? Can i disable that? I dont want people with contribute permission to be ...
2
votes
1answer
35 views

Check which site collections are most used

We have a webapp with 18,000 site collections. We need to know which of those site collections are really used and which are not used at all. Thats all I need, which options do I have? powershell? ...
1
vote
0answers
36 views

How to get Search working on a single server workgroup installation of SharePoint Foundation 2013

How do you get Search working for a SharePoint Foundation 2013 installation on a single server in a workgroup (i.e. not part of a domain)?
0
votes
2answers
62 views

If user is in 2 groups and workflow sends an e-mail to both groups, will user get 2 e-mails?

I have a workflow that runs whenever a new item is added to a list. It sends an e-mail of the contents of that new list item to two groups: Group A Group B If user X is member of both group A and ...
0
votes
0answers
38 views

Add link to Icon in ChromeLoader

I'm using the following well documented Chromeloader.js on my client side 2013 app. i want to wrap a link around the "appIconUrl", can i do this for the JS or will it need to be done on the HTML page? ...
0
votes
0answers
25 views

SP2013 Connect to Outlook 2010 - mssing list of calendars to connect to

Last week I was setting up a demo team site on a on-prem SharePoint 2013 intranet. In order to shown the Outlook 2010 integration with a a certain team calendar, I clicked on the Outlook Connect ...
0
votes
1answer
147 views

Unable to set TaxonomyFieldValueCollection to SPListItem

I have a taxonomy field which is muti-allow. I have placed a taxonomy picker control in the application page and the values which are entered in that control are to be set in the list. My code is as ...
1
vote
1answer
830 views

JavaScript: How to reuse the “Working on it…” pop in

Sharepoint 2013: In have custom JavaScript code that makes Ajax calls. While loading I'd like to show Sharepoint's loading pop in: That is the one that greys out the underlying page and centers a ...
0
votes
3answers
40 views

Browsing sharepoint site using full domain shows blank page?

I have a server, when use machine name internally, ie. http://mySPServer it works fine. however, we want external users to access this site, the external url is http://mySPServer.myinc.com ...
0
votes
2answers
1k views

Get Icon URL and filename of document library file using JSOM in office 365 app

I have an app that includes a Document Library...using my normal code to display the list but keep getting a null on the field...i've tried rptDocsListItem1.get_item("xd_ProgID") and ...
1
vote
2answers
81 views

Pasting a rendered link to a rich-text column with the list in datasheet view

I'm trying to paste a rendered link, i.e., a link from within a Word or Excel file, into a rich-text column in SharePoint's datasheet view... Pasting from Excel, I get a working link, but it's the URL ...
1
vote
2answers
287 views

newfeed items disappear

We have a 2013 farm with the social stuff enabled. People are complaining that whatever they post on newsfeed is being lost. I suppose that this is related to the distributed cache service, I read ...
2
votes
3answers
747 views

Can SharePoint 2013 be configured & Installed without connecting to Active Directory

We want to build a public facing web site using SharePoint 2013 . but as the public facing web site will be accessed by public users, so can we configure and install the SharePoint server 2013 , ...
3
votes
1answer
341 views

Cannot move or delete links on left nav

The left nav menu on a 2013 site has begun misbehaving. A week ago it worked perfectly, but now whenever I use the "Edit Links" button, several symptoms appear: 1) All links appear with an "x" next ...
1
vote
0answers
100 views

My Site Settings: Language Options not applied

On a SharePoint 2013 Server CA Services Applications > User Profile Service > Setup My Sites: The Language Options check box: Allow user to choose the language of their personal site Checking in ...
2
votes
1answer
327 views

Visual Studio 2013 - Workflow debugging prerequisites failed to complete

I am experiencing an issue with debugging SharePoint 2013 Workflows in a SharePoint App solution: Has anyone encountered this error?
0
votes
1answer
139 views

(Calendar) list views disappear from view selector menu of list view webpart

Me and my colleague are having a problem with disappearing programatically created (Calendar) list views. After the creation of the site, the views are created correctly and are displayed in the view ...
0
votes
1answer
31 views

My Sites FollowedSitesUrl

I seem to be having a weird problem with My Sites. When it finishes creating the my site, the button in the homepage redirects to ...
0
votes
1answer
116 views

How is ViewsRecent in search results calculated?

I need to find the top 3 visited webs for the last 4 weeks and I need/want to do it via the REST search api. This is SharePoint 2013. The value ViewsRecent returned by a search query seems to be what ...
0
votes
1answer
158 views

Entity (External Content Type) cannot be found with Namespace = 'http://server1', Name = 'user_information'

I restored site collection backup from one farm to another. I am displaying data from this content type on one of my publishing site page. I had already created this external content type before ...
1
vote
0answers
62 views

Socialfeed not showing notifications from certain sites

We are having a problem with SharePoint 2013 in multiple environments. A user choose to follow a site (say a team site or a user blog) by clicking the "Follow" button in the top right. The users gets ...
1
vote
0answers
31 views

SharePoint sp.js not running on Silverlight page

I am using sp.js to display logged in user name on top of my publishing site page. The code is working fine on all pages except on one page where I am displaying ORG BROWSER web part which is ...