4
votes
1answer
86 views

Adding new site column to existing content type on multi language sites

I'm using the declarative SharePoint feature upgrade approach to : 1. Add a new custom column to site columns gallery 2. Add the new custom column to an existing content type There are two variation ...
0
votes
0answers
31 views

Custom Search to External Service

I am trying to add a custom search on the top static bar in SharePoint 2010. I created a delegate control to perform this task. I have tried multiple ways of creating a form text box and button and ...
1
vote
1answer
134 views

Cannot activate SharePoint Publishing Feature

despite placing the following code in my onet.xml, the publishing feature is not activated. <Feature ID="A392DA98-270B-4e85-9769-04C0FDE267AA"> <!-- PublishingPrerequisites --> ...
1
vote
2answers
78 views

What user data or customizations will I lose if I deactivate and reactivate a site collection feature

I am having problems with my embedded SSRS reports (print button missing) and it claims that my Report Viewer web part is not configured correctly, or something along those lines. I was thinking of ...
1
vote
1answer
27 views

2 exact the same features in different packages

I have a question, basically in a solution i have 2 packages which should be independent, but also should work properly together. So I have a feature which basically is required in both packages. I ...
2
votes
2answers
101 views

Copy user accounts across site collections

I am writing an archival Feature for a SharePoint 2010 list using C#. I have it copying the list items and all version history over to the new site collection but the Modified By and Created By fields ...
1
vote
0answers
91 views

2010 - Update-SPSolution required after solution installed?

I created a new feature and performed a Uninstall/Remove/Add/Install-SPSolution using PowerShell to deploy it. The solution deployed correctly and the feature was added to the 14 hive, but did not ...
1
vote
2answers
926 views

Sharepoint 2010 - feature not appearing in UI

Does anyone here know what could cause a new feature to not show up in the SharePoint UI? The solution it is part of has been correctly deployed to the GAC and shows up in the central administration ...
2
votes
1answer
31 views

Is there a relative URL for files hosted in the TEMPLATE\FEATURES directory?

Is there a relative URL for files hosted in the TEMPLATE\FEATURES directory? What I'm trying to do is re-provision data every time my feature is activated without deleting the SPList. The idea is to ...
0
votes
1answer
569 views

Hide “Customize Form” Button on List Ribbon

I am trying to hide the "Customize Form" button on the List ribbon: I have created a feature that deploys an Elements.xml file that looks like this: <?xml version="1.0" encoding="utf-8"?> ...
0
votes
1answer
43 views

Hide some MySite social features

I'm new at SharePoint 2010, and I'd like to implement social features. I used MySite, but there are too much possibilities, and I would like to hide (or disabled) some of them (red-cicled in the ...
0
votes
2answers
283 views

Managed metadata field grey when deploying with powershell

I have a powershell script that does the following: Create web application x Add and install some wsps Create site collection using a site definition deployed with one of the wsps. 3b. The ...
1
vote
2answers
316 views

How can the deployment of a feature (or element) be made dependent on the SharePoint version (2010/2013)?

I have a solution (deployed in the Sandbox) that declaratively creates CustomActions (menu items). It works fine in SharePoint 2010 and 2013, but we don't like the look in 2013 so I'd like to exclude ...
0
votes
2answers
658 views

Feature deactivation and webpart not being removed

I have a question regarding a feature and the webparts. Basically recently i noticed that when i deploy a webpart with my solution and it is bound to a feature on site collection scope, when it is ...
2
votes
1answer
296 views

SPListCollection.EnsureSitePagesLibrary() throwing SPException (specified title already exists in this Web site)

I am attempting to call SPListCollection.EnsureSitePagesLibrary() upon FeatureActivated. The method is throwing the following exception: Microsoft.SharePoint.SPException: A list, survey, ...
1
vote
1answer
814 views

Can't find WebApplication scoped feature

I've deployed a wsp that has 2 features. The one scoped at a web level is listed where I'd expect to see it and activates without a problem. The feature scoped at a web application can't be found ...
2
votes
1answer
115 views

How to activate content type on specific web?

I have site collection ex: http://microsoft.com/ and i got few child webs: http://microsoft.com/news/ http://microsoft.com/somethingelse/ <Elements ...
0
votes
1answer
95 views

Add custom code for solution upgrade

I have a solution for SP2010. Let's call it s.wsp. I had version 1 of s.wsp and now I have version 2 of s.wsp. Versions 1 and 2 share three common features: A, B and C. Version 2 adds a new feature D. ...
1
vote
2answers
863 views

Content deployment error; feature not installed

The business had a wish to copy content from production to acceptation (publishing environment). So I created a content deployment job to do so, and ran it. It failed with the following error: ...
2
votes
2answers
464 views

How to use one page layout for few content types

I have elements.xml with module: <Elements> <Module Name="IntranetNewsPageLayout" Url="_catalogs/masterpage"> <File Path="IntranetNewsPageLayout\IntranetNewsPageLayout.aspx" ...
3
votes
1answer
202 views

Update SPList.TemplateFeatureId

I need to update the TemplateFeatureId for a couple of lists in our SharePoint 2010 installation. The current TemplateFeatureId points to a feature that is no longer installed in the farm. Both ...
0
votes
4answers
2k views

How to programmatically get Feature ID?

In order to programmatically activate a feature, you need its Feature ID (some type of GUID) that is set in the .feature file. Is there a pretty way of retrieving this value programmatically, so that ...
0
votes
0answers
73 views

Site-scoped feature with both Modules and Visual Web Parts

I have a Feature with Modules that place files in the Master Page Gallery, and I recently added Visual Web Parts to the feature. Then I realized at some point the copying of files into the Gallery had ...
2
votes
1answer
146 views

Using solutions and features in creation/branding of SharePoint websites

I am new to SharePoint website creation and branding and I need your advice. For my first SharePoint site I have done the following: 1- Created/edited a master page. 2- Added CSS and JavaScript ...
0
votes
2answers
534 views

Web-scoped Feature falsely activated during Visual Studio deployment

In Visual Studio I have a solution containing two features with their Scope set to "Web". These two features work as expected but the only thing that is going "wrong" is that they are activated when I ...
0
votes
1answer
468 views

Modify the content of the home page programmatically in SharePoint 2010

First of all, I'm pretty new to SharePoint so don't shoot me if this is a noobish question or if I don't provide all the right information at once... :) I have a team-site in SharePoint with ...
0
votes
2answers
924 views

What's the connection between “Recently modified in Quick Launch” and the “SharePoint Server Publishing”-Feature?

First I had a plain Team Site without the Feauture "SharePoint Server Publishing" activated. I created several Site Pages, all rendered automatically without the annoying "Recently Modified". When I ...
0
votes
2answers
835 views

List ribbon button disappeared

I have a problem with a List ribbon button that disappears. The only thing that has happend that I know of is that the wsp was redeployed and the site-feature (which creates the list) was reactivated. ...
0
votes
0answers
30 views

Custom delegate is applied even if the feature is deactivated

I have a question regarding a feature. Situation: I have a feature that is farm scoped, with this feature I deploy a delegate control (xml file), this file refers to cs code. So I've added that file ...
3
votes
1answer
197 views

Site Scope Feature dependent on a Web Scope Feature

On the root web for my site collection I need to make sure a web scope feature is turned on. In the feature EventReceiver I can turn on the feature progamtically. How can I stop the user turning the ...
2
votes
2answers
999 views

Delete custom master page error on feature deactivation

I have a feature that deploys custom master pages to all sites in a site collection on activation, and want to delete all traces of the custom master pages on deactivation. On deactivation, after ...
1
vote
1answer
2k views

SharePoint 2010 solution not deploying correctly (features not available)

I have been working on a SharePoint 2010 solution on a server using Visual Studio. Unfortunately the server decided to die on me. Fortunately I have the solution backed up using source control and had ...
0
votes
0answers
25 views

SPContext is null on Feature Activation [duplicate]

Possible Duplicate: Error : Object reference not set to an instance of an object on feature deployment I am writing a feature receiver. Here is my code sample on feature_activated code. ...
1
vote
3answers
1k views

Cant´t activate a custom feature with PowerShell but with the GUI

I want to activate a custom feature with PowerShell on a few sites in my environment. When I´m doing this job over the GUI, everything is perfect. But when I´, doing it with my script, the feature ...
0
votes
2answers
693 views

Errors when attempting to install a sharepoint 2010 feature

I'm attempting to install and activate a feature containing a Timer Job. When I execute the install-spfeature cmdlet I get the following error. What is the source of my error? PS ...
1
vote
2answers
2k views

Column 'Document Id' not added to Library even after activating 'Document ID Service'

To enable document id feature in SP10, I followed the steps mentioned in the following posts: http://blogs.msdn.com/b/ecm/archive/2011/10/12/document-id-in-sharepoint-server-2010.aspx ...
1
vote
1answer
701 views

removing a sharepoint solution duplicates entry in web.config?

My intentions is to be able to add and remove web.config changes when a solution is installed or uninstalled. The code below and the powershell below works ALMOST as expected. When I add sp ...
0
votes
1answer
2k views

Provision listview webpart on page layout using feature

I've deployed a custom page layout using a module in a feature, like this: <?xml version="1.0" encoding="utf-8"?> <Elements xmlns="http://schemas.microsoft.com/sharepoint/"> <Module ...
1
vote
2answers
50 views

Customizing a feature: Site Options? Config List? Something else?

I'm developing a feature that renders a link on the user's screen, and I need that link's destination URL to be configurable by site collection administrators (SCAs) who are not developers. Where ...
0
votes
1answer
125 views

Using configuration of base web template in custom web template

I'm creating a custom web template, and I'd like for my configuration only to add the things I need above and beyond what's in the base web template (in my case, CMSPUBLISHING#0). My template works ...
0
votes
1answer
542 views

Column 'ListId' does not belong to underlying table ''

I am trying to run the following code I found somewhere here, but I got this exception on this line DataView dv = new DataView(dtResults); using (SPWeb web = properties.GetWeb()) { ...
0
votes
1answer
66 views

Strange exceptions ocurring

I am having very big trouble with features, my feature has the following site columns content type list tempalte list instance After fighting a lot, I removed the feature and created them again in ...
0
votes
1answer
546 views

Error on activating Publishing Feature SharePoint 2010

I am working with SharePoint 2010. I need to activate SharePoint Publishing Infrastructure Feature under Site Administration>Site Collection features. But when I try to activate this feature I get the ...
1
vote
2answers
367 views

How to upgrade a specific aspx or ascx file in an existing solution

In the current project, the solution is already existing, the solution has like 5 features and each feature deploys different things. The current development never used feature versions. So I ...
0
votes
1answer
61 views

Deploying an individual feature

I am using sharepoint software factory and have a number of features within it. How can I deploy an individual feature to my local dev farm, as opposed to the whole lot? Thanks
1
vote
2answers
449 views

Managing WebParts with dependencies on Web scoped Features

I have a Web scoped Feature which provisions a number of Content Types, List Templates & Instances, Custom Actions etc that enables a discrete set of functionality. I also have a number of ...
1
vote
2answers
438 views

Sharepoint 2010 and 'My Sites Blog'

I'm working with a customer to try to help them create a new site with a template they have created. I am able to reproduce the error locally, which is: The site template requires that the Feature ...
6
votes
3answers
14k views

Explain it to me: SharePoint deployment scope, solution and features

There are different levels of scope for deployment, but I have not been able to find a definitive explaination of when each applies and what the restrictions are that require loosening (or tightening) ...
1
vote
2answers
1k views

Activating OOTB Features Fails

I have a Farm with multiple Site Collections. One of these Site Collections refuses to activate 4 specific Out-of-the-Box (OOTB) Features, namely: aebc918d-b20f-4a11-a1db-9ed84d79c87e ...
1
vote
4answers
855 views

How to embed a CQWP into a master page or DelegateControl

I'm looking for a way to embed a pre-configured Content Query Web Part into a master page. In short, I have a SharePoint:DelegateControl on the master page and I want to plug the web part into it by ...