Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have a publishing and collaboration Farm, published a Managed Metadata Service and given Full Access to the collabortion Farm.

In the Collaboration Farm, created a User profile Property and associated with a Termset defined in the consumed Metadata Service. Users are allowed to edit/update the user Profile property, if I try to edit my profile the property is shown on the edit page, the terms are poping up against that property however the managed navigation picker is not getting displayed for that property.

In the same collaboration Farm, we have a locally managed metadata service, if i pick a termset from this and associate with a user profile property, it works perpectly and shows the metadata navigation picker against this property on the profile edit page.

I'm trying to understand the reason for this, is it something should be configured to get the metadata navigation picker on the user profile edit page on the collaboration farm?

Update:
I have associated the published metadata service connection with the default proxy group in the collaboration farm and granted the required permission to the collaboration farm account and the web-application's application pool logon account however still if I browser the term store in a web-application still it is not showing the termsets available in the "published metadata service".

I could create a site column on the collaboration farm based on the termset is available on the published metadata service however still it is not showing on the term store page and metadata navigation bar/picker is missing from the edit profile page on the collaboration farm.

What could be the issue? Is that by design?

share|improve this question
    
any help or Suggestions? –  Karthikeyan Mar 2 '11 at 22:38

1 Answer 1

Karthikeyan, have a look at this post on my blog.

I had the same problem a few days ago, basically it's not enough to have it associated via a proxy group. You need to check the first box in the Managed Metadata Proxy settings (the one that says This service application is the default sotrage location for keywords).

share|improve this answer
    
Yep, it should be a default storrage location for keywords which seems to be a bug for me. –  Karthikeyan Mar 14 '11 at 10:27
    
I agree completely. If you accept the answer please tick the checkmark in addition to upvoting. Thanks! –  Neil Richards Mar 14 '11 at 11:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.