Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Does SharePoint allow read-only permissions to a document library but allow users to edit or upload to a particular folder?

Here's my scenario....

I have a few AD groups in SP. They need read only permissions to a document library. There will be master docs in the main library that groups will need access to, but not be able to make changes or upload any docs in the library. However, these groups should be able to uploads docs in their department folders only and no one else's department folder.

I've done a few things but ran into some issues.

  1. Broke the document library inheritance from site.

  2. Gave document library read permissions

  3. For each department folder, I selected and "Share" and granted edit permission to the respective department allowing them access to upload.

Here's my problem. After doing this, users were able to upload docs in their department folder but when they click save, they receive a message, "Sorry, you don't have access to this page." When they click out the message, the document upload anyway.

Is there an easier way to accomplish this? I am also looking into creating a custom permission level, but I think I will have the same issue. How can groups contribute to their folders only but still have read only rights to top level document library?

EX of Doc Library

Accounting folder (only Accounting can contribute but Sales and HR can view) Sales folder (only Sales can contribute but Accounting and HR can view) Human Resources folder (only HR can contribute but Accounting and Sales can view) Exel doc (Accouting Sales and HR view only) Word doc (Accounting Sales and HR view only)

share|improve this question

2 Answers 2

Double check the permissions, you have it set up appropriately. It sounds as if you might have made a custom permissions level and not included an option allowing them to view application pages or something like that. Typically when you add a file to a document library, it'll then redirect you to the EditForm page to apply any metadata to the file.

share|improve this answer

In the step you described you missed the delete unique permissions also to the folders. If indeed you did it, you just have to check again. I suggest you to isolate some sample user and use the Check Permissions (button on the ribbon)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.