Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I’m installing a spanish lang pack on SP 2010 and Wizard that runs after installation gives a “failed to create sample data” error, plus this stack:

02/11/2011 11:31:59  14  ERR                      Exception: System.NullReferenceException: Object reference not set to an instance of an object.
   at Microsoft.SharePoint.SPEvaluatorModeProvisioner.IsProvisioned()
   at Microsoft.Office.Server.EvaluatorModeProvisioning.SharedEvaluatorModeProvisioner.IsProvisioned()
   at Microsoft.SharePoint.SPEvaluatorModeProvisioner.Provision()
   at Microsoft.Office.Server.EvaluatorModeProvisioning.SharedEvaluatorModeProvisioner.Provision()
   at Microsoft.SharePoint.PostSetupConfiguration.EvalModeProvisionTask.EvalProvision()
   at Microsoft.SharePoint.PostSetupConfiguration.EvalModeProvisionTask.Run()
   at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

Searched for this issue, tried couple recipes but no luck. Ideas truly appreciated, thanks!

share|improve this question

4 Answers 4

Workaround is to create a root site collection on port 80. That way, Wizard finishes successfully.

share|improve this answer
    
How do you do that? –  Saariko Feb 8 '13 at 20:56
    
Many Thanks for posting the answer! –  Joseph Caruana Jun 26 '13 at 15:37

I ran into the same problem, thanks for getting me on track!

For others trying to fix this issues, my steps were to open "SharePoint Central Administration" from the start screen, which opened a browser to my SharePoint server at port 45093.

From there, select "Application Management" and you will have options to create\delete etc site collections. In my case, I had to first DELETE my existing root site collection by selecting "Delete a Site Collection", opening the "Site Collection" menu, selecting "Change Site Collection", and selecting the collection located at the "/" URL. Once I deleted that site, I needed to go back in through "Create site collections" and build a new collection at the root URL (/).

Once that was finished, I was able to go to the Windows Start screen again (I'm using Windows Server 2013) and re-run the "SharePoint 2013 Products Configuration Wizard" which now completes successfully.

Thanks Ariel!

share|improve this answer

I had the same behaviour with SharePoint server 2013 but the main difference is that I didn't find any Site Collection in my installation.

To solve it, I create a new site collection on the root and then launch product configuration and it works!

share|improve this answer

It worked like Ariel and Michael told. Adding just one observation: after the deletion and recreate the root site "/", I had to logout (cause I was using local Administrator) and login with domain Administrator. Reexecuting the Wizard, completion succesful! Using local Administrator cause "Access Denied" error on Wizard. Running * Windows Server 2012 R2 Standard in domain with all updates installed (2014-12-17) * SharePoint 2013

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.