Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Is it possible to make SP2010 run .net 4 and also use the new Razor syntax that is introduced with asp.net mvc3 ?

Larsi

share|improve this question
    
SP2010 will only run in .NET 3.5. –  James Love Feb 18 '11 at 23:48
add comment

2 Answers

up vote 2 down vote accepted

No this is not possible.

share|improve this answer
add comment

Possible for Razor, but a pain. Have to stick to .NET 3.5 though. Find an example here: http://tqcblog.com/2011/01/22/asp-net-mvc-3-razor-views-in-sharepoint/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.