Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I know about regional settings and that it is present for each site collection under site settings.

Is there any way to check the language in which SharePoint was installed?

We are getting some errors in ULS with eng-US resource file not found. Is it likely that the cause of this is SharePoint being installed in another language (say en-gb)?

Which language resource does the SharePoint server lookup for? Is it the PC language or the SharePoint installation language?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

a simpler and safer method than messing with the registry would be

central admin -> upgrade and migration -> Check product and patch installation status.

you will see a whole list on installs and the language like

Microsoft SharePoint Portal English Language Pack

english langauge is 1033 regardless of it being us or uk (1033), also in 12/14/15 hive youll see 1033 folder and any other number relating to other languages :).

to your question:

sharepoint looks in hive files under:

2007

c:\program files\common files\microsoft shared\web server extensions\12\resources

2010

c:\program files\common files\microsoft shared\web server extensions\14\resources

2013

c:\program files\common files\microsoft shared\web server extensions\15\resources

1033 is for english as noted... doesnt matter if its uk or usa but in the resoures files it would be under en-us as its an american product ;) ..... also you need to check what your SQL database server is setup as (uk or us) as the conflict could be happning there!?

could you post the full error in your question?

EDIT

following on from the error you posted:

C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\Template\Features\MyWebPart_MyPart WebPart\Resources\Resources.en-US.resx

you have a custom webpart called MyWebPart_MyPart?

if you do than you need to open it up in visual studios and it should contain some resource files (resex). It looks like it hasnt been deployed during the wsp deployment to:

C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\Template\Features\MyWebPart_MyPart WebPart\Resources

to make sure goto sharepoint server and goto the location above and look for the file Resources.en-US.resx

if its not there than the webpart that contains the feature is not adding the resource files properly.... either sort it out so that it adds the resource files on deployment or add the files manually.

adding manually goto the webpart project location where the project is stored and look for the resex file... copy them and past them in:

C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\Template\Features\MyWebPart_MyPart WebPart\Resources

or add it again to visual studio:

1.If the SharePoint solution is not already open in Visual Studio, open the solution.

2.In Solution Explorer, open the shortcut menu for the name of a feature under the Features node, and then choose Add Feature Resource.

This step adds a resource file to the feature in the format, ResourceFileName.culture.resx, such as, Feature1.en-US.resx.

3.When the Resource Editor opens in Visual Studio, add resources to the resource file.

http://msdn.microsoft.com/en-us/library/ee231537.aspx

now the key to your error is that its refering to the default resource (fallback file)

To specify default resource files in SharePoint projects that you develop in Visual Studio, choose Invariant Language (Invariant Country) in the culture list of the Add Resource dialog box when you add a resource file.

http://msdn.microsoft.com/en-us/library/ee696750.aspx to do this you do as stated above. This time select Invariant Country rather than englist (US).

so rule of thumb. when creating resource you need two... one is default (no country) which would be resources.resx and the other resources.en-us.resx

see if this works!

if it still complains that you need to add it into the feature.

within visual studio within the project goto feature folder, within the feature folder select the name of the feature... by default its called Feature1... double click and let the page load and then select properties (right hand side).... within the properties tab for the feature you should see 'default resource file', within the box on the right put in the name of the default resource file that you made!

now rebuild and deploy and everything should work!

share|improve this answer
    
    
Please check the link within the above question. It has got the error message of ULS –  variable Apr 11 at 10:42
    
is this one of the error? C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\Template\Features\MyWebPart_MyPart WebPart\Resources\Resources.en-US.resx' –  ali Sharepoint Apr 11 at 10:47
    
Yes. sharepoint.stackexchange.com/questions/95898/…. I am trying to resolve this by following:-joost.haneveer.nl/sharepoint/… –  variable Apr 11 at 10:50
    
just ammended my answer! –  ali Sharepoint Apr 11 at 13:43

Look at this post. To check which SharePoint language packs were installed - check registry.

For SharePoint 2010, change 12.0 to 14.0 and for 2013, change it to 15.0.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\WSS\InstalledLanguages\

here you will see something like this:

LCID – Reg_SZ – {language pack build level}

1033 – Reg_SZ – 12.0.4518.1000

1031 – Reg_SZ – 12.0.4518.1000

or

LCID – Reg_SZ – {language pack build level}

1033 – Reg_SZ – 12.0.6219.1000

1031 – Reg_SZ – 12.0.6219.1000

Note: It’s important to have all language packs on the same build level!

To get an overview about all Microsoft LCIDs you can use this article: Local ID (LCID) chart

share|improve this answer
    
Damn, beat me to it. :) –  user19952 Apr 11 at 8:40
    
Where can I see language? Example: Eng-US or Eng-GB? –  variable Apr 11 at 8:55
    

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.