Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When I import a master page in Sharepoint Designer 2010, using the 'Import Files' button (while clicked into the "Master Pages" section, the file is imported, but not to Master pages. It goes instead to "Page layouts" section.

Why is this and what does it mean in terms of managing the site?

Hope someone can help.

NOTE - I have since discovered that by default, all files imported into the master page gallery via Sharepoint Designer are assigned the page content layout type, which means that they will show up in the Page Layouts directory rather than Master Page directory. Best practice for this and a number of other reasons it NOT to import master pages using SPD, but to use the SP UI.

share|improve this question

3 Answers 3

up vote 0 down vote accepted

Another method to avoid this is to go to the MasterPage and Page Layouts gallery in the web UI and upload your files. Tihs way you explicitly set the content type to Master Page and it shouldn't show up as a PageLayout.

share|improve this answer
    
Hi - thank you for your help. This worked, although I was limited to choosing a Publishing Master Page, presumably because I am uploading to a Publishing Portal. –  NCCadm Feb 16 '11 at 16:16
    
The only options you should get there are Publishing Master Page and Publishing Layout. –  James Love Feb 16 '11 at 21:01
    
OK - thank you :) –  NCCadm Feb 17 '11 at 11:26

From my experience its better to use drag and drop method to upload your masterpages, layouts, css and other files supporting the site.

share|improve this answer
    
Hi - thank you for your help. I'm not quite sure exactly what you mean by the drag and drop method, but I think you meant this: I made sure I was viewing master pages and dragged the master page from the desktop to the master page pane. When I did this, it copied it to Page Layouts! (grinds teeth) –  NCCadm Feb 16 '11 at 15:28
    
No, not to the left pane. but the right one with complete list of other masterpages. thats what i usually did. and it never goes to the site pages. if i may know, are you using the latest spd2010 ? are you workin on foundation or server ? cheers. –  user640 Feb 16 '11 at 20:04
    
Hi Sildeyna, I'm using SPD2010 v14.0.5128.5000 (64-bit) with MOSS 2010. I dragged it to the righthand pane with the list of other master pages. Although I have uploaded the master page using the web UI, and therfore have got around this problem, it does worry me that SPD is not working as expected. There are several issues I am experiencing - this is just one of them and I am not sure what the problem is. For example, Preview in Browser is not available for any of the master pages, but it is for other pages. Anyway - thank you for your help. –  NCCadm Feb 17 '11 at 10:47

I also noticed that I needed to upload one page at a time, if I uploaded multiple, it gave me a "failed" message

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.