Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am currently new to the Navigation control that is used for the top nav bar on MOSS publishing sites. The collection is using a top navigation bar that has a series of subsites listed as defined by the navigation link area under site settings. The issue I have is that the parent(root) site always has a few styles defined by a theme. Here is one of the styles.

.ms-topnavselected{
    background-color:#f3bf38 !important;
    background-image:none;
    border-right:solid 1px #ffffff;
    color:#bed3e6;
}

The problem is that only the root, parent site, will remain in this state. If I click to another site available on nav control, this rule isn't enforced. You will get to the site but the parent remains in selected state rather than the site I click on. How can I modify so the site I click on is hghlighted according to style above.

share|improve this question
    
Just to double check, the link you click in the top nav is actually to a different sub-web, not to a view of a list or library within the same site, correct? I have seen this happen when items within the same site were added to the top nav bar and clicked, because, you actually are in the same site. –  Lori Dec 23 '09 at 15:25
add comment

4 Answers 4

So I figured this out and it was pretty trivial but ignorance is bliss. The links across the top nav were set up as headings according to the publishing navigation control that I viewed from the site settings/navigation section. Once I changed the setting to show sub sites the control now showed each site on the top nav in addition to the headers. I deleted the headers and was left with the site links that were working fine and the CSS for the active link was working fine. This now forces me to ask why I would use headers on the top navigation. Maybe I am missing something obvious.

The bottom line is that publishing sites over quite the learning curve for admins coming from the basic collaboration portal set up using WSS 3 navigation.

share|improve this answer
add comment

Have you changed the attribytes of your navigation treeview controls or data source in the master page?

If so what are your settings?

Anders Rask

share|improve this answer
    
I haven't changed anything with the master page settings for the top nav control. The settings are default as far as I am aware. –  Paul Akerlind Dec 23 '09 at 14:21
add comment

When looking at the html, is the css classes being assigned correctly? Or is the parent site the one that had the topnavselected css?

If it's a css issue, then maybe your stylesheet is not being loaded properly on this subsite. Otherwise the sitemapprovider isn't determining that the site you are currently visiting matches item in the top nav. Are the links to the subsites automatically created for your or did you put the link in? If you typed or copied and pasted the link, you might need to make sure that SharePoint knows that you are referring to an internal url. Sometimes you need to modify the url by removing the pages/default.aspx or something similar.

share|improve this answer
    
The top nav bar was originially created with publishing not activated. It was a collaboration site only so the subsites were just one layer as the limitation with the WSS provider. The site links were created through the UI site settings page and each site inherited navigation from the parent. The theme is the same. The style is part of a custom theme that was created. –  Paul Akerlind Dec 23 '09 at 14:25
    
Right, but how did the subsites get added? Did sharepoint do it for you when you created the subsites, or did you do it manually? What about the HTML? Did you check that out? –  Steve Lineberry Dec 24 '09 at 3:58
add comment

My Top Navigation bar is not showing as selected. I am using a url to link to my custom pages in the same site. do you have any idea, why this is not working?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.