SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using SharePoint 2013 online (Office 365). I am following some JSLink tutorial where I am showing indicator icons in columns. It looks like the .js file is working, but when I change the file and check it in, I don't see any changes.

I have created a custom list with a column with choices : Green, Red, Yellow. After this I created a page and added this list as a webpart.

On this webpart I have set a path of my .js file. In this .js file there is some logic where the control is overridden with an icon. I see a broken image. I did some changes in my js file, but I still see the old path of the image. Is there some caching in SharePoint which is using the js file??

This is the tutorial:

share|improve this question

I have fixed this to rename the js file and add it to the masterpage gallery of the root site of the current site collection. I also changed the JSLink path in the properties of the webpart. I hope this caching problem will be fixed in SP online office 365.

share|improve this answer

I had the same issue in my environment. The following DIDN'T work: - Put script in "Style Library" - use (d) tag - CTRL+F5 - InPrivate

The only thing that finally worked --> turn off caching on your network infrastructure device! When the caching on our NetScaler turned off --> everything worked like a charm.

share|improve this answer

Right click on IE and click on "Start In Private browsing". This will make sure to load latest copy of the .js file. Alternatively, you can ctrl-F5 the page. Personally I prefer first approach.

share|improve this answer
I press F5 and watch the source code of the page. I see the following registration of the js file: /sites/teams/_catalogs/masterpage/projectdashboard.js?ctag=102$$16.0.2607.1216. It looks like there is some querystring which is opening some old verstion. I open this file and see the old js content. I already try cntrl-F5 in firefox. It didnt help. – Ola Mar 3 '14 at 11:50
If you have IE you can try "Start In Private browsing" as mentioned. Otherwise, you may have to clear the browser cache in Firefox. – Nadeem Yousuf Mar 3 '14 at 11:52
I have try "Start In Private browsing" in FF and IE but it didnt work. Also when I try to access the js file in the browser it download an old version:…. When I open this file in SPdesigner it is the latest version. Im stuck! – Ola Mar 3 '14 at 12:09
Did you check-in the file after you made the changes? – Nadeem Yousuf Mar 3 '14 at 12:17
yes I did. I also explicit check out/check in. What about this post? Someone says I need to add the js file to the style library because this list is not caching. – Ola Mar 3 '14 at 12:21

Another perhaps simpler option is to remove the jslink reference from the web part, save the page and then add it again. This is one of many glitches that result from the poorly engineered SP platform.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.