Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created a custom Coreresultswebpart but it doesn't show the default message when no search results are returned from the users search. The OOB Coreresultswebpart shows a message like: "your search for "hello" didn't returned any results.bla bla try to search"

I am sure that is not beacause of the xslt, because i am using the standard xslt.

share|improve this question

2 Answers 2

You may be sure, but I would still suspect the XSL. There is a line that evaluates a variable in the XSL that determines if there are any results. If there aren't it displays the No Results Template (dvt_1.empty) and the no results variable text.

The XSL injects a bunch of divs and spans. Are you using a custom CSS that may be the root of the issue?

share|improve this answer
    
if you tick the checkbox UseLocationVisualization the original xsl is used, so the xsl is not the problem. No custom css. –  David Mar 1 at 17:18
    
Right, but he's using a custom web part. –  Matthew McDermott Mar 1 at 18:49
    
if you edit the Coreresultswebpart no mather if it is a custom one or the OOB, there is a property that the user can set "use location visualization" and that one resets the xsl to the original. –  David Mar 1 at 19:31

Check the webpart properties, as I believe the Out of the box webparts allow you to specify this text or at least tick a checkbox to enable or disable the display of this "no results" text. Your custom wp may be lacking this.

share|improve this answer
1  
can't find such property.. i thought that showMessages maybe was the property. But no help. –  David Mar 1 at 17:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.