Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I can't figure out how to active custom delegate controls on my SharePoint 2013 site.

  1. I've created two custom delegate controls: SuiteBarBrandingDelegate and SuiteLinksDelegate
  2. I then published them to a .wsp
  3. I copied the .wsp to the server and added the solution to the farm
  4. I then deployed the solution globally in Central Admin

The feature does show on any of the feature screens: farm features, web application features, or site collection features, site features.

Is Hidden is set to false in the feature properties.

When I deploy the solution it appears to only be applied to Central Admin and not any of the site collections, sites, or pages

share|improve this question
1  
Is it "does show" or does not show? What is the scope of the feature? –  Nadeem Yousuf Feb 25 at 13:52
    
The Is Hidden field is set to False, thus it should show, but doesn't. The scope is set to web. –  mp42871 Feb 25 at 13:54
    
Central admin shows that the feature has been deployed globally to all the servers in the farm, I just can't activate the features because it doesn't show up anywhere. –  mp42871 Feb 25 at 13:57
    
Use this PowerShell and replace the id with your feature ID. Check if it returns the feature: Get-SPFeature –Limit ALL | Where-Object {$_.Scope –eq "WEB" -and $_.Id -eq "00bfea71-1e1d-4562-b56a-f05371bb0115"} –  Nadeem Yousuf Feb 25 at 14:08
    
It returns the feature –  mp42871 Feb 25 at 17:46

2 Answers 2

Since the below powershell did not return any results:

Get-SPFeature –Limit ALL | Where-Object {$_.Scope –eq "WEB" -and $_.Id -eq "FEATUREID"}

The most likely cause is that the feature is not present in the package. To add feature to the package, click on Package and move the feature from Items in Solution to Items in Package towards the right.

share|improve this answer
    
I stand corrected, it returned the feature. I was using the wrong ID. –  mp42871 Feb 25 at 14:20
    
The items were already in the feature. –  mp42871 Feb 25 at 14:27
    
It still doesn't show anywhere –  mp42871 Feb 25 at 16:49
    
Few things I would do in this case: first since the scope is web stop looking for the feature in other place like web application, site collection etc concentrate on site features only. Second, check the title of the feature in the solution and look for it in site features. Normally it should be visible since it is not hidden in the solution. If it is still not visible and PS shows it then it may be environment issue. Finally, I may try to activate the feature using PowerShell to see if activates properly and the functionality it provides is working. –  Nadeem Yousuf Feb 26 at 5:54
up vote 0 down vote accepted

I ended up editing the feature properties and then changing the feature to be a farm feature and then deployed via PowerShell.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.