Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have SP webpart for importing budget items in SP List. For some 4000 items it tooks about 3-4 minutes (it do some custom checking, parsing and importing) to import that (on my dev pc). But if I start that import on my production test server he start to import, it manage to import about 2000 items in list(in about 2 minutes), and than unexpected exception occur. Log say "System.Web.HttpException: Request timed out." I looked to IIS setting to compare setting(app pool,web application) between my pc and server. They are same. Then I looked in web.config to check executiontimeout. Web.config said:

  <httpRuntime maxRequestLength="2097151" executionTimeout="3600" />

which should be more than enough (2GB, and 60 minutes). Please any suggestion why webpart goes to timeout, when he is able to connect to SP, to read input files, to insert half of records in list?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

There is a web.config in the Layouts folder in the SharePoint Root, change the timeout on this if you need to, too.

Also: This seems to be a great help when debugging, saves you from rushing in a panic to step through code before the worker process bails on you.

share|improve this answer
    
This is answer. I changed connection timeout as Tobi said but this didn't helped. Then I modify web.config from Layouts, in the way that I increased timeout value, and defined maxrequest value which wasn't specified. Despite that, I do code refactoring (putted dictionary instead foreach loop). Now everything is much faster, but thanx anyway! –  trip Feb 2 '11 at 8:10
    
Whoa, this is old. For future readers: to avoid the "Panic before w3wp bails", go to IIS, find your App Pool, and set "Ping Enabled" to False - this will prevent timing out when debugging. –  James Love Sep 26 at 7:38

Check the settings for Request timeout in IIS:

IIS Manager -> Properties of Web Site -> Tab Web Site -> Connection timeout

There are multiple configurations where you can set the timeout and this is just one of them.

share|improve this answer
    
As it seems for now all relevant setting related to IIS, on my pc and server are same. I even increase few numbers on server but with no help. –  trip Jan 31 '11 at 15:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.