Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I knew from previous experience that many SharePoint sites had a section under Site Settings > Look and Feel labeled "Master Page"... however I could not find this section.

Look and Feel - Master Page

There were tutorials online about specific URLs to go to, but I couldn't find any particular one that worked -- after figuring out the correct URL to follow, I was simply getting a blank page.

share|improve this question
1  
Do you have publishing features enabled? –  Robert Lindgren Jan 31 at 17:15
add comment

2 Answers

up vote 4 down vote accepted
  1. Inside the current site's Site Settings, navigate to Site Collection Administration > Site Collection Features.
  2. Activate SharePoint Server Publishing Infastructure if it's available... if it's not, you may be using SharePoint Foundation. "SharePoint Server Publishing Infastructure" setting shown after it's been activated.
  3. Navigate to Site Actions > Manage Site Features, and activate the same feature (which should now be visible.
  4. Return to Site Settings. Under Look and Feel, "Master page" should now be available.

(This is under the assumption the "Server Publishing Infastructure" feature can be enabled in your version of SharePoint.)

share|improve this answer
1  
Be careful turning on Publishing features. Once they're on, you can't turn them off, and there are ramifications to consider when turning them on, like loss of MDS and loss of "save site as template". –  RJ Cuthbertson Jan 31 at 17:46
add comment

Type in the URL ~site/_layouts/ChangeSiteMasterPage.aspx and you should get to the same place.

share|improve this answer
    
I saw this suggestion, but it didn't work -- if Publishing Features aren't enabled, this URL will lead to an empty, white page. :( –  David Is Not Here Feb 3 at 17:17
1  
You need the site collection level publishing infrastructure enabled - but you do not need the site level publishing feature. –  Dave Paylor Feb 3 at 20:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.