Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have SharePoint 2010 set up to sync active directory users and it is working great. I am getting disabled users in the sync though. I have tried what all the blogs say, filter on

userAccountControl bit on equals 2

but to no avail, the disabled users are still syncing. I am at a loss on where to look next. My last resort would be to create a ou/folder in AD and move disabled users there and remove that from the sync connector, but I don't really want to go there.

Any ideas?

share|improve this question
add comment

2 Answers

The link below describes how to remove disabled users.

http://www.bryanporter.com/archive/2010/02/20/excluding-disabled-user-accounts-from-profile-synchronization-in-sharepoint-2010.aspx

share|improve this answer
    
This link leads to a 404...someone have an updated link, or able to put the actual content into an answer? –  Grant Jan 17 '13 at 18:06
add comment

Do you have any other exclusion filters on that same connection? If so, then it is possible that you accidentally added one of them using OR instead of AND. Unfortunately if you look at the filters after they were applied it will not tell you whether they were created using AND or OR. The only thing to do would be to delete the filters and re-add them while making sure that you correctly have AND or OR selected when you add them.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.