Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am testing a colleague's public facing SharePoint site. I am using Safari on a Mac. The site renders fine when I use IE and Firefox on Windows as well as Firefox on a Mac. However when I use Safari on the Mac, most of the time Safari times-out or freezes while loading items on the page. Not always, but often. It also times-out on different items, which I can see in Safari's activity log.

The site uses some standard calls to jQuery leveraging animation. Has anyone seen these issues?

I am using Mac OS X Version 10.6.2 and Safari Version 4.0.4 (6532.21.10)

share|improve this question
    
The site is actually mine and we're trying to test out the jQuery Library for SharePoint Web Services (spservices.codeplex.com) stuff with Safari on the Mac. We are seeing some spottiness that we were hoping others may have seen and have some insights on. If anyone else wants to take a look, the Demo site here sympraxisconsulting.com/demos is where we're trying this. It's hosted WSS at FPWeb.net, and I expect that they have all Service Packs installed, though I will check on that. –  Marc D Anderson Dec 18 '09 at 15:56

6 Answers 6

This has been an on-again, off-again issue for Safari on Mac for years. Integrated Windows Authentication (IWA) wasn't supported in versions 1 or 2, then it worked on 3 (with occasional minor releases breaking it)..things started looking good again when 4 came out, but once again 4.05 is broken again in this regard.

So frustrating.

share|improve this answer

We had this problem. Access to our intranet from off-campus is only via https/ssl. In this way, we were able to enable "basic auth" since the site is encrypted.

Oddly, this issue is not manifest in Safari 4.0.2, but is in 4.0.5

Thanks, Apple...

share|improve this answer

I have noticed considerable differences in rendering speed for Javascript from SharePoint pages (not jQuery Javascript).

Based on that would expect that there is an issue rendering the javascript not getting the data back from the server.

share|improve this answer

FWIW, the first demo page I tried took an age to load via Google Chrome - maybe there is an incompatibility between the SP Service jQuery library and webkit?

share|improve this answer
    
I've been noticing some slowness yesterday and today, so I don't think it's Chrome. I've tested the jQuery stuff with IE, Firefox, Chrome, and Safari. –  Marc D Anderson Jan 25 '10 at 16:54

FPWeb.net hosted SharePoint is unlikely to be configured for NTLM or Kerberos authentication. I think it uses Basic.

share|improve this answer

"most of the time Safari times-out or freezes while loading items on the page. Not always, but often. It also times-out on different items"

what do you mean by "items"?

I wonder if it could be an authentication-related issue. Is the web application setup to use Integrated Windows Authentication? I suspect Safari on Mac does not support this.

If this is indeed the problem then you should be able to get around this by enabling Basic Authentication (with SSL) or configuring Forms Based Authentication.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.