Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Is there a way to disable Excel Web Access (_layouts/xlviewer.aspx) completely on a Site Collection? (SP2010 Enterprise)

I have enabled the "Open in Client Applications" feature and it works fine in Internet Explorer and Firefox if a 32-Bit Excel is installed. But on Machines that use Chrome or 64-Bit Excel, SharePoint still tries to use the Excel Web Access (supposedly because it cannot detect Excel?)

So I would like those clients just to download the File (similar to Send To - Download a copy) when they click on it.

I do want to keep Excel Services enabled as the Web Parts are useful, just the Excel Web Access is undesirable)

Any suggestions?

share|improve this question

3 Answers 3

Have you checked this documentation: Configure the default open behavior for browser-enabled documents (Office Web Apps)

You can either disable the Excel Services Application for all site collection in the central administration (Service Applications under APplication Managemend) , or you can disable the Web Access via Feature/Powershell explained in the above article.

share|improve this answer
    
The Problem is that SharePoint simply ignores the setting. The Caveat is this: "Open in the client application (if available)". In Chrome or with 64-Bit Office, SharePoint believes that there is no Client Application available and opens it in the browser :( I don't want to disable the Excel Service App as we use the Web Parts, just for Document Libraries we don't want it. –  Michael Stum Jan 25 '11 at 23:21
    
You said 64bit Office - only if you want to use Excel files larger than 2GB you need 64bit Office - do NOT install otherwise, especially in a Sharepoint environment (MS recommends you to NOT install it). Back to the real problem: When I use Chrome and have "Open in Client Application" option set in a document library, the document is downloaded instead of opened with web apps. Did you try all of the methods in the MSDN article (e.g. powershell - for PS also check out this script sharemuch.com/2010/09/28/…)? –  Dennis G Jan 26 '11 at 8:41

Not sure if you've tried it or someone suggested, but you can set the Browser Handling in your web app to strict.

This will prompt files to be downladed and not display in browser.

share|improve this answer

I was able to work around this issue by removing the file mapping for xlsx files in serverfilesExcelServer.xml file in the hive ([Program Files]\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\XML):

<?xml version="1.0" encoding="utf-8" ?>
<!– Copyright (c) Microsoft Corporation. All rights reserved. –>
<ServerFiles> 
    <!–<Mapping FileExtension="xlsx" RedirectUrlTemplate="/_layouts/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate="/_layouts/xlviewer.aspx?new=1"/> –> 
    <Mapping FileExtension="xlsb" RedirectUrlTemplate="/_layouts/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate="/_layouts/xlviewer.aspx?new=1"/> 
    <Mapping FileExtension="xlsm" RedirectUrlTemplate="/_layouts/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate="/_layouts/xlviewer.aspx?new=1"/> 
</ServerFiles>

Reference: http://blog.armgasys.com/?p=133

share|improve this answer

protected by Community Oct 24 '13 at 19:52

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.