Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We are having a problem with an out of the box approval workflow.

Environment:

5 Server Farm (2 wfe, 2 app,1 db) SharePoint 2010 Enterprise. (upgraded from moss enterprise)

Problem

Every time a user approves a document the document shows as last modified by System Account. However the task associated to the workflow it show correctly modified by the user whose approved the document.

What we tried

Double checked the user policies on central admin and all seems to be ok (as recommended)

Tested on other libraries on the site and they all have the same problem.

Tried with various user (site collection admin included) and the problem persist

Deleted workflow and recreated (problem persists)

Deleted Library and recreated (problem persists)

share|improve this question
1  
This sounds like the results of an elevated priviledge issue. IE somewhere it seems to be running an elevated priviledge to perform the task. Not sure if this is by design or if there is something else doing that. Just a thought as I have not seen that before. –  spevilgenius Jan 25 '11 at 17:35
    
Hi, yes it looks like its needing the system account to make the update, however it does it with any user (even site coll admin) where there is no need to elevate. thanks for your comment –  Renzo Jan 26 '11 at 9:42
1  
I have been looking at this issue with Renzo also and we still can't fix a fix. If you run the workflow as a user who has full control permissions everywhere it still stamps the System Account as the modified by. Has anyone seen this issue before? We've tried it on other SharePoint farms and it works as normal. Thanks, Alex –  Anonymous Feb 1 '11 at 10:34
    
I thought this was 'By Design' because behind the scenes there is probably an onTaskUpdated handler in the OOB Approval workflow. That means that it is fired by the asynchronous event ItemUpdated which is run by the AppPool's account (i.e. System Account). –  MBSurf Jun 7 '11 at 18:29
    
it was by design on 2007 SharePoint workflows not on the out of the box ones –  Renzo Jun 8 '11 at 10:15

2 Answers 2

up vote 2 down vote accepted

After further investigation we found that when upgrading a farm from 2007 to 2010 the upgrade recreates the workflows in "legacy" mode.

Workflows work differently in 2010 as we are now able to modify the out of the box one from SharePoint designer.

The fix for us was to delete the workflow and use the new out of the box workflow from SharePoint 2010

hope this helps someone

share|improve this answer

To work around this issue, follow these steps to set the Approval workflow to start manually, and then disable the workflow to update the workflow status:

Browse to the Document Library.

Click the Library tab. In the Settings group, click Workflow Settings.

Click the Approval workflow you created.

Select the Allow this workflow to be manually started by an authenticated user with Edit Item permissions option.

Clear the Start this workflow to approve publishing a major version of an item option.

On the next page, clear the Update the approval status after the workflow is completed (use this workflow to control content approval) option.

Click OK to save the changes.

Above solution should fix the issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.