Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Is there any reason when I create a Web Part Page in publishing site the left navigation is missing? If yes, What is the proper way to create a page that will include the left quick nav?

share|improve this question

3 Answers 3

If you don't want to use javascript/jQuery, here's another way to get the left navigation back in web part pages.

  1. Create a new web part page
  2. Edit the page in SharePoint Designer
  3. Remove custom css

Delete this code block:

<SharePoint:UIVersionedContent ID="WebPartPageHideQLStyles" UIVersion="4" runat="server">
<ContentTemplate>
<style type="text/css">
body #s4-leftpanel {
   display:none;
}
.s4-ca {
   margin-left:0px;
}
</style>
</ContentTemplate>
</SharePoint:UIVersionedContent>
<SharePoint:UIVersionedContent ID="WebPartPageHideQLStyles" UIVersion="4" runat="server">

4.-Remove the overrides for the left column

Remove all three lines:

<asp:Content ContentPlaceHolderId="PlaceHolderPageImage" runat="server"></asp:Content>
<asp:Content ContentPlaceHolderId="PlaceHolderNavSpacer" runat="server"></asp:Content>
<asp:Content ContentPlaceHolderId="PlaceHolderLeftNavBar" runat="server"></asp:Content>

Source: http://techmikael.blogspot.it/2011/08/adding-left-navigation-menu-to-web-part.html

share|improve this answer

If I use following method then I get both web part page and the left navigation.

Go to site actions-->More options-->Publishing Page. I selected "(Welcome Page) Blank Web Part page"

share|improve this answer
    
Well, this is a different thing. You asked for a web part page, now you're using a Publishing Page. –  MdMazzotti Jan 14 '14 at 8:15

In SharePoint 2010, the left nav is inexplicably hidden in web part pages. You can’t just change the page layout for these pages as you can with page layout based pages that are stored in the /pages/ library (via the publishing feature).

<!– Turn on left navigation –>
<script type=”text/javascript”>
$(document).ready(function() {
$(“#s4-leftpanel”).show();
$(“.s4-ca”).css(‘margin-left’, ’155px’);
});
</script>
share|improve this answer
    
Why am I missing the Page Layout option when I edit the page? –  Maria Burton Jan 13 '14 at 16:27
1  
Because it is a webpart page and not a Publishing Page based on a page layout –  Robert Lindgren Jan 13 '14 at 16:35
    
This doesn't seem to work in WSS: <!– Turn on left navigation –> <script type=”text/javascript”> $(document).ready(function() { $(“#s4-leftpanel”).show(); $(“.s4-ca”).css(‘margin-left’, ’155px’); }); </script> –  Carl May 28 at 15:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.