SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

An unexpected error is thrown when a navigation item's target audience is created and/or modified. This is a new problem, as I have been using audience targeting for a while without any problem. I have used IE9 32 and 64-bit browsers, both give the same error.

Any assistance in what may be causing this would be greatly appreciated.

Screenshot of target audience error message

share|improve this question
    
Have you checked the actual error message in the ULS logs? That's where you need to start! – Robert Lindgren Dec 16 '13 at 19:34
    
I tried looking in the "C:\Program files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS" folder. However, there is no "LOGS" folder or log files any any of the folders sub- to "Web Server Extensions". – billyjimjack Dec 16 '13 at 19:41
    
The the log files is configured to be stored somewhere else, does the server have a second hard drive partition? If so, poke atriums for logs on that drive :) – Robert Lindgren Dec 16 '13 at 19:45
    
are you able to fix it? if not whats in the ULS logs?You can run the merge-splogfile command with correlation id will get the log entries from all servers. – Waqas Sarwar MCSE Jan 3 '14 at 16:12
1  
I found that the problem only occurs with Internet Explorer 9. I was able to set the target audience with Internet Explorer 8 and Firefox without any problem. I checked and double-checked the Internet settings on both computers (IE8 vs IE9) and they are both configured the same. So, I have found a "work-around", but still do not know why the problem is occurring. – billyjimjack Jan 9 '14 at 14:17

This is caused by the site not being added to Internet Explorer's local intranet zone for some reason. (are you using https protocol?) Try going to Tools>Internet Options:

  • Select the Security Tab
  • Click Local intranet, then click sites
  • Click Advanced
  • Click add to add the site to the local intranet zone

Doing this resolved this issue for me in Internet Explorer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.