Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have a SP 2010 Publishing Portal. It uses variations.

We've had this running in several environments. Every so often global navigation in one of the subsites will stop inheriting from parent and display all subsites / pages. There is nothing logged in ULS that describes why Navigation is changing.

We are using custom Site Definitions, have included the NavBars elements in the onet.xml file:

<NavBars>
  <NavBar Name="SharePoint Top Navbar" ID="1002"></NavBar>
  ...
</NavBars>

We are also using a custom master page and embedded the navigation bar as such:

<!-- top navigation publishing data source -->
<PublishingNavigation:PortalSiteMapDataSource ID="topSiteMap" runat="server" 
   EnableViewState="false" SiteMapProvider="GlobalNavigation" StartFromCurrentNode="true" 
   StartingNodeOffset="0" ShowStartingNode="false" TrimNonCurrentTypes="Heading"/>

    <!-- top navigation menu (set to use the new Simple Rendering) -->
 <SharePoint:AspMenu ID="TopNavigationMenuV4" EncodeTitle="false" Runat="server"
   EnableViewState="false" DataSourceID="topSiteMap" 
   AccessKey="<%$Resources:wss,navigation_accesskey%>" UseSimpleRendering="true" 
   UseSeparateCss="false" Orientation="Horizontal" StaticDisplayLevels="1" 
   MaximumDynamicDisplayLevels="1" SkipLinkText="" CssClass="s4-tn"></SharePoint:AspMenu>

This seems to be datasource related as the breadcrumbs fail to properly reflect the site hierarchy.

Has anyone experienced this before? Got any pointers?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.