Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a Document Library with Content Type enabled. I have few custom columns. I have not used any Custom content type.By default content type is Document.

Issue is when i add some files i do not get Edit form to set all the field values and the content type gets stored as Folder. I am uploading .docx, .xlsx, .pptx files.

enter image description here

Can anyone help me with this?

enter image description here

The file is a .ppt file but the Content Type is set as Folder. If i download this file and add in a replicated library in some other site collection than also the Content Type remains as Folder.

share|improve this question
    
Could u share screenshot for ur list setting page and the library default view. –  Pushpendra Nov 11 '13 at 11:50
    
@Pushpendra i have updated my question body with the screenshot. –  Ishan Nov 11 '13 at 12:04

1 Answer 1

up vote 1 down vote accepted

There are two possible issues here:

In some documents that are either a 2007 or 2010 format there is an issue with the properties. If you go to file>properties>advanced properties>custom field then you will see an entry called content type id. By removing content type id from custom fields then documents that are loaded in either 2007 or 2010 format will have the correct content type.

The second issue is that some of your documents are created in a version earlier than 2007. Office 2007 is the earliest version of Office that works well with Sharepoint 2010. If you save these files into either 2007 or 2010 version of Office then that will resolve the issue.

share|improve this answer
    
Perfect! That resolved the issue. Many thanks. –  Ishan May 9 at 8:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.