Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a sharepoint 2010 site template. The site template activates a feature that deploys several lists. Some lists need to open the new/edit/display forms in full page mode.

Is there a way to disable the Launch dialog option in declarative way in the schema.xml file?

share|improve this question
add comment

3 Answers 3

The property mentioned by djeeg works if it is set on the list element in your schema.xml:

<List Title="A List Definition"
      ...
      NavigateForFormsPages="TRUE">

This is the equivalent to setting "Launch forms in a dialog" to "No" under advanced list settings. It doesn't show up in the schema, but I've verified that it is still effective.

share|improve this answer
add comment

I dont think there is.

The code property is NavigateForFormsPages

http://msdn.microsoft.com/en-us/library/microsoft.sharepoint.splist.navigateforformspages.aspx

But it doesnt appear on either the list or listinstance schema

http://msdn.microsoft.com/en-us/library/ms415091.aspx

http://msdn.microsoft.com/en-us/library/ms476062.aspx

I did a little test, created a new list, then set the property through the browser, then saved the list as a template. There is a property NavigateForFormsPages exported in the template manifest.xml

<List Name="{DE7BBD17-2A35-434C-B8C4-DEB257F40DB3}" Title="ImportData" Description="" Direction="0" BaseType="1" FeatureId="{00BFEA71-E717-4E80-AA17-D0C71B360101}" SendToLocation="|" ServerTemplate="101" Url="ImportData" VersioningEnabled="TRUE" MajorVersionLimit="0" MajorWithMinorVersionsLimit="0" DisableAttachments="TRUE" NavigateForFormsPages="TRUE" BrowserFileHandling="permissive" Version="4">

But the exported value doesnt match what you set in the UI, it is always TRUE.

Even if you edit the manifest.xml, set the property FALSE, re-package and create a new list, sharepoint still ignores the value.

share|improve this answer
1  
I'm not sure why you don't see the UI respect your list settings, but setting NavigateForFormsPages="TRUE" on the list element in my schema.xml works as expected. Keep in mind that "TRUE" is reflected as "No" in the List's Advanced Settings->Launch Forms as Dialogs page. –  bojolais May 17 '12 at 19:31
    
Visual Studio complains that the attribute does not exist, but setting is as described by bojolais works for me. –  cadrell0 Jun 21 '13 at 20:21
add comment

You can change it with powershell: Have a look if this is what you want. http://get-spscripts.com/2010/10/change-sharepoint-list-settings-using.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.