Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've already installed SQL Server 2012 on my machine. Then I tried to run the SharePoint 2013 Foundation installer but I received the following error before I even reached the splash screen menu:

Invalid license data.  Reinstall is required.

I've already tried the advice from a form posting stating that I should reinstall SQL Server 2012 but that did not work.

This server is a development machine so I would like to keep SQL Server and SharePoint on this 1 machine. What should I do?

share|improve this question

2 Answers 2

up vote 8 down vote accepted

I discovered that the problem comes from the program Microsoft Visual Studio 2010 Shell (Isolated) - ENU that gets installed with SQL Server 2012. After uninstalling that program and then running the SharePoint 2013 installer I am able to see the splash screen.

Microsoft Visual Studio 2010 Shell (Isolated) - ENU

Warning - This will prevent Sql Server Management Studio 2012 from working on that machine.

share|improve this answer
    
I wish I'd run across your post 24 hours of effort or so ago. No matter what I tried, SSMS 2012 kept giving me the license error when I tried to run it. I've gone so far as to manually delete ALL SQL Server related registry keys and program files[ x86] folders. I even run a repair-upgrade of Windows and got nowhere. Uninstalling VS 2010 shell fixed it though. One of these days I'm going to have to calculate all my lost time see how much I actually save or lose relying on MS products. Thanks for sharing!!!! –  rainabba Oct 29 '13 at 20:46
    
I'm glad that I could help. It took me testing out a bunch of solutions that didn't work before I found this solution so I know how you feel. Also, as a new StackOverflow user you want to put what you wrote as a comment to my answer and not as an answer itself. And make sure to upvote good answers. –  skeletank Oct 29 '13 at 21:06
    
This also prevents SQL Server Management Studio 2014 from working...alas I was hoping it wouldn't. You can download the shell here if you've already uninstalled it. –  MikeH Oct 21 at 16:35

A little late, but maybe it will help future users.

Got the same problem on a PC with VS2013, SQL 2012, and Office 2013.

Solved the problem by opening a .sln-file with "Open with" and checked "Always use the selected program".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.