Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I administer a Sharepoint 2007 site. All the following occur for any user, including the farm admin user, so I am assuming this has nothing to do with permissions.

On one document library only, the Name field is missing from the Edit Properties page for each document. Folders are fine. This means that users with permissions to edit or delete from the site are unable to rename documents.

If I navigate to the document library via the UNC path, I can use the Windows UI to rename documents without any problem.

The Name field is implicit in Document Libraries - you can't add or remove it as a column either via Content Type or the Document Library columns.

Any ideas what I can do to allow users of this doc library to be able to rename documents?

share|improve this question
    
Are there any hidden scripts on the page hiding the Name field from being displayed? –  PirateEric Dec 16 '10 at 15:04
    
Any update to that issue? Should we close the question? –  AlexPoint Aug 6 '11 at 8:18
add comment

3 Answers

Download SharePoint Manager 2007 from Codeplex, navigate to your list, and see if the Name field (InternalName=FileLeafRef) has it's ShowInEditForm property set to False. If it does change it to True and save the change by clicking the save icon in the toolbar.

I can't think of another reason why it wouldn't show up.

You can download SPM here: http://spm.codeplex.com/releases/view/22762

share|improve this answer
add comment

i belive your problem is with the appropriate column selection in the view.

Go to your document library / list, modify the current view & make sure you selected the column "Name (linked to document with edit menu)".

Regards, Girish

share|improve this answer
add comment

As a next step in troubleshooting I would export/import that content to another webapplication in which all customizations are turned off. Maybe you can then identify the reason for that behaviour.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.