Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've setup Visual Studio 2013 RC and a Office 365 developer site. I can create an app using Nappa and open it in VS from there. But if I create a Sharepoint hosted app project in VS and point it to the url of my developersite it get stuck on "communicating with sharepoint" for a long while and then asks if I want to set the project in "offline mode", obviously I click "no" and then visual studio hangs.

share|improve this question
1  
Did you ever get any answers to your question? I have the same problem :( Edit: I solved the problem. I made two changes. Not sure which one of them actually was the solution. 1. Changed the url to https://mydomain.sharepoint.com. 2. Added an app catalog to my developer site. This can be done in the SharePoint admin section (mydomain-admin.sharepoint.com) right under the apps section (first option in the right hand menu). I would guess the only real problem was the https protocol but since I didnt try them out one by one I chose to post both as a possible solution. –  Johan Frisell Oct 27 '13 at 9:50
    
Is this a product bug, anyone know? –  James Love Oct 27 '13 at 10:01
    
I am facing same issue. Any solution. I put https:// –  asim nadeem Apr 7 at 15:04

1 Answer 1

up vote 0 down vote accepted

The answer is not obvious. You need to prefix the url of the site with httpS:// and not http://.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.