Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm completely stuck on this issue that keeps reoccuring for my organizations Sharepoint Administrators.

On a Site Page under Site Actions, selecting the option 'Edit in Sharepoint Designer' opens the Site Page in MS Word and then displays a 'Install Sharepoint Designer 2010' popup box.

Sharepoint Designer 2010 is already installed, the option to launch Sharepoint is enabled on the Admin Site. Using IE8 on a 32-bit OS (No option at all for 64-bit IE to open up). Default HTML editor is set to Sharepoint Designer (playing around with these options don't change the result).

Have previously attempted reimaging the machine, running a repair over SP2010 and reset, but the issue keep reoccuring. Has also been reported that this is only happening to a couple of our sites where others were working (same configuration, same computer, same user).

Launching SPD2010 from the start menu then openning the sites that way works fine and is the current workaround for the issue while I investigate.

Anyone able to offer any advice? Have hit a wall with this issue.

share|improve this question

4 Answers 4

I was having a similar issue. I repaired SharePoint Designer as suggested on some sites and then tried to edit the options in SharePoint Designer. No luck.

What finally worked for me was changing the options in IE. Go to Tools->Internet Options and click the "Programs" tab. Under "HTML Editing" Change your default HTML editor to SharePoint Designer.

Hope this helps someone.

share|improve this answer

This is perhaps a long shot, but could you open SharePoint Designer 2010 and go to File > Options > General > Application Options > Configure Editors:

Here you can specify which editor to use for each file extension. Try to make sure that SharePoint Designer is listed and is positioned as the first option.

enter image description here

share|improve this answer

A long shot but have you looked at the configuration found in the docicon.xml file which is found in the SharePoint Root folder (c:\program files\common files\Microsoft shared\web server extensions\xx\templates\xml)

Is there a line that looks like :-

<Mapping Key="FrontPage.Editor.Document" Value="ichtmfp.gif" EditText="Microsoft SharePoint Designer" OpenControl="SharePoint.OpenDocuments"/>

and also check

<Mapping Key="aspx" Value="ichtm.gif" EditText="Microsoft SharePoint Designer" OpenControl="SharePoint.OpenDocuments"/>

See if the lines looks above.

Cheers Simon

share|improve this answer

This happened to me the morning after Windows updates ran and this was my fix.

  1. Verify that SharePoint Designer is still installed locally.
  2. Verify that you can still open Designer correctly on other sites.

1 & 2 were true for me so if they're true for you as well this should work.

  1. Close or ignore the certification window & the word doc that opens.
  2. Close all Office items & run the suggested SharePoint Designer install as "Repair".
  3. Once the install is complete immediately close any/all remaining windows and restart your machine from the start menu.

Once I completed this I was able to edit with SharePoint Designer on the site in question. I've had no residual issues since.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.