Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've enabled the Custom Site Collection Help feature in my Sharepoint 2010 install, and verified that it works by creating a Help Collection folder and uploading some html files as Help Topics.

The problem is that the search box at the top of the help windows doesn't work - it just gives me a message of "Search Service Not Found.". It looks like this only occurs when I have the custom site collection selected in the search scopes drop-down, as when I select one of the default Sharepoint search collections, such as "Sharepoint Server 2010", I can search and find results. I've reset the search index, done a full crawl and can search for and find help content from the main site search page (using the All Content scope), but still get the "Search Service not found" result.

Has anybody else come across this problem and found a way resolve it? Is there another service hidden away somewhere that I have to enable?

share|improve this question
    
My current understanding is that this is a bug (acknowledged by MS) in Sharepoint. –  Stark Apr 5 '11 at 9:23

3 Answers 3

This worked for me. http://stackoverflow.com/questions/4323662/how-to-enable-search-for-custom-site-collection-help

Start SharePoint Foundation Help Search Then in CA _admin/CNTDBADM.aspx, Go to the content database that holds the site collection and under "Search Server" select the server where you turned the help on.

share|improve this answer

I might have the solution, depending on your installation/configuration:

I found out that on my SP2010 Server installation the "SharePoint Server Search" service was started but the "SharePoint Foundation Search" service was not. Since the "SharePoint Foundation Search" service is responable for searching the help content, it might be the missing piece in that puzzle.

Let me know if that helps!

See also: http://www.sharepointoverflow.com/questions/3324/do-you-need-foundation-help-search-on-a-sharepoint-server-moss-implementation

share|improve this answer
    
We've just recently tried enabling this service, and it didn't seem to have the desired effect. One of my collegues is currently investigating whether there is any further configuration or setup required for this. –  Stark Jan 14 '11 at 15:46
up vote 0 down vote accepted

Actually, I received an answer on stackoverflow that solved this problem. After enabling the "Sharepoint Foundation Search" another step was necessary to associate the content databases covering the help content with the help service. The answer and a better explanation are here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.