Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

SYMPTOM

Created new Word and Excel docs in a SharePoint 2013 Online library. When I attempt to "Edit in Excel" from IE9 to open the file in my Excel 2010 desktop client, I only get a "The webpage cannot be displayed" message with the following in the address bar:

ms-excel:ofv|u|https://xyz.sharepoint.com/Shared Documents/xyz.xlsx

Analogous results are obtained when attempting to open the Word doc in the Word 2010 Win7 client:

ms-word:ofe|u|https://xyz.sharepoint.com/Shared Documents/xyz.docx

THE SYMPTOMATIC STACK

  • SharePoint 2013 Online Plan 2
  • Windows 7 SP1, 64-bit IE 9.0.18 (KB2846071), 32-bit
  • Office Standard 2010 (14.0.6029.1000)
  • Also installed:
    • Project Professional 2010 (14.0.6029.1000)
    • Visio Premium (14.0.6029.1000)
    • SharePoint Designer 2013 (15.0.4517.1005)

THE PROBABLE PROBLEM

I was already installing SharePoint Designer 2013 when I first tried to open one of the Excel file in the 2010 desktop client. I had already edited the file in the 2013 desktop client of another computer with no problems and wasn't aware that the process differing with the differing client version. I was prompted to allow my Office 2010 installation be prepared to handle the file. Since I didn't want two installation / configuration processes running on the (possibly) the same tool suite simultaneously in case of conflict, I declined. I assumed I would be prompted again, but I have not.

WHAT I'VE ALREADY TRIED

  • I've tried other browsers on the same Win7 machine.
  • I've had successful results on other machines with the same OS, browser, and Office Standard 2010, on the same network. Thus, it's not a firewall or other network issue.
  • I've cleared caches and deleted cookies said browsers.
  • I've deleted the contents of this folder: C:\Users[username]\AppData\Local\Microsoft\Office\14.0\OfficeFileCache
  • I've configured SP to force opening docs in desktop client, hoping that would trigger a config reset. My results did not change and the config change has been reverted.
  • Per the advice at http://blogs.technet.com/b/raymond_ris/archive/2013/04/04/cannot-open-or-create-word-documents-in-sharepoint-2013-with-office-2010-and-project-2013.aspx, I've disabled Office 2010's SharePoint Foundation Support then run Repair on Office 2010. After the repair, Office 2010's SharePoint Foundation Support was enabled. Results have not changed.
  • I've opened Office templates directly from the Office website, confirming that, at least in some cases, I can open Office documents from IE9. (Success seemed haphazard.)

UPDATE

I've now uninstalled SharePoint Designer 2013 and my attempt to open the Word doc results in the following message: "Sorry, but to open this document, your computer must be running a supported version of Microsoft Word and a browser that supports opening files directly from Office Web Apps."

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

With SharePoint Designer 2013 uninstalled, I repeated the aforementioned process of disabling Office 2010's SharePoint Foundation Support and then running Repair on Office 2010. After the repair, SP-created/stored Word and Excel documents are opening smoothly in 2010 desktop clients from IE9.

So, it would appear that the problem for Office 2010 is having SharePoint Designer 2013 uninstalled.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.