Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Situation:

I have a document library with a few site collection specific extra columns. Uploaded msg files present the dialog with the Open button when clicked.

enter image description here

I save the document library as a template and it is available as a solution.

I add a few other lists to the site and save the whole site as a template, which is also available as a solution.

When I create a site from that site template and upload a few emails (.msg) files to the document library, the Open button does NOT appear.

enter image description here

I then created a new document library from the library template mentioned above. Emails uploaded to that library show the Open button just fine.

I've been through all the GUI settings of the two document libraries with a fine tooth comb. I cannot see any difference between them.

Does anyone have an idea what could be causing the difference? Obviously, the Mime type is registered. I can reproduce this behaviour with other sites created from the site template.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

OK, I found the answer in this Technet thread

It seems that the Web Application's Browser File Handling setting that are set to "permissive" get reset to "strict" for a site that is created from a template other than an OOB site template.

The workaround involves running some Powershell to set the library's permissions back to "permissive"

Credit to Craig Lussier

#Get Web
$web = Get-SPWeb "http://yourspweburl"

#Get Document Library
$docLib = $web.lists["Your Document Library Title"]

#View all properties/methods of the Document Library and you'll see that BrowserFileHandling is a property
$docLib | Get-Member 

#See the current BrowserFileHandling setting for the Document Library
$docLib.BrowserFileHandling

#If you need to change it from Strict to Permissive
$docLib.BrowserFileHandling = "Permissive"
$docLib.Update()
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.