Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've followed the steps found across the web for enabling anonymous access to a SharePoint 2010 instance. For the most part, it works as expected. However, when I click on a blog entry on a site created using the blog template, I'm prompted for user credentials. This happens when I try to click on an entry or the comments link on the blog homepage.

Is there anything special I need to do to get anonymous access for a blog site in SharePoint 2010?

Edit: Steps I've followed - http://social.technet.microsoft.com/Forums/en-US/sharepointsocialcomputing/thread/e4eefc4f-d0f1-43fb-bc2f-4b32fc98d320

share|improve this question

3 Answers 3

up vote 2 down vote accepted

I discovered what was going on. With the configuration I had, the main site was a publishing web. The blog site was a sub-site from the publishing web. The fact that the publishing web was enabled led to permissions problems for the blog site. What I ended up doing was creating a new site collection that only has the blog site within it. Setting up anonymous access within the new site worked just fine.

The feature turned on by default with publishing sites is called Lockdown Mode in SharePoint 2010. Turning this off on the publishing site, with my original setup, will also work but leaves you wide open from a security perspective. By separating the blog site we're getting the functionality needed and minimizing the risk. You can learn more about Lockdown Mode here: http://blogs.msdn.com/b/russmax/archive/2010/01/22/lockdown-mode-in-sharepoint-2010.aspx

share|improve this answer

You could try this http://www.sharepointblues.com/2010/12/22/blog-site-in-anonymous-use/ and not having to enable ViewFormPagesLockDown or create your blog site in another site collecion but still have your Blog working by stapling custom security settings to the blog sites created.

share|improve this answer

I too encountered with the same problem.but now it's got solved and working successfully.Thanks for the information.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.