Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am having trouble linking an Access database to a SharePoint list using the Access macro builder (the database is to be published on SharePoint, so I can't use any code). I have created a data macro on a completely unrelated table that performs a few lookups (using the 'Look Up A Record In...' macro action) on SharePoint lists and passes them back as return values to a macro that is responsible for the setup of a form. The lookup works fine with the UserInfo list, but when I try to do a lookup on a list titled 'Employees' (which I linked in the same way as the UserInfo list), I get the error 'Invalid list or query reference "Employees".' After clicking OK, it takes me to a window that shows the error number as 2950. I looked this error up and found nothing helpful. The Access error table also shows the error 3204, which is 'Database already exists'. This also doesn't make any sense to me. I tried removing every reference to this list other than the actual lookup itself, and the error persists, so it must be coming from that macro action, but I selected the table name from the system-populated dropdown in the action setup, so there shouldn't be any spelling issues or anything like that. Does anyone have any ideas as to why this might be happening?

UPDATE: My current thinking on the issue is that it is caused by a problem I found a while back and forgot about. When I open the table that I cannot get data from (in Access) I get the error 'The setting you entered isn't valid for this property.' I have no idea what causes this, as I haven't changed any data and the table opens perfectly in the SharePoint site. I have read that disabling caching may fix this, but I am unable to disable caching as the option is grayed out in the menu. I have tried removing and relinking the list, and even creating a clean database to test the connection, but I still get the error.

On a possibly related note, when I modify the layout of the table, I am prompted to save my changes on close. However, if I click yes, I receive a message informing me that the layout of the table has been changed since the last time I opened it, so I select the option to overwrite the old version. At this point, the table does not close, and when I try to close it, I am once again told that I have changed the layout, even though I supposedly just saved those changes. Again, not certain that this is relevant, but it is a problem and it doesn't seem unlikely that these are all the same issue.

share|improve this question
    
Has noone seen this problem? –  Crash Jul 15 '13 at 14:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.