Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a SharePoint 2013 + Workflow Manager 1.0 installation that is using a "wait for field change" in a workflow.

The workflow that has problems is "waiting for" a checkbox Yes/No field to change to Yes, but when it does change, it just ignores the changes. No errors... it just silently ignores the change

If on the same server I create another workflow but I use the legacy 2010 platform mode, the "wait for field change" on the Yes/No field works fine.

After many tests a friend discovered that in 2013 platform mode (the mode that uses the Workflow Manager 1.0) while it does fail with Yes/No field, it works correctly for numeric fields.

We now believe it might be a localization problem (the English SharePoint 2013 & the Workflow Manager 1.0 are installed on top of a Spanish version of Windows). The Spanish language pack is not installed... and since the legacy 2010 workflow mode works correctly we now are thinking that Workflow Manager 1.0 has some kind of bug when running under Windows that is not in English...

Any one knows how to fix this? Should the language pack fix it? (since we are already beyond the deadline, we do not want to waste time installing the language pack for SharePoint if we are not sure is not going to help...)

(why there is no tag for Workflow Manager? No one here has used it yet? )

Update: We installed the Workflow manager following this instructions: http://technet.microsoft.com/en-us/library/jj906604.aspx, but I am seeing now that the download from here: http://www.microsoft.com/en-us/download/details.aspx?id=35375 is different depending on the language...

We reversed our logic so that we are now waiting for "a checkbox Yes/No field to change to No" (because No is the same in Spanish and in English) but it did not work...

So I guess until someone finds out what is happening we are going to need to avoid checkboxes and use numeric fields (or multiple choice fields)

We do have another server where everything is in english and checkbox waiting seem to be working fine there...

Another Update: We changed the field type from checkbox to choice (and added the choices Yes/No). Then opened the workflow designer... and instead of showing "Yes" as it did when it was a checkbox... or "Yes" since one of the choices is "Yes"... it now shows... "True".

¿What is happening?

share|improve this question
    
I don't have the tools in front of me to check myself, but does the designer require you to explicitly select "Yes" and "No" as the wait to change to values? In code behind (I'm a developer) I kind of recall seeing interesting behavior with these types of fields and you may want to consider trying things like TRUE/FALSE true/false True/False or 0 and 1 if you are able to provide your own value. –  ToddersLegrande Jul 11 '13 at 17:52
    
@ToddersLegrande Yes, the designer requires me to explicitly select "Yes" and "No" as the wait to change to values –  Luxspes Jul 11 '13 at 18:04
    
Ah that's unfortunate then. Nevermind! :) –  ToddersLegrande Jul 11 '13 at 18:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.