Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Trying to create custom search connector with dynamic properties In model.xml define properties this way

<TypeDescriptor IsCollection="true" Name="DocumentRequisites" TypeName="Connector.Entities.DocumentRequisite[], Connector, Version=1.0.0.0, Culture=neutral, PublicKeyToken=321321321321">
    <TypeDescriptors>
        <TypeDescriptor Name="Item" TypeName="Connector.Entities.DocumentRequisite, Connector, Version=1.0.0.0, Culture=neutral, PublicKeyToken=321321321321">
            <Properties>
                <Property Name="Property" Type="System.String">xxxxx</Property>
            </Properties>
            <TypeDescriptors>
                <TypeDescriptor Name="Name" TypeName="System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
                    <Properties>
                        <Property Name="Name" Type="System.String">xxxx</Property>
                    </Properties>
                </TypeDescriptor>
                <TypeDescriptor Name="Value" TypeName="System.Object, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
                    <Properties>
                        <Property Name="Value" Type="System.String">xxxxxx</Property>
                    </Properties>
                </TypeDescriptor>
            </TypeDescriptors>
        </TypeDescriptor>
    </TypeDescriptors>
</TypeDescriptor>

.

  public class DocumentRequisite
  {
    public string Name{get;set;}
    public object Value{get;set;}
  }

Define property group

New-SPEnterpriseSearchMetadataCategory -Name "My Connector" -Propset "1849f92f-daa0-4511-b3a1-fa35e22da8e4" -SearchApplication $fastContentSSA

In INamingContainer retuns this GUID.

After the full crawl, my documents appears in results, but only on basic properties and full-text file index. "My Connector" property set is empty. There is no errors in SharePoint logs.

I'm trying to use this example but there is the same results.

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.