Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created a simple solution (just a new content type for now) that works both on my development machine and test server. However, when I upload it the solution gallery on the live site, it just uploads and the activate popup doesn't appear and is not enabled in the ribbon (I also have to use the edit icon next to the solution to delete it, instead of the ribbon option).

What could prevent this from working, is there a setting somewhere for preventing activation of user solutions? I am a farm administrator as well as the administrator for the site collection. Everything is enable in the user permissions as well. I have tried different settings for the scope of the feature (the solution only has one defined), but it doesn't make a difference which scope is used.

Edit
The solution is a Sandboxed Solution and the Microsoft SharePoint Foundation Sandboxed Code Service is running (on the web and the application server)

Edit 2
When the SharePoint site collection is set to 'Records Center' it fails to activate. However, when it is a 'Document Center' it works.

share|improve this question
    
Is it Sandboxed solution or Farm solution? –  Ashish Patel Nov 17 '10 at 16:17
add comment

1 Answer 1

up vote 2 down vote accepted

This may happen if "Microsoft SharePoint Foundation Sandboxed Code Service " is not running. Please verify from Central Admin if this service is running.

share|improve this answer
    
The service is running, checked that before (although enabled it for both the web and application server, not just the web one) –  Sam Nov 18 '10 at 10:06
    
Have you tried this? social.technet.microsoft.com/Forums/en/sharepoint2010setup/… –  Ashish Patel Nov 18 '10 at 14:26
    
It's not on a domain controller, plus the 'fix' gives users full control of the registry entry HKLM:\System\CurrentControlSet\Control\ComputerName, which is not a very good idea I think –  Sam Nov 22 '10 at 9:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.