SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I created a custom timer job and deployed it into my development farm. The job runs fine. The thins is that after I deployed it to the QA farm. The status of the job says succeeded in central admin, but nothing happens. I added extra logging and nothing is being logged.

I thought it was something with that specific timer job, so I created another timer job that just has an assert and displays a pop up when it runs. Again, it just in the dev farm but not in the QA one. In this case though, the status of the job says Initialized and 0% completed, but no pop up.

I think it has something to do with permissions, but I cannot find what it is. Any toughts??

share|improve this question
Have you tried to debug your timer job? – spevilgenius Nov 16 '10 at 23:42
Yes, I tries, but did not work for me. I installed the remote debugger tools in the server. I ran it, and then connected from my dev machine. The thing is that VS tells me that there is no symbols loaded for the code. I'm doing something wrong here :P – omar Nov 18 '10 at 14:40
Perhaps it's a good idea to add some more logging to your app to see where an exception is (possibly) thrown. Also add some informational logging. You can do this in the eventviewer or in the Sharepoint logs: That way you'll probably be able to find out where the job is quiting. – Jan_V Dec 1 '10 at 17:33

When you deploy to your QA environment have you ensured that you have restarted the timer service on all of your SharePoint boxes? The OWSTimer service will cache DLLs and cause very strange issues when trying to debug and test new timer jobs.

share|improve this answer
Yes, I even restarted the server. – omar Nov 18 '10 at 15:16
up vote 0 down vote accepted

I erased the cache of the server and the job started working again. However each time the I change the schedule of the timer job, I have to clear the cache again.

share|improve this answer
how did you clear the cache? – e.ozmen Jan 18 '13 at 8:57
follow these steps… – omar Jan 18 '13 at 16:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.