Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I just created a brand new https SharePoint 2013 Developer site that uses SSL, and has NTLM windows authentication enabled. It was created using Central Administration, and has no customizations, other than setting up the SSL certificate.

The site displays fine in FireFox and Chrome, but in Internet Explorer 10, I just get a generic blue SharePoint bar across the top, and the rest of the page is blank.

I tried toggling Compatibility mode with no change.

Additional information from the IE 10 Dev tools:

  • Browser Mode: IE10
  • Document Mode: Standards
  • Script Console: "SCRIPT5: Access is denied. start.js, line 1 character 46027"

The script error seems a likely culprit, but I have no idea where it is coming from.

Why won't Internet Explorer 10 display a SharePoint 2013 site?

Edit: This problem only seems to occur when I have specified a host header in the SharePoint web application.

share|improve this question
    
stackoverflow.com/questions/1886547/… looks like it might possibly be related, but as I don't control the SharePoint site contents, I don't see how I can (at least directly) apply the workaround. –  Nathan Jun 19 '13 at 18:28
add comment

2 Answers

It will display your site properly when you will click on compatibility button which is just next to address bar in IE 10.

What happened was, there was some place holder which was taking a lot of top space of page and moving real site to bottom, saying that it happened on SharePoint 2007.

I think there was some issue with our custom master page.

Try these steps out if they help you,

  • Open Internet Explorer and navigate to your SharePoint site.
  • Press the “ALT” key to show the File menu, and click “Tools”.
  • Select “Compatibility View Settings”.
  • In the box type in the URL of your SharePoint site, click “Add”, and “Close”.

Reference

share|improve this answer
    
Toggling compatibility view has no effect. –  Nathan Jun 19 '13 at 18:49
    
I added few steps check if they work out, otherwise is there anyway I can look at your screen, team viewer maybe ? –  Muhammad Raja Jun 19 '13 at 18:51
    
I have verified with the developer tools to ensure that I had tried the site both under Standards mode and Compatibility View mode. Compatibility View simply does not solve this problem. –  Nathan Jun 19 '13 at 18:54
add comment

Adding the site with the full domain name to Internet Explorer's "Trusted Sites" list fixes the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.